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Program License Agreement 
 
IMPORTANT NOTICE: Please read the terms of the following License Agreement carefully. Your use of the product signifies your 
acceptance of the terms of the Agreement. Retain this License Agreement for future reference. 
 
Article 1: License Grant 
 
The software is the intellectual property of Gold Run Partners, Inc., dba TriTools Partners, and its licensors, and is protected by law, 
including United States copyright laws and international treaties. 
TriTools Partners grants to you a license: 
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a single user and not at the same time, for example, office and home computers or desktop and notebook computers used by a 
single user. 
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3. To modify the program and/or merge it into another program of the licensee's own design and making for the licensee's own use 
on a single machine. 
4. To use the program with third party commercial and/or freeware programs which are designed to be used as add-on custom 
command tools exclusively with and by the program and its user interface. Developers of any other third party commercial and/ or 
freeware programs must obtain a separate license from the licensors and must provide certification of that license to the licensee 
upon request. 
5. To transfer the program to another party if that party agrees to accept the terms and conditions of this Agreement, and you do not 
retain any copies of the program, whether in printed, machine readable, modified, or merged form. Except as expressly provided for 
in this license, you may not copy, modify, or transfer this program. 
6. If the software in this package is licensed as a Site License, it is licensed for use on multiple machines. Additional master copies 
of the software may be made by the licensee, equal to the number of licenses purchased. 
No reverse engineering. Except as stated above, YOU MAY NOT MODIFY, TRANSLATE, DISASSEMBLE, OR DECOMPILE THE 
SOFTWARE, OR ANY COPY, IN WHOLE OR PART. 
 
Article 2: Term 
 
The license is effective until terminated. You may terminate the license at any time by destroying the program together with all 
copies, modifications, and merged portions in any form. The license will also terminate upon conditions set forth elsewhere in this 
Agreement, and TriTools Partners may terminate your license if you fail to comply with this Agreement. You agree, upon such 
termination for any reason, to destroy the program together with all copies, modifications, and merged portions in any form. 
 
Article 3: Disclaimer of Warranties and Limitations of Remedies 
 
1. TriTools Partners software is licensed to you As Is. You, the consumer, bear the entire risk relating to the quality and 
performance of the software. In no event will TriTools Partners be liable for direct, indirect, incidental, or consequential damages 
resulting from any defect in the software, even if TriTools Partners had reason to know of the possibility of such damage. If the 
software proves to have defects, you, and not TriTools Partners, assume the cost of any necessary service or repair. In the event 
any liability is imposed on TriTools Partners, TriTools Partners liability to you or any third party shall not exceed the purchase price 
paid for this product. 
2. Thirty-day limited warranty on media, for CD-ROM versions only. TriTools Partners warrants the enclosed disks to be free of 
defects in material and workmanship under normal use for 30 days after purchase. During the 30-day period, you may return a 
defective disk to TriTools Partners with proof of purchase, and it will be replaced without charge, unless the disk is damaged by 
accident or misuse. Replacement of a disk is your sole remedy in the event of a defect. This warranty gives you specific legal rights, 
and you may also have other rights which vary from state to state. 
3. THE LIMITED WARRANTY STATED ABOVE IS THE ONLY WARRANTY OR REPRESENTATION OF ANY KIND WITH 
RESPECT TO THE SOFTWARE MADE BY TRITOOLS PARTNERS OR ANY THIRD PARTY INVOLVED IN THE CREATION, 
PRODUCTION, DELIVERY, OR LICENSING OF THE SOFTWARE. TRITOOLS PARTNERS AND ANY SUCH THIRD PARTY 
DISCLAIM ALL WARRANTIES, EXPRESS OR IMPLIED, WITH RESPECT TO THE SOFTWARE, ITS QUALITY, RELIABILITY OR 
PERFORMANCE; OR ITS MERCHANTABILITY, NON-INFRINGEMENT OF THIRD PARTY RIGHTS, OR FITNESS FOR A 
PARTICULAR PURPOSE. 



 

 

4. Some states do not allow the exclusion or limitation of implied warranties of liability for incidental or consequential damages, so 
the above limitations or exclusions may not apply to you. 

 
Article 4: General 
 

You may not sub-license, assign, or transfer the license or the program except as expressly provided in this 
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C H A P T E R  

1 
INTRODUCTION TO VISUAL CADD™ 

Visual CADD™ is highly productive design and drafting software. Compared to many 

other programs, Visual CADD™ is easier to use, has a shorter learning curve, and is 

faster. But it is also very powerful. 

Whether you are new to CADD or an experienced CADD user, Visual CADD™ will help 

you become super-productive in your work. You will find everything you need to know 

to get started in this manual. 

Installing Visual CADD™  

Visual CADD™ has very modest hardware requirements, as shown in the following 

table, and will perform well on an older computer system. However, a more powerful 

computer and increased memory will always have an impact on the speed that the 

program runs at, increasing your productivity. 

System Requirements 

Component Minimum Recommended 
CPU Pentium Pentium 4 or greater 
Operating System Windows XP Windows 7 or 8 
Memory 1 GB 2 GB or more 
Disk Space 30 GB 40 GB 
Display 800x600 SVGA 1024x768 or greater 
Pointing Device Mouse or digitizer tablet Mouse or digitizer tablet 
CD-ROM 2x Any current CD/DVD 
Web browser Any current browser Any current browser 



 

2 Introduction to Visual CADD™ 

 

A CD-ROM is required only if you install from a Visual CADD CD.  A downloadable 

and fully-functional version of Visual CADD is available and in that case a CD-ROM is 

not required.  A web browser is not required to use Visual CADD, but it is helpful if you 

need to download updates, get on-line help, or participate in user’s forums. 

Preparing for Installation 

Before installing Visual CADD™, check the following: 

Do you have the minimum system requirements? 

If you are upgrading, have you backed up all files that you customized in the previous 

version? These might include menus, toolbars, hatches, scripts or other editable files. 

If the operating system is Win2000 or later, do you have Administrator or Power User 

rights? If not you may not have the necessary permissions to install Visual CADD™ on 

your system. If you are not sure, see your Windows settings and documentation for more 

information, or contact your network administrator. 

Temporarily disable any virus checking software before installing. Some, though not all, 

of the anti-virus programs will treat the install files as a virus and will not allow the 

installation to complete successfully. 

Tip 
We strongly recommend that you close any open programs before beginning the install. 
This will free up additional memory that may be required. 

To install Visual CADD™ from a CD 

Insert the Visual CADD™ disk in your CD-ROM drive and an install screen should 

appear. Click on the [Install Visual CADD™] button and a dialog pops up to begin the 

installation process. Follow the instructions on each screen until the Visual CADD™ 

install is completed. 

On some systems, the install screen might not automatically appear. If nothing happens 

after you insert the CD-ROM, select the Start button, then Run, and in the dialog that 

appears type D:\setup.exe (if D is your CD-ROM drive), then click [OK]. 

Follow the directions on the screen. 

file:///D:/setup.exe
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Install Options 

During the install process a dialog will pop up with several checkboxes that allow you to 

customize and add only a subset of the default install. The choices include sample files 

for drawings, styles, symbols and macros as well as font files, and a thumbnail viewer 

that will show Visual CADD™ drawings in Windows Explorer. Unless you are an 

experienced Visual CADD™ user and know exactly which features you need, we 

recommend that you make no changes on this screen and instead do a default installation. 

You can add the other items at a later time. 

To Start Visual CADD™ 

Click the Start button, then select Programs>Visual CADD 7.0 and then Visual CADD 

7.0 on the flyout menu, or double click the shortcut icon on the desktop if you elected to 

add it during the installation process. 

When you first open the program you will be prompted to input the User ID and keycode 

received when you ordered the software. Entering these codes will register the software. 

Until that happens, the program runs in demo mode and expires 30 days from the date of 

install. We suggest you print out and keep a copy of the ID and keycode with this User 

Guide in case you need to reinstall Visual CADD™ in the future. 

Additional CD Contents 

The CD contains additional software and files that are not part of the Visual CADD™ 

installation. If you purchased a downloadable version of Visual CADD™ without the 

CD, all the software and files are available for download at the TriTools website: 

Symbols - only a small subset of symbols are installed with Visual CADD™. There are 

15,000 symbols on the CD, covering a wide range of disciplines including the 

architecture, mechanical and electrical fields. For information on adding any of these 

symbols to your hard drive, see the file Symbols.txt in the Symbols folder on the CD. 

House plans - almost 300 sample house plans are included in the Visual CADD™ 

drawing file format (vcd). Many also have a bitmap of the same name showing a 

photograph or perspective rendering of the house. 

Adobe Reader 9.0 - install this software to open, view and print Portable Document 

Format files. Use it to check PDF files you have created in Visual CADD™, before 
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sending them to clients or associates. If you are a new user, you will open the Reader to 

view and print the tutorial, as described below. 

Using the Documentation  

The Visual CADD™ documentation set includes: 

The Visual CADD™ User Guide (this document) 

Installed Help file 

Using the Manual 

This manual provides an introduction to Visual CADD™ and basic information on all of 

the Visual CADD™ features. 

The manual is intended as a general reference and introduction to tools and features. For 

complete, detailed step-by-step instruction on each tool, refer to the Help file that is 

opened from the Help menu within the program. 

This manual uses the following typographic conventions: 

 Keyboard keys (Hotkeys) are in SMALLCAPS, (For example: Press ENTER, TAB, SHIFT or 

ESC). 

 Key combinations (more than one Hotkey needed to execute a command) are joined 
by a plus sign, (For example: Press ALT+A means to hold down the ALT key on the 
keyboard while you press the letter A). 

 Buttons and tabs on the screen are enclosed by straight brackets ([]), (For example: 
Click [OK], [Cancel], or [Help]). 

 Visual CADD™ filenames are usually shown in all capital letters (For example: 
MAINSBAR.VCTBR), and sometimes in italics. 

 Pulldown menu instructions are separated by an angle (>), (For example: File>Open 
means to select the File menu and choose the Open menu item). 
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Using Installed Help 

Detailed information about Visual CADD™ is always at your fingertips while working in 

the program. 

To access installed help: 

Choose Help>Visual CADD Help. 

Using Context-Sensitive Help 

Context-sensitive help provides instant information about an item on the screen. You can 

activate context-sensitive help in several ways: 

 Once a command is started, press [F1] to pop up a Help dialog for that command. 

 All speedbars have a help button. Click it and the Help topic for that command will 
appear. 

 In the titlebar of an onscreen dialog, click [Help] to open a help topic screen with a 
description of the features and tools on the dialog. 

 

Tip 
You may choose to assign a Script to the F1 key to run a command or string of 
commands, instead of starting a Help dialog. 

Technical Support  

Tech support for Visual CADD™ is e-mail and Internet based. We will attempt to 

respond to your request as soon as possible. 

Sometimes, a problem can be traced to hardware, or to another software application that 

is interacting with Visual CADD™. Our engineers will supply as much support as 

possible in these cases, but they cannot guarantee to fix the problem or support products 

manufactured or published by another company. 

The more detailed information you can provide, the better chance that your problem will 

be resolved. 
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Technical Support Checklist 

To receive the best response to your questions, complete the following checklist before 

you contact us: 

 Please do not assume that we already know about your problem. It might be a bug that 
has not previously been discovered. A one or two line post usually does not give us 
enough information to resolve your issue. Give us very specific details. 

 Check this User Guide and the Help file thoroughly for possible solutions. Let us 
know what solutions you have tried. 

 Record the exact sequence of events that created the problem. Make sure that you can 
reproduce the problem by following the same series of steps, and describe those steps 
to us. 

 Have the name, version number, and file date of the application. To get the exact 
version number of Visual CADD™, select Help>About Visual CADD. 

 Let us know the type of computer and Windows version you are using. For Print or 
Plot problems, provide the manufacturer and model number of the hardware, the 
version number of the printer driver, and whether it is on a network or standalone. 

 Record the exact wording of any error messages. Some message boxes allow you to 
select the text and use the CTRL+C and CTRL+V key combinations to copy and paste the 
text into another document such as an e-mail message. 

Support Options 

We are committed to trying to solve any problems you are having with Visual CADD™. 

Please post via e-mail and we will answer as quickly as we possible. The best time to 

contact us is between 9 AM and 5 PM Pacific Standard (or Daylight) time, except on 

weekends and US holidays, but we will try to help at other times as well. 

Send e-mail to helpdesk@visualcadd.net. 

Occasionally after you contact us with your initial report we will ask for a drawing file to 

help better understand the problem. Please compress the file(s) with a zip utility and 

upload to helpdesk@visualcadd.net. 

When you reach us via the Web, click on the Support link on the main TriTools page to 

access the support options. There you can link to a user forum, a knowledge base, 

mailto:helpdesk@visualcadd.net
mailto:support@tritools.com
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software patches and other files, links to information for 3rd party developers, and other 

support information. You can go directly to the support pages by typing: 

http://helpdesk.visualcadd.net 

Customer Service 

TriTools Partners offers sales & customer service via the Internet. 

Additional Support 

A public user’s forum for Visual CADD™ can be found at: 

http://tech.groups.yahoo.com/group/visualcadd/messages/ 

You can expect quick answers to your questions. When you join, there are also links to 

valuable websites related to CADD, and files to download for customizing and enhancing 

Visual CADD™. 

The Visual CADD™ Tutorial  

If you are brand new to Visual CADD™, we recommend that you run our tutorial for an 

introduction to the workspace and commands. The tutorial provides five lessons that will 

teach you the basics of Visual CADD™. The lessons are based on the typical process of 

creating, editing, and printing a drawing. The tutorial will not take long to complete and 

will teach you what you need to know to start creating your own drawings. 

In these lessons you will construct a floor plan of an apartment (the illustration on the 

next page shows the completed tutorial drawing). Visual CADD™ is used of course in 

many different industries and applications; the techniques that you learn here can be 

applied to any type of drawing. 

The tutorial.pdf file is located in the Tutorial folder of your installation. The location of 

the folder varies depending on which version of Windows you are using. See the Getting 

Started book of the Help file and the topic Running the Tutorial to find the location. 

Service Contact 
E-mail address sales@tritools.com 

Online store http://www.tritools.com, then click on Purchase 

http://helpdesk.visualcadd.net/
http://tech.groups.yahoo.com/group/visualcadd/messages/
mailto:sales@tritools.com
http://www.tritools.com/
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Use Adobe Reader software to open and print the contents of the PDF file. 

Starting Visual CADD™  

Run the program from the Start menu or a desktop shortcut. The Visual CADD™ 

drawing window contains a menu bar, main toolbar, side toolbar, and status bar. As you 

work, you can zoom in and out as far as you want, because the drawing area has no limits 

or page boundaries. 

Visual CADD™ starts with a blank drawing titled Drawing-1. To work on an existing 

drawing, select File>Open, and then find its folder, or select a recently opened drawing 

file from a list at the bottom of the file menu. 

If you are a new user starting Visual CADD™ for the first time, you might open one of 

the included sample files from the Drawings folder. 

Once you have finished working on a drawing in Visual CADD™ and have saved it, 

select File>Close to close the drawing. When you have completed a work session, select 

File>Exit to leave the program. 

The illustration below shows the workspace and provides details on the most common 

elements of the interface. 
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C H A P T E R  

2 
GETTING STARTED 

This chapter introduces some of the basic concepts of Visual CADD™. If you are an 

experienced user upgrading from an earlier version, you may want to skip this section 

and check out the Help file to see a complete list of the new features. 

If you are migrating from another CADD program - and particularly if you are making 

the move from pencil and paper drafting to CADD - you should read the information in 

this chapter before you start drawing or changing Visual CADD™’s default settings. 

As a first step, we recommend that you run the tutorial described in Chapter 1, and refer 

to the information in this chapter as needed during the process. 

Understanding CADD  

In conventional drafting, you draw objects at a scale different than their actual size 

because paper dictates the size of your drawings. When you draw on paper or film with a 

pencil or pen, you have to place each line or arc or other object precisely at the scale that 

you will print it: for example 1/4”=1’0” or 1:150. 

In Visual CADD™, you always draw at real world scale (1:1), and then specify the 

output scale when you print. 

Computer aided design and drafting (CADD) creates a database of coordinates in two 

dimensions that closely mimics three dimensional reality. 

In conventional drafting you draw each line precisely. In Visual CADD™ you place the 

points necessary to define endpoints, corners, centerpoints, vertices, foci, and control 

points of drawing entities. Visual CADD™ creates the objects from the coordinate 
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information of these points. Place points quickly and precisely by typing the X and Y 

coordinates or more typically by using a method called direct distance entry. 

The coordinate system you choose will have an effect on how and where points are 

placed in your drawing. The coordinate system can be changed as you work so that points 

are placed in reference to the absolute drawing origin, a basepoint you specify, or the last 

point entered, depending on which is most efficient for the type of drawing you are 

creating. 

An Overview of Visual CADD™ Terms  

Some terms might be unfamiliar if you are new to computer aided design and drafting. 

The illustration below will help you understand the basic terms used to describe parts of a 

CADD drawing. Note that some of the familiar terms that you used in conventional 

drafting take on new meaning in the CADD world. 
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For example, in Visual CADD™, the lines you draw are called entities or objects. 

Individual entities can be combined to form symbols, such as a door, a stairway, or a 

table, that can be reused without having to draw each object again. Text is not just a 

group of individual characters, but instead an object that contains settings for properties 

such as font, height, justification, etc., that are applied to the text as you enter it. Hatches 

are not a series of individual lines; they are an object that is typically applied to a closed 

area defined by other objects such as lines, circles, and rectangles. A hatch object has 

predefined properties such as pattern, scale, angle, and color. 

Starting, Saving, and Closing a Drawing  

When you start Visual CADD™, a new drawing opens with the title Drawing-1. Once 

Visual CADD™ is running, you can open another new drawing file or an existing one. 

Save a Visual CADD™ drawing before closing it as you would do in any Windows 

application, or save it with another name to create a new drawing while preserving the 

original drawing file. 
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If you are sharing drawing files with other Visual CADD™ users on a network, you can 

lock Visual CADD™ drawing files so that only one person can make changes to them at 

a time, enabling you to control which drawing is the most recent version. 

You can save one or more backup copies of a drawing at a timed interval you specify, as 

a safeguard in case the original drawing becomes corrupted. Autobackup is turned on by 

default; it can be set on the Utilities>Settings>System2 dialog. A backup is always 

opened as a Read-Only file, so you must save it as a Visual CADD™ .vcd file with 

another name via the SaveAs command to create the new file. 

You can also Autosave drawings while working, at a timed interval you specify. 

To … Do This … 
Start a new drawing Select File>New. 
Open an existing 
drawing 

Select File>Open, find the path and filename, and 
then click [Open]. 

Save a drawing Select File>Save. If you are saving the drawing for 
the first time, type a name and then click [Save]. 

Save a drawing under a 
different name 

Select File>Save As, type a different name, and 
then click the [Save] button on the dialog. 

Lock a drawing for 
version control when 
working on a network 

Select Utilities>Settings>Sytem2 dialog, and under 
the File Management section make sure Use File 
Locking is checked. 

Close a drawing Select File>Close. Visual CADD™ prompts you to 
save the drawing if it is “dirty” - if it has not been 
saved since you last modified it. 

End a Visual CADD™ 
session 

Select File>Exit Visual CADD™. If the file is dirty 
you will get the prompt described above. 

Open a backup drawing 
file 

Select File>Open, in the Files of Type dropdown 
choose “Visual CADD Backup (*.vb*)”, find the 
path and filename, and then click [Open]. 

Using Visual CADD™ to Match Your Working Style  

You can start almost any task in Visual CADD™ at least three different ways. If you are 

new to the program, use a mouse or digitizer puck to choose commands and tools from 

the top level menu. Then right click when a command is running to pop up a context 

sensitive menu with a list of commands and settings pertinent to that tool. 

As you become more familiar with the commands you might start using the buttons on 

the toolbars to run your most frequently used commands. 
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The real power of Visual CADD™ however is with the 2 and 3 letter keyboard shortcuts. 

They will speed up your productivity by reducing the number of mouse moves that are 

needed to run a command from a menu or toolbar. You will see increased production 

every day even if you only memorize the shortcuts for a half dozen or so of your most 

used commands. 

You can assign scripts to the function keys and other keys as well as mouse and digitizer 

buttons to run command sequences. You can create new menus and toolbars, or 

customize the existing ones with commands, options, and tools you use most often. 

Ways of Working in Visual CADD™ 

 

 Use a mouse or digitizer puck to choose a 
command or tool from the top menu. Or right click 
to use context sensitive commands from a popup 
menu after starting a command, as shown at right. 

 Enter 2 and 3 letter keyboard shortcuts for 
commands, tools or options. You do not need to 
press ENTER after the keyboard shortcut to start 
the command. 

 Assign scripts to function keys and mouse and 
digitizer buttons to automate a command or a 
linked series of commands. 

 Use a mouse or digitizer puck to click buttons and select options on the main and side 
toolbars. Most commands start a speedbar, as shown below, where you can further set 
options for how the specific command runs. 

Whether you choose to start a command from a menu, a toolbar, or by entering a 

keyboard shortcut, the status bar at the bottom of the screen displays the command and 

provides you with prompts to guide you through all steps of the task or tool. 

Planning Your Drawing  

There are several considerations to take into account before you start a drawing. Planning 

ahead will help keep you from having to make wholesale changes later. 
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Setting a Measurement System 

In Visual CADD™, you can enter numeric values using fractional feet and inches, 

decimal feet and inches, millimeters, centimeters, meters, kilometers, and miles, as well 

as custom units you may define. Dimensions can contain up to two different 

measurement units. By default Visual CADD™ is set at Decimal Inches when you first 

start the program, but it can be changed at any time from the menu via the 

Utilities>Settings>Numeric dialog. Please see Appendix C for more information on 

entering numbers in Visual CADD™. 

Setting Layers 

In paper drafting, you sometimes key separate drawings to a particular point on each 

sheet of paper and overlay them. In Visual CADD™ you can key all parts of your 

drawing to a single origin point (0,0), or basepoint, or survey monument, enabling you to 

easily draw all parts of a drawing in the same file rather than on separate sheets. You 

could draw all objects on a single layer, but typically you will create different layers for 

related groups of objects (for example: lower floor plan, upper mechanical plan), and 

then display only the layers you want to work with or print. Layers and layer 

management is described in detail in Chapter 4. 

Setting a Scale 

Once you have completed a drawing in Visual CADD™, you can print it on paper or 

film, export it in PDF format, as a print or XML file, or as a graphics file such as BMP or 

JPEG. Whatever the final output, your drawing should be at a scale that legibly conveys 

the information you want to communicate. The most important task is planning the size 

of text and dimensions beforehand so that they are neither too small to read nor too large 

when you print. Chapters 9 and 10 discuss dimensions and text. A bit of experimenting 

with different sizes at your planned output scale(s) will quickly establish standards that 

you will use for printing or exporting drawing files. 

Changing the Coordinate System  

In Visual CADD™, construction points, which have a location, distance, and direction, 

define each entity that you draw. For instance, to draw a 2-point circle, you specify the 

circle’s center and the point at a certain distance from the center (its radius). To draw a 

single line, specify the two endpoints. 
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Where these construction points begin and end when you place them depends on the 

coordinate system that is current in Visual CADD™ at that time. 

Set one of the three coordinate systems as your default, and switch between them as 

needed. 

Overview of the Three Coordinate Systems 

Absolute Coordinates 

All distances are measured along the X and Y 

axis from a fixed origin, with coordinate 0,0 at 

the lower left corner of a new drawing file. 

Basepoint Coordinates 

Distances are measured along the X and Y axis 

from a temporary origin, set with the Set 

Basepoint command on the Manual Entry 

submenu of the Snaps menu. For example, 

when drawing a house far from the true origin, 

you might want to set a corner of the house as 

the basepoint. 

Relative Coordinates 

Distances are measured along the X and Y axis 

from the last point entered. For example, when 

breaking a line a specific distance from its end, 

you might want to set the coordinate system to 

Relative to locate the break a specific distance 

from one end of the line. 

To set the coordinate system: 

From the menu select Snaps>Manual Entry, and then select an option, or, Select 

Utilities>Settings>Constraint and select an option in the Manual Entry section, and then 

click [OK]. 
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Tip 
Change coordinate system options quickly by clicking on the coordinate 
system section of the status bar (second from right) until you see the option 
you want. 
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C H A P T E R  

3 
SETTING UP A DRAWING 

Before beginning to draw, set up Visual CADD™ to help you work most effectively. 

You can change a wide variety of settings: everything from whether scrollbars are dis-

played at the bottom and right side of the screen to the width between the lines of the 

double line tool and whether it will be filled with a solid color. 

This chapter covers the System and Path settings that apply to the overall drawing 

environment, and the General and Numeric settings that are saved with each specific 

drawing but also affect every new drawing file that you open. Later chapters will explore 

settings for text, dimensions, hatches, and other specific object types. 

Visual CADD™ Defaults  

Visual CADD™ ships with default settings that control the coordinate system, units of 

measurement, tool parameters, and other elements of all new drawings you create. You 

can modify any of these to suit your work. 

Initially, you might want to change only the appearance and behavior of Visual 

CADD™'s basic features. For example, you can choose a different default tool, change 

the size and color of the cursor, change the color of the drawing background, and display 

or hide various drawing elements. As you gain more experience working with Visual 

CADD™, you can customize the settings further to match the way you work. 

Some Default Settings 
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The default Visual CADD™ cursor size is set at one 

screen inch, but you can resize it in the Tools section of 

the System1 dialog on the Utilities>Settings menu. For a 

full screen cursor as shown in the illustration at lower 

right, set the size to zero. Run the Save Current 

Environment command (from the Utilities menu) or type 

EN to make this and any other changes “stick” the next 

time you open Visual CADD™. Otherwise the settings 

will revert back to the original. 

By default, line types, line widths, fills, hatches, and 

points are all displayed. You can also set construction and 

handle points to be displayed as shown in the lower left 

illustration. The more items you display, however, the 

longer it takes to redraw the displayed objects. This is 

generally only a problem on older machines or those with 

limited amounts of memory. 

By default, the cursor must be within 0.25 or 1/4 inch of 

an object when you click to select it. You can change the 

search tolerance to a larger or smaller distance in the 

Selection section of the System1 dialog on the 

Utilities>Settings menu. 

 

The Settings Dialog  

Most of the settings in Visual CADD™ are found on the Utilities>Settings dialog. The 

dialog is often called a “tree” dialog because there are a number of dialog screens 

selected from a list (or tree) on the left side. 
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This illustration shows the System1 dialog. Note that some of the settings dialogs are 

Global and affect all drawings that are open. Others include settings that are saved with 

each drawing. All versions of Visual CADD™ have this same mix of global and drawing 

settings. 

System Settings  

The system settings are found on the System1, System2 and Advanced dialogs on the 

Utilities>Settings menu. System settings are global and affect all drawings that are open 

in the current Visual CADD™ session. 

System 1 dialog 

Open the System 1 dialog from the 

Settings item on the Utilities menu 

or by typing TBS. These settings 

change the drawing environment. 

For example, turning off the dis-

play of hatches in the current 

drawing also turns them off in all 

other open drawings, and any new 
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drawing you open, until the setting is toggled back on. 

Tools 

Cursor Size - sets the size, in inches, of the crosshairs of the cursor. For a cursor that 

spans the entire screen, type 0. 

Default Tool Option - sets the active tool in new drawings and the tool that Visual 

CADD™ reverts to after completing most operations. 

Explode Continuous Line - sets Visual CADD™ to draw continuous lines as a series of 

single lines rather than as a single object. When unchecked, lines are drawn as a single 

entity (sometimes also called a polyline). This setting also applies to 2 and 3 point 

Rectangles, Center Regular Polygon, and Irregular Polygon. 

Zoom In/Out options 

Zoom In Factor - sets the multiplier used to change the drawing magnification when the 

Zoom In command is used. The factor for the Zoom Out command is the reciprocal of 

this number. 

Ask for Center Pt - Specifies if Visual CADD™ will prompt you to pick a point on the 

screen before performing any zoom in or zoom out operations. This point becomes the 

center of the new view displayed on the screen. 

Arrow Keys 

World - Sets the real-world incremental distance that each arrow key will advance the 

cursor. 

Screen - Sets the on-screen incremental distance each arrow key will advance the cursor. 

This incremental distance remains the same even when the zoom value changes. 

Display Colors options 

These options set the color of the drawing background, cursor, selected objects, and the 

rubberband line. The Selection color is the Highlight shown when you select an object, 

while the Rubberband color is shown onscreen while moving the cursor in a direction to 

draw or modify (e.g. Move) an object. It disappears when you set a point and complete a 

command. 
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Note: Choosing a background color changes only how the drawing appears on the 

monitor screen. Because Visual CADD™ does not print or plot the background, the out-

put is unaffected. 

Selection options 

These options control the amount of visual feedback you receive on screen as you draw 

or edit. Turning these functions off can reduce the time required to edit large selection 

sets, since highlighting or dragging large groups of objects can take a considerable 

amount of time on older computers. 

Show Drag - specifies if selected objects will visibly drag across the screen during move 

and copy operations. 

Show Highlight - specifies if selected objects are highlighted in the selection color. 

Quick Search - determines if Quick Search is toggled on or off. If toggled on, Visual 

CADD™ will select the nearest object in the database within the current search tolerance. 

Search Tolerance - sets the maximum distance in on-screen inches the cursor may be 

from an object for Visual CADD™ to snap to it or select it. This value also determines 

the size of the aperture tool discussed later in this User Guide. 

Display options 

These options determine whether certain items are displayed on the screen as well as in 

output such as printing to paper or to a PDF file. Turning off the display of some of these 

items while drawing will reduce the visual clutter and increase the speed of redraws 

(especially true with hatches) on older machines. 

Construction Points, Handle Points, Fills, Hatches, and Points - specifies if these 

items are displayed and printed or plotted (checked) or hidden (unchecked). 

Line Type - specifies whether all linetype patterns are displayed and printed or plotted 

(checked) or whether all lines appear as line type 0 Solid (unchecked). 

Line Width - specifies whether all linewidths are displayed and printed or plotted 

(checked) or whether all lines appear as line width 0 (unchecked). 
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Show Scrollbars - when the box is checked the scrollbars are displayed. You can also 

toggle the state of the scrollbars by right-clicking on the top menu bar, the top or side 

toolbars, or on the status bar. If the scrollbars are displayed, you can also turn them off by 

right clicking on a scrollbar. 

System 2 dialog 

Open the System2 dialog from the 

Settings item on the Utilities menu or 

by typing TB2. 

The dialog is shown here with the 

default settings that appear the first 

time you open Visual CADD™. 

Miscellaneous Settings 

Environment Save on Exit - when 

checked, the Save Current 

Environment command is auto-

matically run every time you quit 

Visual CADD™. This means that all 

the settings in the drawing that are 

current when you close the application will be applied to any new drawing that you create 

the next time you open the program. If you have multiple drawings open, the settings 

from the last drawing that is current when you exit Visual CADD™ will apply. 

Alternatively, if you leave the box unchecked, Visual CADD™ will not update the envi-

ronment until you choose to change settings with the Save Current Environment (EN) 

command found on the Utilities menu. Until you do so, the exact same settings will be 

applied to each new drawing, no matter how many times you open and close Visual 

CADD™. 

You should leave the box unchecked if you have a "standard" group of settings that you 

want to appear each time you begin a new drawing in Visual CADD™. 

Shift + Right Button = Popup Menu - by default, Visual CADD™ uses the right mouse 

button to display context sensitive popup menus. By checking this box you free up the 

right button and can then assign another command or routine to it via Assign Script. If 

you want to use the Snap Near Point command, you do not have to assign it via a script; 
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with the box checked it is automatically assigned and activates any time you click the 

right mouse button. 

Hold down the SHIFT key and right click to bring up a popup menu. Alternately, if you 

have a three button mouse and do not assign a command to the middle mouse button via a 

script, that button will activate the popup menus. 

Speedbar Fast Properties - when checked, certain speedbars display an edit box instead 

of a dropdown list - the Properties and Change speedbars for example. This allows you 

to type information into the box from the keyboard instead of having to use the mouse to 

dropdown a list. Using the Tab key to move between the boxes and then typing the 

information directly can greatly speed up your work. If you need to see a dropdown list 

while in this mode, note that you can toggle Fast Properties "on the fly" by right clicking 

in the appropriate speedbar after opening it. 

Mouse Wheel Settings 

Enable Zoom In/Out - checked by default, it allows a mouse with a scroll wheel to 

zoom in/out in Visual CADD™. If you do not want this feature, uncheck the box. 

Zoom Factor - sets the multiplier used to change the drawing magnification when 

zooming in or out with the wheel. The default setting is 1.5; the minimum you can set is 

1.1. 

Reverse the Wheel Direction - the default setting is to roll the wheel forward to zoom 

out and roll it towards you to zoom in. Checking the box reverses this action. 

Use Zoom Previous - by default each zoom in and zoom out with the mouse wheel 

results in a display that is centered on the cursors position in the drawing. When the 

Zoom Previous box is checked, a zoom out with the wheel will zoom to the previous 

zoom of the drawing, as long as the drawing has not already been zoomed out by another 

command. The cursor position is ignored for zoom outs with zoom previous on. When 

there is no previous zoom available or the drawing has been zoomed out with another 

command, the resulting zoom out will be centered on the cursor. 

Enable Panning - checked by default, it allows you to pan with the scroll wheel. Hold 

down the Shift key to pan sideways or the Control key to pan up or down. If the scroll-

bars are turned on, you can pan without using the keys by hovering the mouse pointer 

over the bar and scrolling the wheel. 
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Pan Factor - sets the multiplier for the amount of a pan, as a percentage of 100. For 

example, a setting of 25 will pan 1/4 of the screen. 

Layers 

Use Layer Properties - when checked, objects drawn on each layer take on the 

properties assigned to that layer. Note that in all earlier versions of Visual CADD™ this 

setting was found on the General Settings dialog. It has been moved to this dialog 

because it is a global setting that affects all open drawings. 

Font List Sorting 

In Visual CADD™ you can use TrueType fonts, vector fonts, or a combination of both in 

your drawings. Many people choose to use only vector fonts or only TrueType fonts. 

Because Visual CADD™ allows both, the dropdown list of fonts can be quite long, and 

require a lot of scrolling to find the desired font. 

You can choose several options for how the font list will appear in each of the Visual 

CADD™ dialogs. Check the appropriate radio button to determine the order that fonts 

will be displayed in all font dropdowns in Visual CADD™. Alphabetical displays all 

fonts in order; Vector then TrueType lists vector fonts at the top of the list; and True-Type 

then Vector displays TrueType fonts at the top of the list. 

The Font Manager described later in this guide gives you additional display options. 

File Management 

Use File Locking - when checked, subsequently opened drawings cannot be modified by 

another Visual CADD™ user on your network until the drawing is saved or closed. Other 

users can only open, view, and copy the drawing. 

Auto Backup - when checked, Visual CADD™ will automatically save your work in a 

backup file. Visual CADD™ will not overwrite the current VCD file with new informa-

tion but will save it with a different file extension (.vbk). When this option is checked, all 

open, named drawings in all document windows will be saved in the .vbk format at the 

specified time interval. A drawing that has not been saved cannot be backed up. Only 

drawings that are named and have changes (i.e., entities added, deleted, moved, etc.) will 

be automatically backed up. Named drawings that you open but make no changes to will 

not be backed up. 
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If your .vcd file becomes corrupted or is lost, you can open the backup .vbk file with the 

File Open command. VBK files are opened as Read Only --you cannot modify the 

drawing and save it as a VBK. Instead use the Save As command to save the .vbk as a 

Visual CADD™ file in the .vcd format. 

# of Sequential Backups - by default a single .vbk file is saved when you have Auto 

Backup turned on, saved at the interval you specify in minutes as described below. But 

you can specify up to 10 sequential backups. They are saved in the following order: .vbk, 

.vb1, .vb2, .vb3 etc. through .vb9. 

Auto Save - when checked, all drawings open in the current session will automatically be 

saved at the interval specified. If you have a new drawing that has not yet been saved, the 

File Save dialog will appear at the specified interval. 

Minutes - specifies the interval, in minutes, at which drawings will be automatically 

saved in the .vcd or .vbk formats when the boxes described above are checked. Visual 

CADD™ will not save at the specified interval if a dialog box, such as the Text Editor or 

Assign Script is open, or if a tool is active, until the dialog has been closed or the tool 

operation completed. 

Use Layer Group Properties 

When you create a Layer Group, you have the option of saving the properties that are 

current at the time of creation for the layer, color, linetype, and linewidth with the Group. 

If you check this box, those properties will become current properties when you apply the 

layer group in a drawing. If unchecked, the properties that are now current in your 

drawing apply to any layer group that you open, regardless of whether other properties 

were saved at Group creation. 

Advanced Settings Dialog 

Advanced settings tend to be those 

that are changed once if at all and 

then not thought about again. 

New Drawing Extents - sets the 

zoom for a new drawing. The initial 

view will open to a size for the type 

of drawing you want to create. For 

example, an architect drawing house 
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plans may start at 72' by 48' or a cabinet maker may start at 3' by 4'. The units in the edit 

boxes are the Entry and Display Unit as set on the Numeric dialog (for example; decimal 

feet, fractional inches etc.). 

Recently Opened Files - sets the number of recently opened files shown in the list at the 

bottom of the File menu. Range is 4-16 and the default is 8. 

Drag Density - sets the onscreen appearance of objects as you drag them. Lower values 

(in onscreen inches) mean more dots displayed for greater clarity but slower redraw time. 

Range is 4-64 and the default is 16. 

Text Threshold - sets the zoom level that text is shown onscreen. This setting has an 

entry range 0 to 100. Higher numbers will show text as "greeked" (solid line) as you 

zoom out. Lower numbers will show the individual text characters. 

Advanced Settings List: 

Display Hidden Layer Message - by default Visual CADD™ displays a message when 

you first open a drawing warning if hidden layers exist in the drawing. Uncheck this box 

and the message will not be displayed. 

Show Pack Data Message - by default Visual CADD™ displays a confirmation message 

when you run the Pack Data command, asking if you are sure you want to perform the 

operation. Uncheck this box and the message will not be displayed and the Pack Data 

command will simply execute and complete. 

Show Splash Screen at Startup - by default the splash screen appears for a few seconds 

every time you open the Visual CADD™ program. Uncheck this box and the splash 

screen will not appear at startup. 

Show Spellcheck Completed Message - by default Visual CADD™ displays a message 

after it parses the drawing for misspelled words, alerting you that it has finished. Uncheck 

this box and the message will not be displayed. 

Show "Font Not Found" Message - by default Visual CADD™ displays this message 

when you open a drawing that contains a font that is not found on your system. If you 

share drawings with other users, it is a helpful reminder to obtain the font and install it, so 

that you are looking at the original drawing exactly as the creator intended. Uncheck the 

box and the message will not be displayed. 
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Use Legacy Draw Order- checking this box effectively disables the Draw Order 

commands introduced in version 5 and returns the display order of objects in the drawing 

to that used in version 4 and earlier. The old draw order may be used by some 3rd party 

add-ons, but we recommend most users should keep the new draw order intact. 

Display text onscreen while typing - by default text and leader characters are drawn 

onscreen in real time as you type, as well as in the speedbar at top of screen. If you have 

an older machine or minimal memory, redraw speed may be adversely affected. Uncheck 

this option and a bounding box (with no text) will expand onscreen as you type 

characters. 

Allow Mainsbar property boxes to change selected objects - checked by default, when 

you select one or more objects in the drawing, you can change any or all of the four 

properties for layer, color, linetype, and linewidth by changing the setting in one or more 

of the property dropdown boxes on the mainsbar. To disable this feature, uncheck the 

checkbox. 

Save Auto Backups to subfolder of current drawing's folder - by default a drawing saved 

with the Auto Backup option is saved to the same folder as the VCD file that is being 

backed up. By checking this box, the backup (VBK) file is instead stored in a subfolder 

of the folder where the VCD is stored. If the folder does not exist it is created at the first 

Auto Backup, and is always named \Backups. 

Tracking always toggles Ortho Mode ON - the default behavior of the Track command is 

to always toggle Ortho Mode ON when Track starts, whether or not Ortho Mode was 

previously ON. If you want Ortho Mode to not change when Track is started, uncheck 

this box. 

Restore Defaults - button restores all settings on the Advanced dialog to the default 

settings when you first installed Visual CADD™. 

General Settings  

Unlike the system settings, general settings are stored with each individual drawing file. 

The current general settings will be applied to each new drawing, but they do not affect 

previously saved drawings, as explained below. 
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General dialog 

Open the General dialog from the 

Settings item on the Utilities menu 

or by typing TBG. 

Settings on this dialog are saved 

with a specific drawing. For 

instance, the Double Line Right 

Offset is set at 6 in the illustration 

shown here. If you open an existing 

drawing where the offset is set to 

10, it retains that setting unless you 

change it and save the file with the 

change. The current offset has no 

effect on that existing drawing. 

However, when you start a new 

blank drawing in Visual CADD™, it will always take on the settings that are current on 

the General tab. 

Fillet options 

These options set the fillet radius either during editing (with the Fillet command), or 

while drawing with the double-line tool (LD) when the Auto Fillet option is checked. 

Radius - sets the radius of the fillet. 

Auto Fillet - specifies if corners are filleted automatically when the Double Line tool is 

used. The radius occurs at the interior intersection of each inside corner. 

Preview - specifies if the possible fillet options are displayed as the cursor is moved 

around an intersection or corner during a Fillet command. 

Regular Polygon options 

Settings in this box determine the number of sides and the construction technique used to 

define regular polygons (i.e., from the Draw menu, Polygon Center and Polygon Side). 
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Num sides - sets the number of sides drawn with the center-polygon and side-polygon 

tools. 

Inscribe - specifies if the second point placed with the center-polygon and side-polygon 

tools will correspond to a vertex of the polygon. This is equivalent to inscribing the 

polygon in a 2-point circle. 

Circumscribe - specifies if the second point placed with the center-polygon and side-

polygon tools will correspond to the midpoint of a side of the polygon. This is equivalent 

to circumscribing the polygon around a 2-point circle. 

Offset options 

Lets you set the distance used by the Offset command, and whether the distance is fixed, 

or can be changed by using the mouse. The Offset options can also be changed on the 

speed bar when you are performing an offset. 

Distance - sets the distance from the target object to the offset copy. 

Fixed - specifies that the distance is a fixed number as typed in the Distance edit box. If 

this box is not checked, you can set the distance by placing a point in the drawing area. 

Double Line options 

This section sets the offset distances used by the double line command, and whether the 

space between the lines is filled. 

Left Offset - sets the offset distance of the line to the left of the cursor path. 

Right Offset - sets the offset distance of the line to the right of the cursor path. 

Solid fill - specifies if the space between the double lines is to be filled with a solid color. 

Chamfer options 

These options display the current distance settings used with the Chamfer command. The 

distances are measured from the corner or intersection of two lines and represent the 

endpoints of the diagonal line that will chamfer the intersection when that command is 

chosen. 
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Dist 1 - sets the distance from the corner or intersection to the start of the chamfer on the 

first line selected. 

Dist 2 - sets the distance from the corner or intersection to the start of the chamfer on the 

second line selected. 

Layer options 

Lets you control how Visual CADD™ treats visible layers other than the current layer. 

All Layer Edit - when checked, you can edit all visible objects, regardless of layer. If 

unchecked, you can only edit objects on the current layer. 

Snap All Layers - when checked, you can snap to all visible objects, regardless of layer. 

If unchecked, you can snap only to objects in the current layer. 

Miscellaneous 

Show Aperture - when checked it shows the aperture circle as part of the cursor. If 

unchecked the cursor is displayed as cross-hairs without the circle. The size of the 

aperture circle is set in the Search Tolerance editbox on the System1 settings dialog. 

File Compression and Encryption 

Use Compression to reduce drawing size - when checked it adds compression when 

you save the drawing to reduce the size of the file. Please note that using this feature 

means that compressed files will only open in Visual CADD™ 6 and later. Earlier 

versions do not support and will not be able to open a compressed file. 

Password required to open drawing - when checked, you are prompted to supply a 

password when saving the drawing. A second edit box pops up asking you to retype the 

password. After saving, the drawing cannot be opened without the password. Please note 

that using this feature means that password protected files will only open in Visual 

CADD™ 6 and later. Earlier versions do not support and will not be able to open a 

password protected file. 

Password - the password is case sensitive. A password must be between 1 and 32 

characters long. Any character value except zero is valid. 
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Tip 

Changes made to the General (and Numeric) dialogs will be saved with an 
existing drawing when you save that drawing file. These changes will not apply 
to a new drawing that you open in the next session of Visual CADD™ unless 
you run the Save Current Environment (EN) command to update the 
environment, or close Visual CADD™ with the Environment Save on Exit box 
checked on the System2 dialog. 

Numeric Settings  

Settings on the Numeric dialog relate to the display of numbers in a drawing. There are 

two distinct settings categories. Numeric Dimension settings affect the number format of 

dimensions you create. Numeric Display settings affect the number format displayed on 

the status bar and used in direct-distance entry. 

Numeric settings are drawing specific and are saved with each drawing. As with the 

General settings dialog, the current numeric settings will be applied to a new drawing you 

open in Visual CADD™. 

Numeric dialog 

Click on Settings in the Utilities 

menu to open the dialog, then 

click on Numeric in the settings 

tree. Settings common to both 

Dimension and Display are 

described first: 

Decimal Places - sets the number 

of digits to show to the right of the 

decimal in both distances and 

angles. Valid range is 0 to 8. 

Fractional Value - sets the 

smallest fractional value permitted 

in the display when using a 

fractional format. The range is 1/2 to 1/64. 

Angular Format - sets the format for displaying angles as decimal degrees or 

degree:minutes:seconds. If decimal degrees format is used, the number of decimal places 

displayed is determined by the Decimal Places setting above. 
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Leading Zeros - when checked, total values less than one are displayed with a zero 

preceding the decimal point, or before the fraction if Fractional Units format is on. For 

example, if Leading Zeros is checked, .75 meters would be displayed as 0.75 m, and 3/4 

inch would be displayed as 0 3/4", or 0’ 0 3/4" if units are in feet and inches. 

Show Units - specifies if the abbreviation for the unit type is displayed after the number. 

Note: If units are Feet and Inches, then units are displayed regardless of this setting. 

Dash - (dimension only) when checked, displays a dash between feet and inches when 

dimensions are placed using the feet and inches unit. 

Single Unit Fraction - (dimension only) determines if fractions will display as single or 

multiple characters. If checked, fractions within dimensions will display as single units, 

i.e., ¼ rather than 1/4. This setting is only available when using Vector fonts and only 

with dimensions (not with text or leaders). 

Dimension Unit - (dimension only) sets the primary unit of measurement in which 

dimensions are displayed in the drawing. 

Secondary Unit - (dimension only) sets an optional secondary unit of measurement in 

which dimensions are displayed in dual units. For example, if you set Dimension Unit to 

inches and Secondary Unit to Millimeters, placing a dimension will show the millimeter 

dimension text in parenthesis, directly following the inches dimension text. Tick the 

Show checkbox to display the secondary dimension. 

Entry & Display Unit - (display only) sets the unit of measurement used in the status bar 

display, in direct-distance entry, and in certain other dialogs. 

Base Angle - by default Visual CADD™ has a coordinate system where 3 o'clock is set 

as 0 and runs counterclockwise. For example if you start and then draw a line constrained 

by Ortho Mode to the right, the status bar will report the angle at 0 degrees. If you draw a 

constrained line toward the top of the screen it will report the angle as 90 degrees. 

You may change the base angle and save it with a drawing. Status bar prompts will 

update to show the new coordinates dependent on the base angle you set. For example, if 

you specify 12 o’clock, and tick the Clockwise check box, you will emulate a compass, 

with 0 degrees as North and positive values entered clockwise, so that a line drawn to the 

right will read as 90 degrees. 
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To use a custom angle, choose the option from the Base Angle dropdown list and type the 

angle as the number of degrees measured from the 3 o’clock Visual CADD™ default. 

See the Help topic Polar Coordinates for an overview of entering points in Visual 

CADD™. 
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C H A P T E R  

4 
ORGANIZING YOUR DRAWING 

When drafting with pencil or pen on paper or mylar, complex projects benefit from the 

use of overlay drafting systems. Different building elements can be separated easily by 

combining the overlay sheets. For example, you can stack different plans -foundation, 

first floor, framing, plumbing-- to determine how elements line up with each other. And 

to prepare a cohesive set of drawings, complex projects sometimes require a large team 

of drafters, all whom must use the same drawing conventions-from line weights to 

symbols to annotation. 

The more complex the drawing, the more you benefit by using Visual CADD™’s 

organizing tools: Layers, Properties, and Styles. Used individually or together, they can 

speed the setup, editing, redraw, and printing of even the most complex drawings. 

Create portions of a drawing on different layers to separate the drawing into logical 

categories. Use layer groups to display or hide certain layers and to print groups of 

information separately. Use styles to maintain a consistent format for different types of 

objects. Styles enable you to change drawing settings quickly and to maintain drawing 

conventions. 

When you develop a scheme for setting up layers and styles before beginning a drawing, 

you build a foundation for organized, efficient work. 

Using Layers to Manage a Complex Drawing  

As with the transparent overlays in conventional drafting, you use layers to organize a 

drawing into distinct categories that can be easily managed as your drawing increases in 

complexity. For example, you might organize the floor plans for a renovation into the 

following layers: existing walls, new structure, existing doors, new doors, electrical 
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system, plumbing, mechanical system, and so on. You would then work on each layer, by 

viewing, drawing, editing, and printing it with any combination of other layers. 

The layer functions are available from the Layer Manager. You can draw objects on a 

layer with any properties you choose, or you can designate that certain properties always 

apply to objects on a particular layer. You can save a single layer or a set of layers as a 

new drawing to use a portion of the original drawing as the base for a new project. And in 

the Settings dialogs on the Utilities menu, you can set dimensions, leaders, text, and 

hatches to always be placed on a specific layer of your choice if so desired, regardless of 

which layer is set as current in the drawing. 

 

Working with Layers  
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Open the Layer Manager by clicking the button on the top 

toolbar or typing MGL. The dialog shows a scrollable list of 

layers numbered 0-1023. Layers are numbered by default but can 

be named. 

The current layer is shown in the color red. Any layer that has 

objects drawn on it displays an asterisk (*). The nine buttons at 

the top of the dialog perform layer related commands as follows 

(from left-to-right): 

Visible - displays or hides the selected layer(s). A hidden layer is 

shown italicized in the list. 

Lock - sets the selected layer as locked or unlocked. Objects on 

a locked layer cannot be selected or edited. A locked layer is 

shown as underlined in the list. 

Printable - sets the selected layer(s) as printable or non-printable. A non-printable layer 

is shown with a horizontal strikethrough line through the number or name. 

Current - makes the selected layer current. 

Set Layer Properties - opens a speedbar dialog to set bylayer properties as described 

later in this chapter. Bylayer is an optional feature in Visual CADD™. 

Alphabetical Sort - if layers are named, this toggles their display order between numeric 

(0-1023) and alphabetical. 

Short List - toggles the display between all 1024 layers and only those that are named or 

numbered but with objects drawn on them. 

Move - selected objects in the drawing are moved to the layer you specify. 

Copy - selected objects in the drawing are copied to the layer you specify. 

Note that these commands as well as several others can also be accessed via a popup 

menu by right-clicking while in the Layer Manager list. 

To … Do This in Layer Manager… 
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Name a layer Select a layer, press ENTER, type a name and 
press ENTER again. 

Make a layer current so 
that you can draw on it 

Select a layer and click the [Set Current] button or 
double-click on the layer number/name. 

Display a layer Select one or more hidden layers and click the [Set 
Visible] button, or click the light bulb icon to the right of a 
selected layer. 

Display all layers Right-click in Layer Manager, click Select All, then click 
[Set Visible] button to toggle it on.  This same method 
works to unlock or set printable layers. 

Hide a layer Select one or more displayed layers and click the [Set 
Visible] button, or click the light bulb icon to the right of a 
selected layer. 

Hide all but the current 
layer 

Right-click in Layer Manager, click Select All, then click 
the [Set Visible] button to toggle it off. 

Lock a layer Select one or more layers and click the [Set Lock] 
button, or click the lock icon to the right of a selected 
layer. 

Make a layer non-printable Select one or more displayed layers and click the [Set 
Printable] button to toggle it off or click the print icon to 
the right of a selected layer. 

To move an object to 
another layer 

Select one or more objects in the drawing. In Layer 
Manager click on the [Move Selected to Layer] button, 
move the arrow over the desired layer in the list and left 
click. 

To copy an object to 
another layer 

Select one or more objects in the drawing. In Layer 
Manager click on the [Copy Selected to Layer] button, 
move the arrow over the desired layer in the list and left 
click. 

When you copy objects to another layer the new copy will be displayed on top of the 

other. From the menu, select Zooms>Backward Redraw to display the original on top. 

Select the objects and move them to another part of the drawing. 

Alternately, if you want to move the copied objects to another part of the drawing, hide 

the original layer, move the object(s), then display the original layer. 

Note that the current layer can never be hidden. 

You can resize the Layer Manager by selecting any border and dragging the mouse while 

holding down the left button. You can also “roll up” the dialog by double-clicking on the 

title bar so that only the title remains visible. This allows you to keep the Manager open 

while minimizing its impact on screen real estate. When you need to make further layer 

changes, double click the title bar to roll it down. 
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Visual CADD™ offers alternate methods to do some layer management without having 

to have the Layer Manager dialog open. For instance, from the Layers menu, you can call 

up speedbars that will let you set the current layer or display and hide layers. See the 

Help file for a detailed description of the commands on the Layers menu. 

Working with Layer Groups  

In Layer Manager you can show or hide any combination of layers and then save the 

settings as a "snapshot" by creating a Layer Group. For 

example, you might specify that only Windows, Doors, 

and Wall layers are visible and printable, and then save 

that combination as a layer group called Base Plan. The 

main toolbar has a dropdown list where you can select the 

existing layer groups. The same dropdown is found at the bottom of Layer Manager. 

Layer Groups are created and saved with each individual drawing. 

Do not confuse layer groups with the Group command found on the Edit menu. A Group 

is a collection of individual objects, somewhat like a symbol. 

To create a layer group: 

1. If the Layer Manager is not open, select 

Layers>Layer Groups. 

2. In the layer list, set the status of each layer as you want it to appear in the layer 

group. That is, specify which layers you want visible, printable, locked, and so on. 

3. Click the Add button at the bottom of the dialog. 

4. Type a name in the new window that pops up. If you want the group to save the 

current drawing properties, check the box. 

5. Click [OK]. A new group is created and the name is displayed in the Groups list at 

the bottom of the Layer Manager dialog. 

6. If desired you can now change the settings in Layer Manager and then add another 

layer group. 

To modify a layer group: 

1. If the Layer Manager is not open, select Layers>Layer Groups. 
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2. In the bottom part of the Layer Manager, select the layer group that you want to 

modify from the dropdown box with the arrow. 

3. Make changes to the layer settings in the Layer Manager list. 

4. In the Layer Manager, click [Modify]. 

To delete a layer group: 

1. If the Layer Manager is not open, select Layers>Layer Groups. 

2. In the bottom part of the Layer Manager, select the layer group that you want to 

delete from the dropdown box with the arrow. 

3. In the Layer Manager, click [Delete]. 

To apply a layer group in the drawing: 

1. Select a Group from the dropdown on the main toolbar. 

2. The drawing updates with the new group. 

If you saved the properties for layer, color, linetype, and lineweight that were current in 
the drawing when the group was created, you have the option to either use these 
settings, or the properties that are current in a drawing when you apply the group. 

On Utilities>Settings>System2, checking the box in the Layer Groups section titled Use 
Layer Group Properties will apply the settings originally saved with the group. With the 
box unchecked, settings in the current drawing will be applied instead. If you did not 
save current settings when creating a layer group, this setting will have no effect. See the 
Layer Group topic in the Help file for more detailed information. 

Tip 
Run the Save Current Environment (EN) command from the Utilities menu if you 
want changes such as the one described above to “stick” next time you open 
Visual CADD™. Otherwise settings will revert to the previous state. 

Assigning Properties to a Layer  

By default Visual CADD™ draws objects with the properties that are currently set for 

layer, color, linetype, and linewidth. If for instance color red is current and you want a 

new line with color yellow, you either set the color property to yellow before drawing the 

line or later modify the line to change the color from red to yellow. 

But you can also assign color, linetype, and linewidth properties to a particular layer so 

that all objects you subsequently draw on that layer have those properties applied. Layer 
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Properties can speed your work; to change all of the properties of the object you want to 

draw, you only need to change the current layer. 

Layer Properties are commonly known as Bylayer in other CADD programs. Many of 

these programs are strictly bylayer and force you to set all properties before you draw 

anything. Visual CADD™ gives you a choice. 

Layer Properties in Visual CADD™ are flexible, allowing you to use bylayer for one 

property and the current settings for another. For example, you can assign the color for 

layer 10 to red and the linetype and width to “none”. When you draw a line on layer 10, it 

will always be color red, but will take on whatever linetype and linewidth are current in 

the drawing when the line is drawn. 

Layer Properties are applied in the drawing when you mark the Use Layer Properties 

checkbox on the Utilities>Settings>System2 dialog. If you later clear the Use Layer 

Properties option, each object instead takes on the properties that were current in the 

drawing at the time the object was drawn. This can be confusing; we recommend that if 

you decide to embrace Layer Properties, you use them consistently on all drawings. The 

ability to set some or all bylayer settings for each layer, and the option to assign them to 

any or all layers in a drawing, make Layer Properties a powerful feature. 

Tip 
To assign layer properties to objects drawn on a layer before properties were 
assigned to the layer, select the objects, select Modify>Change, and press the 
[LP] button on the speedbar. 

Layer Properties Speedbar 

The Set Layer Properties command can be started from either a button on the Layer 

Manager dialog or a selection on the Layers menu. On the speedbar shown above assign 

color, type, and width layer properties to the layer you specify. You can also choose to 

clear all Properties previously assigned to a layer. 

To assign properties to a layer: 

1. In Layer Manager, select a layer (or hold down SHIFT and select a series of layers). 

2. From the top of the Layer Manager, click [Set Layer Properties] . 

3. In the Layer Properties speedbar, select options from the dropdown lists to set the 

layer properties, and then click [Apply]. 
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Using Styles to Maintain Standards  

A Style is a template; a collection of settings you define, name, and save. You create a 

style and apply it to a new or existing drawing to set some or all of the drawing’s settings 

in one step, saving time and maintaining consistency. Loading a style does not modify 

existing drawing objects; instead it applies to any further entities created in the drawing. 

When you create a style with the Save Style command you are taking a “snapshot” of the 

current drawing settings. You can choose all the current settings, or save a style that 

might include only the properties of objects, Visual CADD™’s drawing environment, 

selection filters, file exchange settings, or some combination. 

Why Use Styles? 

Use styles to maintain project or company 

drawing standards. For instance, using the 

same styles, all members of a project team can 

create drawings that use the same layer 

conventions, line widths, colors, hatches and 

fills, and Symbol settings. 

Styles are also a quick and easy way to load an 

entire group of settings for a particular type of 

object. For instance, create different text and 

dimension styles and then quickly call them up 

with the Load Style command. 

To Save a Style: 

1. Change the settings in the drawing environment 

as desired, then click File>Save Style or type 

TV.  

2. Click the Style Settings button to open the 

dialog, check the categories that you want to 

include in the style or click [All] to select all 

categories, and then click [OK]. 
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3. Enter the name of the style file, and then click Save. 

Information in style categories: 

 Some categories define all settings for a single entity type, such as hatches, symbols, 
and text. 

 Others define all settings for non-entities, such as Numeric and Fonts settings. 

 Some categories give you the option of defining settings in greater detail. For 
example, on Layers you can choose to save only the current layer settings, only the 
current layer groups in the drawing, or both. 

 Filter includes all the settings on the Selection Filter speedbar. 

 Dimensions include the ability to apply only some of the current settings, for example 
text, arrows and extensions. 

 Leaders also give the option of saving only some settings. 

 File Exchange can include all Import/Export settings or just DWG or GCD. 

 Drawing checkbox includes all settings on the General and Constraint settings dialogs. 

 System checkbox includes global settings that apply to all drawings. 

To Load a Style: 

1. Click File>Load Style. 

2. Select a style file, and then click [Open]. 

Tip 

System settings saved with a Style by default include the file paths as found on 
the Paths tab of the Utilities>Settings menu. If you are saving a Style file that 
you will share with others who might have different paths, uncheck the Paths 
checkbox before saving the style. See the illustration on the preceding page that 
shows System settings being saved with the style but not the paths. 
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C H A P T E R  

5 
DRAWING TOOLS 

In conventional drafting, you lay down lines by drawing each stroke exactly as you want 

the finished line to look. In CADD, you draw lines (for example, the perimeter of a 

building), and then delete parts that are unneeded, for example, to make openings for 

windows and doors. 

In CADD, you draw lines and other objects by placing the points that define a drawing 

entity, such as a line, a circle, or a polygon. Each point is represented by an X,Y 

coordinate shown on the display and stored in the drawing database. 

Visual CADD™ provides the tools to draw efficiently. Rather than drawing two lines 

separately to create a wall, for example, use the Double Line tool to lay down two lines at 

a specified distance from each other. 

Each object that you draw has a set of basic properties for layer, color, linetype, and 

linewidth. You can change these settings if desired before starting a drawing tool. 

Introduction to the Drawing Tools  

To draw objects in Visual CADD™, start a drawing tool, 

and then place the points that define 

the object by either clicking its 

position with the mouse or typing in 

the x,y point coordinates. The status 

bar prompts you for the next point to 

enter. 

Some tools create a series of adjoining 

line segments or curves. Others create 

Selection Tool 

Straight-Line/Point Tools 

Rectangle Tools 

Polygon tools 

Circle/Ellipse Tools 

Arc Tools 

Complex-Curve Toosl 
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a closed object, such as a rectangle or polygon. You can choose to draw these closed 

objects as a single object (also known as a polyline) or exploded so that each line is an 

individual entity. Most tools create objects that maintain their shape when you move or 

modify them. 

Methods of entering points 

To draw by entering keyboard coordinates: 

1. Select a drawing tool, type X and Y coordinates, separated by a comma, and press 

ENTER to set the first point. 

2. Type in the X and Y coordinates to locate additional points, pressing ENTER to set 

each point. 

To draw by using direct distance entry: 

1. Select a drawing tool, and then either click the mouse or type X and Y coordinates 

and press ENTER to set the first point. 

2. Move the mouse in the direction and at the angle where you want to place the second 

point, type a distance, then press ENTER. 

3. The point will be placed at the distance value you entered. Use the Ortho commands 

to constrain the point at a precise angle if desired. 

To draw by entering polar coordinates: 

1. Select a drawing tool, and then either click the mouse or type X and Y coordinates 

and press ENTER to set the first point. 

2. Type a distance and an angle, separated by the symbol for angle (e.g.; 36<45), and 

then press ENTER. Note: use this method after setting the Relative coordinate system 

as described at the end of Chapter 2 to achieve accurate results. 

Setting Properties  

Every object that you draw in Visual CADD™ has four basic properties: a layer, color, 

linetype, and linewidth. Set these properties before 

you draw by selecting them from the dropdown 

boxes on the main toolbar, or with the Properties 

command on the Draw menu. 
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Layer - by default layers have a number but you can name any layer using the Layer 

Manager dialog described in Chapter 4. 

Color - assign any one of 256 colors to an object. 

Linetype - Visual CADD™ has 50 default linetypes. See 

a complete illustrated list in Appendix B. You can modify 

existing or create new linetypes. See Chapter 13 for 

details on customizing linetypes. 

Linewidth - There are 16 predefined linewidths that display and 

print based on pixels; linewidth 2 is 2 pixels and linewidth 15 is 

15 pixels. A small sample is shown here; see Appendix B for the 

full list. 

You can also specify a Real-World linewidth by selecting the last entry in the linewidth 

dropdown on the main toolbar and then typing in a value, or from the Properties 

command on the Draw menu by clicking the [RW] button and typing in a value. Real-

World linewidths print and display at the width you enter, regardless of the drawing 

scale. 

Note Linewidths 0 and 1 both appear onscreen as 1 pixel. 

Straight Line Tools  

Visual CADD™ has five tools for drawing straight 

lines: 

The Single Line tool (LS) creates a line between two 

endpoints A and B. 

The Continuous Line tool (LC) places the endpoints A, 

B, C, D, and E of adjacent line segments. Use this tool 

to draw a continuous, segmented line. When you select a 

segment of a continuous line, you select the entire line, 

unless you set Visual CADD™ to explode continuous 

lines on placement. 
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Continuous Line is one of five persistent or “continuous” drawing tools, active until you 

either double click, press ESC, or right click and select Pen Up from the popup menu. 

You can also type PU to run Pen Up and end a persistent tool. 

The Midline tool (ML) places the midpoint A and one 

endpoint B. Use this tool when you need to draw the 

endpoints of a single line segment equidistant from a 

specific point. 

The Double Line Tool (LD), a continuous tool, places the endpoints A, 

B, C, and D of the adjacent line segments of two parallel lines. Use this 

tool to draw walls and roads. You can set the offset or size of the space 

between the lines, and you can add a solid fill to the space between the 

lines. 

Setting the offset of double lines: 

The line offset specifies the distance from the cursor to 

each line drawn with the Double Line tool. An offset of 0 

locates the line on the cursor. When left and right offset 

values are equal, the cursor lies equidistant between the 

two lines. Left and right offsets are defined relative to the 

cursor’s forward movement. 

To change the offset of a double line and apply a solid fill: 

1. Start the Double Line tool. 

2. Right-click, and then select DB Line Settings (or type DB). 

3. On the speed bar, enter values in the Left and Right Line Offset 

boxes, check the Solid Fill checkbox, and then click [OK] or press 

ENTER. 

The MultiLine tool (MN), a continuous tool, works a bit like Double 

Line but allows you to draw from 1 to 16 separate lines at the same time. 

Each line can be set with its own dedicated layer, color, linetype, and 

linewidth. Or you can specify that some or all the properties for each line 

take on the settings that are current in the drawing when placing the line. 

You can create and save MultiLine Styles and call them up later. Using the MultiLine 

tool can save a lot of time over the course of a drawing session or project. 
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Setting up a MultiLine Style 

To set up a Style, open the MultiSettings dialog from the Draw>Line menu, or type MS 

from the keyboard. 

Instead of creating a series of individual 

lines, you quickly draw entire assemblies. 

For instance, you could create a 

MultiLine Style for a wall assembly on a 

Plan drawing that includes lines to 

delineate the framing, the interior finish, 

the exterior sheathing, and the exterior 

finish. Draw the entire wall at once with 

the MultiLine command, and then add a 

hatch to complete the assembly. 

You may save as many MultiLine styles 

as you want. Create your style settings, 

press [Save], type a style name in the 

dialog that pops up and type [OK] to save 

the style and exit the popup. You can click [Save] to create another style without leaving 

the MultiLine settings dialog, [Draw] to start the MultiLine command using the style 

current in the Styles dropdown to the left of the buttons, or [OK] to finish and close the 

dialog without drawing a line. 

MultiLine is a true entity type rather than as a collection of single lines. Selecting a 

MultiLine entity after placement selects the entire MultiLine. If you prefer MultiLine to 

place separate lines, tick the classic checkbox on the dialog when saving a style. 

The style example shown on the preceding page is an 8” thick concrete wall with 16” 

wide footings, so they extend 4” from each side of the wall. All 4 lines are placed on the 

same layer with the same color. The wall lines (#2 and #3) are solid and a heavier 

linewidth; the footing lines (#0 and #4) are dashed with a lighter width. 

If you draw a horizontal MultiLine, the cursor will attach to the line #2 with the 0 value; 

line #1will be offset above because the value is entered as -4. Line #3 is offset 8” below 

line #2, and line #4 is 12” (and thus 4” below the foundation wall line #3). 

You do not have to apply specific property settings for layer, color, linetype, or linewidth 

of a line that is part of a MultiLine Style. Select [current] for any of the properties 
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dropdown lists, and when you draw the MultiLine the properties that are current in the 

drawing will be applied to that property of the MultiLine. 

Rectangle Tools  

There are two different commands for drawing rectangles. By default the rectangle tools 

draw a single entity that is a closed, continuous line (polyline). However, you can specify 

that they be placed as individual line segments with the Explode Continuous Lines (CX) 

command on System1 of the Utilities>Settings menu. 

The 2-Point Rectangle (R2) tool places two points to establish 

the rectangle’s opposite corners A and B. Points are always 

placed restricted to 0, 90, 180 and 270 degrees, regardless of the 

Ortho Angle setting. 

Use this tool to create horizontal and vertical rectangles. 

The 3-Point Rectangle (R3) tool places the two endpoints of the 

rectangle’s sides A and B, establishing the length and angle, and 

then places the third point C to establish the rectangle’s height. 

Use this tool to create rectangles at angles and orientations other 

than the 0 and 90 constraints, or when you need to specify 

precise values for both the x and y axis. 

Polygon Tools  

By default, the polygon tools draw a single entity that is a closed, continuous line 

(polyline). However, you can specify that they be placed as individual line segments with 

the Explode Continuous Lines (CX) setting. Both the Center and Side Polygon tools can 

draw polygons with up to 99 sides. Set the number of sides after selecting the tool by 

right clicking and then selecting Number of Sides. 

The Center Polygon tool draws polygons either inscribed or circumscribed on a circle. To 

set an inscribed polygon, click the Center Polygon tool, right click, and then select 

Inscribed. To set a circumscribed polygon, click the tool, right click, and then make sure 

Inscribed is clear. 
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The Center Polygon tool (PC) places the center point A and, if 

inscribed, one vertex point on the polygon’s perimeter B, or if 

not inscribed, one midpoint of a side of the polygon C. Use this 

tool to snap a vertex or midpoint of a side to an existing point. 

 

The Side Polygon tool (PS) places two adjacent vertices on the 

polygon’s perimeter A and B, defining one of its sides, and then 

establishes the polygon’s orientation C. Use this tool to snap the 

side of a polygon to an existing line. 

The Irregular Polygon tool (IP), a continuous tool, places 

points that create an irregular shape with three or more sides of 

any length or angle. Use this tool to draw an irregular, closed 

object. 

Circle and Ellipse Tools  

Each of these tools draws a single entity that also is a closed object. 

The 2-Point Circle tool (C2) places the center-point A and one point 

on the circle’s circumference B. Use this tool when you know the 

location of the circle’s centerpoint and any point on its circumference. 

 

The 3-Point Circle tool (C3) places three points on the circle’s 

circumference A, B, and C. Use this tool when you do not know the 

center or radius, but you know the location of two or three points 

through which the circle’s circumference must pass. 

The Diameter Circle tool (CD) places points opposite one another 

on the circle’s circumference A and B. Use this tool when you need 

a circle to exactly fill the space between two objects. 
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The Ellipse tool (EP) places the endpoints A and B of the ellipse’s major axis, and then a 

point at the end of the ellipse’s minor axis C. 

Tip 

Have Visual CADD™ calculate the distance for you when placing a circle’s 
second point with the 2-point or diameter circle tools by entering a 
mathematical expression for the radius (diameter/2) or the diameter 
(radius*2) in a direct-distance entry. 

Arc Tools  

The 2-Point Arc tool (A2) places the centerpoint A of the circle 

describing the arc, the arc’s starting point B, and then the arc’s 

endpoint C. Use this tool to draw an arc with a precise 

centerpoint or radius, such as a door swing. 

The 3-Point Arc tool (A3) places the arc’s starting point A, an 

intermediate point B, and the endpoint C. Use this tool for 

shaping an arc as you draw it 

 

The Elliptical Arc tool (EA) first establishes the ellipse that 

describes the arc, placing the ellipse’s first and second endpoints 

A and B on the major axis of an ellipse, and a point C at the end 

of the ellipse’s minor axis. It then places the arc’s starting point D 

and finally its endpoint E. Use this tool to draw an arc that 

follows the contours of an ellipse. 

Complex Curve Tools  

 The Single Bézier Curve tool (BS) places the endpoints A 

and B of the curve, and then the control points C and D that 

define the slope of the curve. Use this tool to draw a single 

Bézier curve. 

The Continuous Bézier Curve tool (BC), a continuous tool, 

places the starting point A and subsequent tangent points B, 

C, and D of adjoining Bézier curves. When you select any 

portion of a continuous Bézier curve, you select the entire 
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line. Use this tool for drawing steep curves such as highway acceleration curves. 

The Spline Curve tool (CV), a continuous tool, places the starting point A and 

subsequent tangent points B, C, and D of adjoining spline curves. When you select any 

portion of a spline curve, you select the entire line. Use this tool for drawing the broad 

curves common to aerodynamics, automotive, and marine design. 

Point Basics  

In Visual CADD™, points are placed when you draw an entity. An object’s first and last 

points are its endpoints. On open objects, endpoints do not touch. On closed objects, the 

endpoints touch. 

Of the four point types, three are always associated with an object when you place it in 

the drawing. You can snap to these points or use them to modify the object with 

commands such as Move or Stretch. Standard Points are different: they are an actual 

Visual CADD™ entity, independent and not part of another object. 

You turn the display of each point type on and off individually from the 

Utilities>Settings System1 dialog. There are also keyboard shortcuts to toggle each point 

type on and off. See the Help file for more information. 

Comparing the Four Types of Points 

Standard points (PO) are the points you place with the Point 

tool, typically marking positions that are not part of any 

objects. You can snap to standard points when drawing other 

objects. Unlike other points, standard points are a unique 

Visual CADD™ entity and not part of other objects. They can 

be printed and can be assigned properties such as layer or 

color, in the same way as a line or circle. 

Construction points are the points you place to draw objects or 

to move when editing most objects. The endpoints of lines and 

arcs and the centerpoints of circles, arcs, and polygons are 

construction points. 

Control points, a special kind of construction point, are the 

points created when placing points and the endpoints of Bézier 
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and spline curves. Defining a tangent to and lying off of the curve, control points alter the 

curve’s size and shape when you use the Stretch command. 

Handle points are points used to locate certain types of entities, 

including symbols, text, dimensions, hatches, and layers. You typically 

use handle points to snap to during a Move or other Modify command 

with these types of objects. 

Using Control Points to Change a Curve’s Shape  

Moving, extending, or retracting control points alters the curve of the adjacent line 

segments. With construction points checked in the Display section of the Settings 

System1 dialog, you can see the control points displayed on a selected Bézier or Spline 

curve, and select them to modify the curve shape. 

How Control Points Shape a Curve 

A control point controls the portion of the curve on the same side of 

the construction point. 

As you drag a control point farther from its corresponding 

construction point, the curve becomes broader. 

 

 

To alter a complex curve by moving a control 
point: 

1. Select Modify>Move Point, and then click the control 

point on the curve you want to reshape. 
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2. Drag the control point to its new position. 

Tip 
To turn off the display of control points so that you do not accidentally snap to or 
alter the shape of a curve, type DV, select Zooms>Redraw. Type DV again to 
display them. 

Properties  

The Properties command sets new current drawing properties for linewidth, color, layer, 

and linetype. After the properties have been set, the next entity you create will be drawn 

with the new properties. 

You can set the 4 properties directly from dropdown list boxes on the main toolbar, as 

described in the beginning of this chapter. 

Why use the Properties command if you can make the same changes from the toolbar? 

You might prefer it simply because you are used to it from past versions. Or you might 

want to use the Fast Properties feature, which is not available on the main toolbar. 

Properties Speedbar 

Start the Properties command from the Draw menu or by typing PP. Using this speedbar 

you can: 

 Change any or all of the 4 properties by selecting from the dropdown lists. 

 Press the [RW] button and type a value in the Width box to set a Real-World 
linewidth. 

 Press the [LP] button to return the settings to Layer Properties. If you have assigned 
layer properties to a layer, it is possible to override them by selecting a different 
property, either in the Properties dialog or on the main toolbar. Clicking [LP] returns 
the settings to the ones assigned by the Set Layer Properties command. 
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 Press the Match button to set all 4 properties to match an object already in the 
drawing. After pressing the button, click on the object in the drawing with the 
properties you want to match. The settings of the selected object are applied and the 
Properties speedbar immediately closes. 

Fast Properties 

This powerful feature allows you to use the speedbars as a command line, entering values 

directly from the keyboard without having to move the mouse up into the speedbar and 

pick from dropdown lists. When toggled on it works with several commands, including 

Properties, Change, Selection Filter, and Set Layer Properties. The dropdown lists on 

these speedbars are replaced by edit boxes where you type in a value to set the property. 

To turn it on, right click on the speedbar of any of the commands above and click on Fast 

Properties. You can also set Fast Properties on the System2 dialog of the 

Utilities>Settings menu or by typing the 2 letter keyboard shortcut FP. 

To set properties with Fast Properties: 

1. Start the Properties command and make sure Fast Properties is toggled on. 

2. The value in the Layer edit box should be highlighted. Type in a new value to replace 

it if desired. 

3. Press the Tab key to move to other edit boxes, and type in new values as needed. 

4. Press ENTER on the keyboard to end the command. 

Line Scaling  

You can set or change the scale of all non-solid linetypes in a drawing with the Line 

Scale command. This is useful if you print the same information at different scales and 

want more control over the appearance of linetypes in your output. The command affects 

all non-solid lines in a drawing; it cannot be applied to only one line at a time. If you save 

a drawing with a new Line Scale it affects only that drawing; it is not a global setting. 

There are two types of linetypes in Visual CADD™: Device and World. With the Device 

type the apparent size of the segment lengths will remain constant onscreen and on paper 

regardless of the zoom factor or print scale. With the World type, the apparent size of the 

segment lengths will change when you zoom in or out onscreen, or when you plot or print 

at different scales. 
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To change the line scale in a drawing: 

1. Select Draw>LineScale from the menu or type LZ. 

2. In the speedbar, type the desired linescale into either or both the Device and World 

Line Scale edit boxes. The default is 1. 

3. Press [OK] to end the command. All non-solid linetypes in the drawing will 

immediately be redrawn at the new scale. 

Tip 

All the linetypes supplied with Visual CADD™ are of the Device type except for 
one; changing the World Line Scale has no effect on device-type lines in your 
drawing. If you want to add more World linetypes, see the topic Customizing 
Linetypes in the Visual CADD™ Help file. 

Isometric Mode  

Isometric Mode constrains the line tools to angles of 60 and 90 degrees to create the left 

side, right side, and top of an isometric drawing. It is useful for drawing details where a 

flat 2D projection might not convey the needed drawing information, for example the 

timber connections shown in the illustration below. 

Isometric Mode also changes the cursor to 

reflect that you can draw only at these angles. 

The onscreen display of the cursor will change 

depending on which option is active in 

Isometric Mode. For instance, with the Iso-Top 

(IO) option active, the cursor will appear 

onscreen as an "X" and you are constrained to 

drawing lines at 120° either direction. Iso-Left 

(IL) and Iso-Right (IR) constrain the lines to 

vertical and 60° in either direction. 

The Isometric Mode command (IM) on the Draw menu toggles Isometric Mode on and 

off and changes the cursor display when you start a line tool. 
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C H A P T E R  

6 
DRAWING WITH PRECISION 

Visual CADD™ replaces parallel rules, T-squares, triangles, and other manual drafting 

equipment with more precise tools such as Ortho settings, Snaps, and Grids. 

Ortho mode constrains all entities that you draw to 90° increments of a specified base 

angle, ensuring square corners and true horizontals and verticals. 

When you use snaps, you do not need to know the precise location of a point you want to 

place. Instead, you define the relationship of the point to a point on an existing object. 

The new point snaps to the existing point. 

Snap Grid 

 

When you draw on a grid, you can snap points to the intersection of gridlines, ensuring 

that you place the points at regular intervals. 
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Constraint Settings  

Open the Utilities>Settings>Constraint 

dialog to initially set ortho and grid 

properties. Individual settings are discussed 

in more detail later in the chapter. In 

addition, the Help file gives a complete 

description of each setting on the dialog. 

 

 

 The Ortho section is where you set the base ortho angle, toggle whether ortho is 
constrained to 90 degree directions, and if desired set the cursor to move independent 
of the object you are drawing when Ortho Mode is on. 

 Advanced Ortho settings allow you to draw using additional angles while drawing 
with ortho constrained. 

 The Manual Entry section sets the coordinate entry mode as described in Chapter 2. If 
you set the mode to Basepoint, specify the X and Y coordinates in the edit boxes of 
the Basepoint section. 

 The Grid section sets the size of the grid, whether it displays, and whether to snap to 
the grid points. 

 Increment Snap is a special snap, as described below, that you might use when placing 
objects of the same length or same offset from each other. 

To draw in multiples of a specific length: 

1. Select Utilities>Settings. 

2. In the tree list at left side of the dialog click [Constraint]. 

3. Tick the Increment Snap On checkbox, and type a value in the Size box. 

4. Click [OK] to close the dialog, then start a Draw or Modify tool. 

Tip 
To quickly place joists or rafters on a framing plan, set Increment Snap to 16 or 
24 inches and use the Multiple Copy command. 
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Constraining Lines and Objects  

In ortho mode, you constrain all points that are placed to a perfect 90° relationship with 

each other. You can toggle ortho mode on or off for one point, a series of points, or all 

points in your drawing. Using the Advanced Ortho options, you can add other angles to 

the constraint. 

Even when ortho mode is on, you can unlock the cursor from its constraint by right 

clicking the mouse during a drawing command and making sure that Cursor Free is 

checked (or type CF from the keyboard). With Cursor Free on, you can snap to any point 

in the drawing, and Visual CADD™ places the closest point that is perpendicular to the 

cursor location on the constrained axis. 

You can also set the Base angle, which changes the Ortho mode base orientation to the 

angle of the X axis relative to 0°. 

How Ortho Mode Constrains Entities 

Ortho mode overrides all snaps except the constraining snaps: that is, points you place 

will constrain to the ortho axes even when you snap them to points not on the ortho axes. 

If you manually enter the point’s coordinates, however, ortho mode is overridden, and the 

points are placed at the coordinates you enter. 

Tip 

Toggle ortho mode On/Off temporarily by holding down CTRL key as you 
place a point. 

Set the ortho base angle to align with an object in your drawing by starting 
the Ortho Angle command from the Snaps menu (or type OA), click the 
[Match] button on the speedbar, click the object in the drawing you want to 
align the ortho angle to, and press [OK] or ENTER to finish. 

To turn ortho mode on and off: 

Select Snaps>Ortho Mode from the menu. Ortho has a checkmark when on; or 
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Start a drawing tool, right click, and select Ortho Mode. Ortho has a checkmark when on; 

or 

Click the Ortho section of the status bar to toggle Ortho on and off. If on, the current 

Ortho Angle is displayed. 

To change the Base ortho angle: 

1. Start a tool, right click and then select Ortho Angle 

2. Enter a value in the Base angle edit box and click [OK] or press ENTER. 

Advanced Ortho 

By default Advanced Ortho is set to None, meaning that it is not active. With Ortho mode 

On and Advanced Ortho active, you have three different options to draw additional 

angles besides the standard 90° degree horizontal and vertical constraints: 

 Step Angle sets a repeating angle at whatever increment you type in the edit box. For 
example, setting a step angle of 15° with a Base Angle of 0° lets you draw lines at 
15°, 30°, 45°, 60°, 75°, etc., all the way around a 360° compass rose. 

 Divisions divides the compass rose into the particular number of segments you 
designate. For example, with base angle set at 0, six increments gives you right and 
left horizontal lines at 0° and 180°, and angled lines at 60°, 120°, 240°, and 300°. 

 Add 1 Angle specifies a single angle in addition to the standard 90° increments. But it 
actually gives you a total of 4 angles: the one you specify, a mirror to the right, and 
mirrors up and down. This option is useful for drawing roof elevations and sections, 
and isometric drawings at non-standard angles. 

To set the advanced ortho angle: 

1. Select Advanced Ortho from the Snaps menu or by typing OV from the keyboard. 

2. On the speedbar, select the desired option, and type the value in the edit box 

3. Select [OK] or type ENTER. 

Note 

When you draw with Advanced Ortho active, if you have Cursor Free (CF) 
turned On, you can only change angles within the Search Tolerance (set on the 
System1 dialog) after you place the first point of a drawing tool. To see the 
search tolerance type AP to toggle the Aperture, which places a circle around 
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the cursor crosshairs that reflects the current search tolerance setting. 

To change the angle at any time during a line command, toggle Cursor Free 
Off. Or with Cursor Free On, you can press the CTRL key to temporarily turn 
Ortho off, and then move the cursor roughly to the angle you want, and 
release the CTRL key. The line will “snap” to the closest angle you have set 
on the Advanced Ortho speedbar. 

Working with a Grid  

When you are creating a drawing with entities 

spaced at regular intervals, such as a buildings 

structural system or an electronic circuit board, a 

grid can speed your drawing while maintaining 

precision. In Visual CADD™, a grid is a 

nonprinting background of equally spaced dots. A 

grid enables you to snap the points you are 

drawing to grid points. 

After you activate the grid, you can choose to 

display the grid or not. You can also change the 

distance between adjacent grid points. 

By default, the grid aligns with the drawing 

origin’s 0,0 location. You can move the grid, 

however, so that it aligns precisely with a specific 

point in your drawing 

Using a Grid 

To … Do This … 
View the grid Select Snaps>Grid>Grid Display. 
Snap to grid points Select Snaps>Grid>Snap Grid. When checked, 

point placement is constrained to the grid points. 
Set the distance 
between grid points 

Select Snaps>Grid>Grid Size, and enter the X and 
Y grid intervals on the speedbar. Click [OK] or 
ENTER to finish. 

Align the grid with a 
specific point 

Select Snaps>Grid>Grid Origin and either type in 
x,y coordinates or click the mouse to place the 
origin. Use snap commands to precisely place the 
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origin to an existing point or object in the drawing. 

 

Tip 

Several actions and commands override the Snap Grid command: manually 
entering x and y coordinates to place a point and the snap commands. 

You can also start the grid commands from the main toolbar. Display Grid is 
the default icon. Press it repeatedly and the grid display will toggle on and 
off. If you hold the left button down over the icon, a “flyout” will appear. Drag 
the mouse down to select another icon and release the mouse button to start 
that command. 

Drawing Objects Precisely with Snaps  

Snaps help you place points and objects precisely in relationship to other points, lines, 

and objects. Some snaps also serve as a drawing constraint. Used in combination with 

Tracking, snaps can serve as a navigational tool for quickly finding points. You can use a 

snap any time you use a drawing tool or Tracking, and you can use a combination of 

snaps together. Tracking is discussed later in this chapter. 

You can choose most snaps from the Snaps menu, from the toolbar, or by right click and 

then selecting Snaps. You can also type a keyboard shortcut for any of the snaps. 

Snaps that Prompt You to Select a Point or an Object 

The Snap Object tool (SO) finds the point on an object 

nearest where you click. 

 

 

The Snap Midpoint tool (SM) finds the midpoint of the line 

or arc you select. 
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The Snap Center tool (SN) finds the center of an arc, circle, ellipse, or polygon that you 

click. 

 

The Snap Closest tool (SC) finds the construction point nearest where you click. 

 

The Snap Intersection tool (SI) finds the point nearest where you click at which two 

entities or objects intersect. 

 

The Snap Between 2 Points (S2) tool finds the midpoint between two points or entities 

that you select. 

 

The Snap Quadrant tool (SQ) finds the quadrant point nearest where 

you click on a circle, ellipse, or an elliptical arc. Quadrant positions are 

absolute, whatever the ortho angle, and correspond to a clock’s 12:00, 

3:00, 6:00, or 9:00 positions. 

The Snap Percentage tool (SR) finds the point at a distance 

from the end nearest where you click that is a percentage of the 

entity’s total length that you specify. Use snap percentage with 

lines, arcs, and curves. 

To draw using a prompting snap: 

1. With a tool selected, click the Snaps menu and then click the snap you want, or click 

the snap tool that you want on the left toolbar. 

2. Click the point or entities to which you want to snap, and then continue drawing. 

Quick Snaps 

The Snap Near Point command (NP) is the most 

commonly used snap command in Visual CADD™. It finds 

the construction point nearest the cursor location when the 
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command is chosen with the right mouse button or keyboard shortcut NP. 

Because the snap is executed immediately with no prompts, and since the cursor must be 

positioned near the point to be placed, you cannot select this command from a menu or 

toolbar button (and you will not find it on a menu or button). Run the snap with the two-

letter shortcut shown above, or by holding down the Shift key and pressing the right 

mouse button (or, if configured as detailed below, by simply clicking the right mouse 

button). 

Tip 

By default a right click in Visual CADD™ brings up a popup menu with 
commands and settings related to the tool currently running. You can specify 
that a right click runs NP instead. On the System2 dialog of Utilities>Settings, 
tick the Shift+Right Button = Popup Menu checkbox. Click [OK] to finish, and run 
the Save Current Environment command (EN) from the Utilities menu to make 
the change “stick” in the next session of Visual CADD™. Now your middle 
mouse button will bring up the popup menu. 

 

The Snap Last tool (LP) finds the last point placed. 

To draw using a quick snap: 

1. With a tool selected, type the two letter command for the snap you want to use. 

2. Continue drawing. 

The Constraining Snaps 

The Snap Perpendicular tool (SP) sets a line or rectangle you 

are drawing to be perpendicular to another line, arc, curve, 

circle, rectangle, polygon, or ellipse. 

 

The Snap Tangent tool (ST) sets a line or rectangle you are 

drawing to be tangent to another line, arc, curve, circle, 

rectangle, polygon, or ellipse. 
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The Snap Parallel tool (LL) sets a line, rectangle, or polygon you are drawing to be 

parallel to another line, rectangle, or polygon. 

To draw a line perpendicular to an object: 

1. With a tool selected, click the Snap Perpendicular tool. 

2. Click the entity you want to snap to, and then continue to 

draw. 

 

 

To draw a line tangent to an object: 

1. With a tool selected, click the Snap Tangent tool. 

2. Click the entity you want to snap to, and then continue to 

draw. 

To draw a line parallel to an object: 

1. Start one of the line tools or the 3 Point Rectangle tool, and 

place the first point of the new line. 

2. From the Snaps menu, click Parallel or type LL from the 

keyboard to start the Snap Parallel command. 

 

 

 

3. Click anywhere on the object that you want to draw parallel to. 

4. Drag your cursor to extend the new line, and it will draw 

parallel to the line that you selected in the step above. 

5. Click to set the second point of the new line. 

To draw a line parallel to an object at a specific distance: 

1. Start a line tool, but do not set the first point. 



 

66 Drawing with Precision 

 

2. From the Snaps menu, click Parallel or type LL from the keyboard to start the Snap 

Parallel command. 

3. Click anywhere on the object that you want to draw parallel to. 

4. Enter an offset value on the snap parallel speedbar and then click [OK] or ENTER from 

the keyboard. 

5. Place a starting point for the new line. 

6. Drag your cursor to extend the new line parallel to the one selected in Step 3, and 

place a second point to finish. 

Running Snaps 

If you use one or more Snap tools frequently, you can set these snap tools as running 

snaps so that you do not have to select the same snap commands repeatedly. Running 

Snaps remain active until you turn them off in the Running Snaps dialog (or by using the 

keyboard shortcut RS. Type the shortcut again to quickly toggle running snaps on). 

If you select the Preview Snap options, when the cursor moves within range of a point 

where a running snap is active, the icon for that snap is displayed beside the cursor, and 

the object to which you are snapping is displayed in a color that you have set from the 

dropdown list on the Running Snaps dialog. 

To display the Running Snaps dialog: 

1. Select Snaps>Running Snaps or type RN. 

2. In the Running Snaps dialog, select the check boxes 

for the snaps that you want to set as running snaps. 

3. To activate the selected running snaps, tick the RN 

Snaps On checkbox. You can also toggle Running 

Snaps on and off by typing the keyboard shortcut 

RS. 

4. Select the Show Preview checkbox to have a snap 

icon displayed and the object shown in color when 

the cursor is within range of a snap point. Choose a 

color from the dropdown list. 

5. The Show Aperture check box allows you to show or hide the aperture for the cursor. 

If Show Aperture is not selected then the cursor is displayed as cross-hairs without 

the circle. For more information on the aperture, see the following section. 
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Tip 
Hold down the ALT key to temporarily disable running snaps for any one 
instance when you left click the mouse to place a point. 

Using the Aperture 

The aperture is a circle that is centered on the cross-hairs. The aperture provides a visual 

clue that your cursor is close enough to an entity to snap to it or select it. If the object is 

outside the circle it will not be selected and most snap commands will be ignored. 

The size of the aperture circle is set by the Search Tolerance edit box on the Settings 

System1 dialog. 

Displaying the aperture 

1. Select Snaps>Running Snaps, or 

2. In the Running Snaps dialog, check the Show Aperture check box. 

You can also type AP from the keyboard to toggle Aperture on and off, or set it from a 

checkbox on the Utilities>Settings>General dialog. 

Note 
When you select the Show Aperture check box in the Running Snaps dialog, the 
aperture is visible even when Running Snaps are turned off. 

 

To change the size of the aperture: 

1. Select Utilities>Settings. 

2. In Settings, click the System1 dialog. 

3. In the Search Tolerance box, type a value to specify 

the distance you want snaps to be active. The size 

of the aperture will change to reflect the value in 

the Search Tolerance box. 
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Using Tracking to Place Temporary Points  

Frequently while drawing, you might start constructing an object but do not know the 

precise location of the second or third point you need to place. Or you might start a line 

command, but before placing the first point, you decide you want the line to begin an 

exact distance from the endpoint of an existing object. Rather than cancel the operation, 

you can nest a command that enables you to interrupt the action temporarily until you 

locate the point, and then start or continue the drawing operation. 

Tracking enables you to set the location of points before you place them. You can start 

the Track command at any time after starting a drawing tool, whether or not you have 

placed any points. 

As soon as you select Snaps>Track, you draw a rubberband line that will vanish when 

you use the Track End or Pen Up (PU) commands, leaving the cursor in a location ready 

to place the next point in your drawing. When tracking, you can use any coordinate 

system, drawing constraints such as ortho mode, and snaps to aid you in finding a 

location in your drawing. 

Using Tracking to Locate a Point 

Tracking is useful for finding the precise location 

where you want to break a wall to insert a window or 

door. It is also useful when inserting a symbol into a 

drawing, because you can track to an exact location, 

and a Pen Up will both end the tracking command and 

place the symbol. 

 

To locate a point in your drawing using 
tracking: 

1. After starting a drawing command, select 

Snaps>Track, or Track on the right click popup menu, 

or type TK. 
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2. Begin “drawing” from a known coordinate in your drawing, using snaps, constraints, 

direct distance entry and any other drawing tools as aids to locate the first point. 

3. Continue creating other points if desired. 

4. When you locate the last point, 

right click and select Track End (or 

type PU). 

5. The drawing command will continue from that point, prompting you with further 

instructions depending on which tool you are using and where you were at in the 

command when you started Tracking. 

Tip 
See the Tracking topic in the Help file for a step by step example of using the 
Track command to find the center of a rectangle created with 4 single lines. 
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C H A P T E R  

7 
VIEWING THE DRAWING 

Because Visual CADD™ has an unlimited drawing area and you draw objects at actual 

size, you will often need to view an area of the drawing that is not on the screen. 

You have several options for changing the view of your drawing: 

 Zooming in and out to see more or less detail. 

 Panning left and right or up and down to change the view. 

 Bird’s-eye view, to open a thumbnail view of your entire drawing. 

Visual CADD™ offers a wide range of zoom and pan tools on the Zooms menu for 

navigating to a specific view of the drawing, including AutoPan. 

Zooming and Panning  

Using a Wheel Mouse 

The most effective way to navigate around a drawing is by zooming and panning with a 

mouse wheel. Roll the wheel forward or away from you to zoom out and roll back 

towards you to zoom in. Hold down the SHIFT key and roll to pan the drawing right and 

left, and CONTROL key to pan the drawing up and down. Hold down the middle button and 

drag the mouse to pan the drawing. 

You can change several settings on the Utilities>Settings>System2 dialog to modify how 

the mouse wheel works. These include reversing the wheel direction so that rolling 

forward zooms in, and setting values for the amount of zoom and pan with each click of 

the scroll wheel. See the Help file for more details on mouse settings. 
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Scrollbars 

By default scrollbars are toggled on when you first open Visual CADD™. Using a wheel 

mouse makes the scrollbars somewhat redundant --many people turn them off to increase 

the viewable drawing area. To toggle scrollbars off, right click on either one and uncheck 

the Scroll Bars option on the popup menu. To toggle them back on, right click on the 

status bar or one of the toolbars. Run the Save Current Environment command (EN) to 

make the change “stick” the next time you open Visual CADD™. 

Zoom Pan (PA) 

Centers the view around a point you choose by clicking in the drawing after you select 

Zooms>Pan from the menu. The magnification or zoom level of the drawing does not 

change. Pan is useful for viewing portions of the drawing that lie beyond your current 

view. 

Zoom AutoPan (AA) 

Allows you to drag the drawing around onscreen by holding down the left mouse button 

after you start Zooms>AutoPan (or type AA from the keyboard). Release the mouse 

button to end the command and the screen will redraw with the current view you have 

selected. Press the spacebar if you want to immediately repeat the command. 

If your mouse has a middle mousewheel, you can just press and hold down the middle 

mousewheel without having to type AA. Drag the drawing to pan it and release the 

mousewheel when you are satisfied with the view and the screen will redraw. 

Zoom All (ZA) 

Fills the screen with the entire drawing. Zoom All is useful when you want an overview 

of your work. 

Zoom Window (ZW) 

Fills the screen with the objects contained in a selection frame you draw. Click to select 

the first corner point, drag the cursor and select the opposite corner point. The screen 

display will zoom to the window created by those two points. 



 

72 Viewing the Drawing 

 

Zoom In (ZI) 

Enlarges the view using the multiplier you set for Zoom Factor (set on the System1 screen 

of the Settings dialog). You can also set Visual CADD™ to prompt you to click in your 

current view to locate the center of the new zoom view. If you do not set the prompt, the 

new view will use the same center of view as the current view. 

Zoom Out (ZO) 

Reduces the view by the Zoom Factor (set on the System] screen of the Settings dialog). 

You can also set Visual CADD™ to prompt you to click in your current view to locate 

the center of the new zoom view. If you do not set the prompt, the new zoom view will 

use the same center of view as the current view. 

Zoom Selected (ZS) 

Fills the screen with the objects that you have selected on-screen before starting the 

Zoom>Zoom Selected command. Zoom Selected is useful for focusing on specific 

objects. The objects remain selected after the zoom command finishes, so you can start 

another command, for example if you want to move or copy the objects. 

Zoom Previous (ZP) 

Returns to the previous view. Zoom Previous is useful when you are editing at a close in 

view and want to return to an overview or adjacent view. Repeating the command will 

toggle between the two most recent views set by the other zoom and pan commands. 

Zoom Value (ZU) 

Enlarges or reduces the view by a ratio of the actual size of the objects. You set the ratio 

on the ZoomValue speedbar, select [OK] (or ENTER) and then click to locate the new 

center of the window. A value of 2, for example, displays objects at twice their previous 

size. See the Help file topic for a more complete explanation. 

Birds-Eye View  
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From the View menu click on Bird’s-Eye View (or 

type ZB) to open a small window displaying a 

thumbnail of your drawing. Click in the bird’s-eye 

view window to center the new drawing view around 

that point. Right click for other options. You can “roll 

up” the dialog by double clicking on it so that only the 

title bar is displayed. Roll it back down again when 

you need to use Bird’s-Eye View by double clicking 

on the title bar. 

Click the left mouse button and hold it down to grab 

the selection frame in the bird’s-eye window and drag 

it to a new location. To create a new frame, hold 

down SHIFT as you drag to draw a selection frame 

within the existing selection frame and release to set 

the lower right corner. 

 

Tip 
Hold down the left mouse button and drag on any border to resize Bird’s-Eye 
View. 

Naming Views for Easy Reference  

If you find yourself returning to the same view repeatedly in a drawing, you can name the 

view and then quickly select it later from a list of saved views. 

To name the current view for later use: 

1. Select Zooms>Name View or type NV. 

2. In the speedbar, enter a name. 

3. Click [OK] or press ENTER. 

To use a named view: 

1. Select Zooms>Zoom View or type ZN. 

2. Select a named view from the list, and then click [OK] or press ENTER. 
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To delete a named view: 

1. Select the Zooms>Zoom View or type ZN. 

2. Select a named view from the list, and then select the Remove View button. 

3. Click [OK] or press ENTER to end the command. 

Working on a Drawing in Multiple Windows  

In Visual CADD™, you can open multiple windows to work simultaneously with several 

views of the current drawing. 

Having multiple views open is a good technique for working on different parts of a large 

drawing, such as a floor plan of a house or office building. You can start a tool in one 

view and end it in another. For example, begin a line in one view and move the cursor to 

the other view. The rubberbanding as you drag the mouse will show in the second 

window and you can place a point to complete the line. 

When you save a drawing, you also save the number and arrangement of windows as well 

as the view each window displays, including layer information. When you open the 

drawing file again it opens to the same set of windows. 

Using Multiple Windows 

Display different layer information in multiple windows. 

 

Use the Zoom In command to see enough detail to snap points precisely to each of the 

two opposite ends of a drawing. 
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Tip 
Use Tile Horizontal or Tile Vertical from the Windows menu to arrange the views 
of your drawing. Drag the borders of a window with the mouse to resize the 
window. 

To open a new window displaying the active drawing: 

Select Zooms>Multiple Views>Create New View (VW). 

To do a Zoom All command on all open views: 

Select Zooms>Multiple Views>Zoom All Views. 

To refresh each open view of the current drawing: 

Click the Zooms>Multiple Views>Redraw All Views, or hold SHIFT and perform a 

redraw by typing the 2 letter command RD or pressing the Redraw button on the toolbar. 

The views will be refreshed but the current zoom level of each view will not change. 

Tip 
To delete a view, close it with the "x" button in the upper right corner of the 
window of the view, then save the drawing. 
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C H A P T E R  

8 
MODIFYING OBJECTS 

In conventional drafting, you hope to draw objects only once. But in fact, the old adage 

advises: draw no more in the morning than you can erase in the afternoon. It is quite 

different when drawing in CADD. 

You tap the power of Visual CADD™ when you need to alter and manipulate objects. 

After drawing basic shapes, use the editing tools to quickly refine them. 

As part of a building renovation, for example, you need to complete as-built drawings 

and reconcile some of the measurements. In Visual CADD™, it is easy to stretch 

individual lines to change the drawing. 

As part of a new building design, you will want to add windows or doors to the walls 

after first drawing them. In Visual CADD™, you simply break the lines and then place 

the symbols for doors and windows where the lines break. 

Perhaps you are ready to draw building elevations. In Visual CADD™, you can extend 

construction lines from the plan into an adjoining area of the drawing and start to draw 

the elevations. Once completed, you can trim the construction lines back to the plan. 

When drawing a complex mechanical part such as a cam, for example, you can draw the 

ellipses and arcs that make up the cam shape, and then use Booleans to create a smooth 

final shape. 

In the hundreds of modifications you make in a drawing, the ability to quickly make 

editing changes greatly increases your productivity. 
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Selecting and Deselecting Objects  

Visual CADD™ provides tools to select only the objects you want to edit. You can select 

objects individually, in groups, and by type, properties or layer by using the Selection 

tool, the Group command, the Select commands on the Edit menu, or the buttons on the 

selection speedbar. Objects remain selected until you either edit them or explicitly 

deselect them. Select a set of objects to edit by repeating and combining selection 

commands to build a selection set. If you have not selected any objects before beginning 

to edit, Visual CADD™ prompts you to select an object and opens the selection 

speedbar. You can open the selection speed bar at any time by typing S1. 

Using the Selection Tool 

The default selection tool selects an object when you click on that object. To select 

multiple objects, hold down the SHIFT button as you click additional objects, or when you 

draw a selection frame around a group of objects. 

The selection tool deselects all objects when you click in an empty portion of your 

drawing, and a single object when you press CTRL and then click the selected object. 

Tip 
To select most but not all the objects in your drawing, select Edit>Select 
By>Select All (or type SA), and then deselect unwanted objects. 

Selection Settings 

Search Tolerance 

Search Tolerance, found on the System] screen 

of Utilities>Settings, specifies the maximum 

distance the cursor can be from an object for 

Visual CADD™ to snap to or select it. The 

Search Tolerance value also determines the size 

of the aperture. Anything within the aperture is 

within the snap or select range specified by the 

Search Tolerance. Although it is a handy reference, the aperture does not need to be 

visible onscreen. Toggle it on/off from the Snaps menu, the Running snaps dialog (RN) 

or by typing AP. 
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Quick Search 

If Quick Search is checked, the object drawn earliest within the search tolerance of the 

cursor is selected when you left click. 

Backward Redraw 

With Backward Redraw checked on the Zooms menu and Quick 

Search checked on the System] dialog, the object drawn most 

recently within the search tolerance of the cursor is selected when 

you left click. 

Selection Color 

By default, objects appear pink (Magenta) when selected with the cursor. You can change 

the color of selected objects from the Selection dropdown list in the Display Colors 

section of the System] dialog from the Settings menu. 

Selection Tools 

The following selection tools are available from the Selection speedbar (S1), or from the 

Edit>Select By menu section. 

All (SA) 

When you choose this tool, all objects in the drawing are selected. 

Window (SW) 

The tool draws a box enclosing the objects that you want to 

select. Click and hold the left button and drag the mouse to 

the right and release the mouse to define the opposite 

corner. Objects whose endpoints are completely within the 

window will be selected. 

Crossing (SX) 

When you choose Crossing, you are prompted to draw a box 

from right to left that encloses or touches all of the objects 
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you want to select. The tool differs from Window in that any object touched, regardless 

of whether the endpoints are within the crossing window, will be part of the selection set. 

Tip 

If you are drawing with the Selection arrow as your default tool, simply click and 
hold to set first point and then drag the box to the right to enclose a window 
selection, or to the left to create a crossing selection. If you are drawing with 
single or continuous line as the default, type SE and these options will be 
available. Three commands in one! 

Object (SB) 

Selects a single object. When you start this tool you are 

prompted to select an object by clicking on it. 

Last (SL) 

Selects the objects that were first selected during the last editing operation or before the 

last selection was cleared using the Clear List tool. If you selected 4 objects and copied 

them, this command will select the 4 original objects and not the copies. 

Modified (SU) 

This command selects the last copied object or objects in the drawing. It is an alternate to 

Select Last. which only selects the original objects you first selected to use in creating the 

new copied objects. 

Last Object (LO) 

Selects the last object placed in your drawing. This can be a new entity, such as a line just 

drawn, or a modified entity, such as a line or circle that is copied from an existing entity. 

Note that this command is different from Select Last, which only selects the last 

unmodified entities in the drawing, and Select Modified, which selects the last copied 

entities. 

Select Last Object does not care. It selects the last object placed in the drawing. To select 

multiple objects, press the spacebar to repeat the command. 
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Adjoining (SJ) 

When you click this tool you are prompted to select an 

object. When you click one of the objects in a series of 

objects that share end points all objects in that series are 

selected. Press TAB to display branching selection alternatives, and then click to select. 

Layer (SY) 

This tool selects all objects on the layer you specify. 

Invert List (IS) 

This tool deselects all selected items and selects all other items in the drawing. 

Clear List (CS) 

This tool deselects all selected items. 

Selecting Objects by Properties and Type  

Using the Selection Filter command, you can specify criteria for quickly selecting 

multiple objects to modify them. Select objects based on type of entity, color, linetype, 

linewidth, and/or layer. You can select text that uses a specific font. And you can select a 

symbol, hatch, or Reference Frame by name to find all occurrences of that symbol or 

hatch or RF. 

Selection Filter Speed Bar 

The Selection Filter speedbar opens when you select Edit>Selection Filter. 
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A Sets the type of object as a search criterion. 

B Sets a layer as a search criterion. 

C Sets the color of objects as a search criterion. 

D Sets the line type of objects as a search criterion. 

E Sets the line width of objects as a search criterion. 

F Resets the selection filter speedbar criteria to All. 

G When clicked, sets the selection filter criteria to match the properties of 
the next object you click. 

H Saves the new criteria and closes the selection filter speedbar. 

I When checked, turns on the Selection Filter. 

When you tick the Filter checkbox on the Selection Filter speedbar, or the Use Filter 

checkbox on the Selection speedbar (S1), and then apply a selection command, it selects 

only those objects that meet all of the filter criteria you have set on the selection filter 

speed bar. For example, you can select all red entities on layer 5, or all Bézier curves with 

line type 8. 

Use the Selection Filter speedbar to quickly select specific objects in a complex drawing. 

See the Help file for additional details and a number of tips on how to get the most out of 

this tool. 

Tip 
To select objects based on more than one set of criteria, set the selection filter 
for the first selection criteria, perform the selection, and then set the filter for 
another set of criteria and select again. 

To select objects by properties and type: 

1. From the menu choose Edit>Selection Filter or type SF to 

start the command. Filter criteria from the last time the 

filter was used will appear. Click the Reset button to clear 

old data. 

 

2. Select an Entity type and then other criteria from the 

dropdown lists, make sure the Filter checkbox is ticked, 

and then click [OK]. 
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3. Use an appropriate selection command or tool, such as Select 

All, to select objects using the criteria of the selection filter. 

4. Make changes to the selected objects as desired. For 

example, change the font of all selected text or the color or 

linewidth of all selected lines. 

 

 

Tip 
To use an object in the drawing as a selection criterion, click Match on the 
selection filter speedbar, and then click the object. Visual CADD™ will apply 
all properties of the object into the selection filter boxes. 

Creating Groups  

The Group commands are powerful tools that will help organize your drawings. A Group 

is created when you select a collection of objects and run the Group command. Now, any 

time you select any object in the group, the entire group is selected in the drawing. A 

Group is saved with a drawing. 

Groups are similar to Symbols in that several objects become one object, but they are also 

quite different. A Symbol has a name and can be saved to disk and then inserted into any 

other drawing via the Symbol Manager. A Group exists only in the drawing it was 

created in and cannot be saved to disk separately from its drawing. However, you can 

Copy and Paste a Group into another open drawing. And if you Merge a drawing into 

another drawing, any Groups that exist in the original drawing will also be merged into 

the other drawing. 

One advantage Groups have over Symbols is that they can be easily modified. Once a 

Symbol is created, to make any changes you must explode it into individual objects, 

make the changes, and recreate the Symbol. With a Group you can modify all objects at 

once, or by pressing the ALT key, select an individual object in the Group and modify it 

without affecting other objects in the Group. Save the drawing to save the change in the 

Group. 

Groups can be selected with all the usual selection tools. You can Ungroup any Group to 

return it to a collection of individual objects, and add or remove objects from an existing 

group. See the Help file for complete details. 
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Deleting Entities and Undoing Actions  

In Visual CADD™, you can delete a selected object or group of objects, the last point 

placed, the last object drawn, or the entire drawing. 

You can also undo drawing or editing actions. If you accidently undo an action, you can 

redo it. Visual CADD™ does not limit the drawing actions you can undo and redo. 

If you run the Pack Data command from the Utilities menu, you can only undo and redo 

the drawing actions that follow that command. The Pack Data command deletes all 

record of earlier changes from the drawing database, to free up memory. 

We recommend that you use the Pack Data command occasionally on each drawing to 

clean up the drawing database. In order for undo/redo to function properly, each entity 

must remain in the database, even after it has been erased from the screen. File sizes can 

become quite large, and occasionally corrupted drawings result. Use Pack Data in each 

drawing when you are satisfied that you no longer need to undo/redo recent work. 

To Delete an Object or Objects: 

1. Select the object or objects you want to delete. 

2. Press the DEL key or type ER. 

To … Do This … 
Delete one or more selected objects Select the object(s) you want to delete, 

then select Edit>Erase, type ER, or 
press DEL. 

Delete the last object drawn or modified Select Edit>Erase Last or type EL. 
Remove the last segment drawn while 
drawing a continuous line, irregular 
polygon, a boundary hatch, or a boundary 

Right-click and then select Undo Vertex 
or type UV. 

Undo your last operation Select Edit>Undo or type OO. 
Cancel the last Undo Select Edit>Redo or type RE. 
Delete the entire drawing Select Edit>Clear Drawing. Caution: 

Once you clear a drawing, you cannot 
retrieve any part of it. 
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Viewing the Results of Your Edits  

When you move, delete, or change an object that overlaps another object, the screen 

displays a break in the remaining object. Selecting Zooms>Redraw or typing RD updates 

the screen display. 

Redraw time for a complex drawing can be lengthy if you have an older machine, so you 

might want to redraw only the portion of the drawing on the screen. 

By default, Visual CADD™ redraws objects in the order in which they were drawn.   

You can reset Visual CADD™ to redraw the newest objects first, which is useful when 

you want to update only the last few entities drawn. 

To redraw only a portion of a drawing: 

1. Select Zooms>Redraw Window. 

2. Draw a selection frame around the area you want to update. 

To redraw newest objects first: 

Select Zooms>Backward Redraw to check it. 

Breaking Lines  

Visual CADD™ has two break commands: Break and MultiBreak. Use 

them to create a gap in any object(s) except text, dimensions, symbols, 

attributes, hatches, and fills. For example, use MultiBreak to break the 

lines delineating a wall to insert a door symbol. 

When you apply a break: 

 Polygons and rectangles remain continuous lines. 

 Circles become arcs. 

 Ellipses become elliptical arcs. 

 Open objects, such as continuous lines and arcs become two objects of the same type. 
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Break is a persistent command, enabling you to break any number of objects, one after 

another. Break repeats until you press ESC or choose another command or tool. 

MultiBreak, on the other hand, is not persistent. To repeat this command, press the 

spacebar. 

How Far Can a Gap Span? 

In lines drawn with the Continuous Line tool, the Continuous 

Bézier tool, and the Spline Curve tool, you can begin a break 

at any point in one segment and end it at any point in another 

segment. 

To insert a gap in a line: 

1. Select Modify>Break from the menu or click on the 

toolbar button. 

 

2. Click the object in which you want to create the break. 

 

3. Place a point where you want the break to begin. 

 

4. Place a point where you want the break to end. When finished, press ESC. 

The same sequence applies to the MultiBreak command, except that you should select 

objects before starting the command, and since it is not a persistent command it does not 

require an ESC; it will end when you place the second break point. 

Tip Any command in Visual CADD™ can be repeated by pressing the spacebar. 
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Extending Lines to Objects  

You can extend portions of already drawn lines to another object. You can extend any 

line, arc, or complex curve to any entity except text and attributes. Separate tools give 

you the option to extend one line or several lines at once. 

Extend Single is a persistent command, enabling you to extend a series of lines, one at a 

time. It repeats until you press ESC or choose another command or tool. Extend Multiple 

is not, and ends after completing one instance of extending multiple lines. 

To extend one line to an object: 

1. Start the Extend Single tool from the toolbar, and then click the line you want to 

extend. 

2. Select the object to which you want to extend the line. Repeat on additional lines as 

desired then press ESC to exit the command. 

To extend several lines to an object: 

1. Select the lines you want to extend, and then start the Extend Multiple tool. 

2. Select the object to which you want to extend the lines. 
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Trimming Lines  

You can quickly erase a portion of a line that extends beyond another simple line or 

complex object. Visual CADD™ has three Trim commands: 

Trim Single (TR) deletes the portion of a line, arc, or 

complex curve that extends beyond another object. 

Trim Single is a persistent command, enabling you to 

trim a series of lines, one after another. Trim Single 

repeats until you press ESC or choose another 

command or tool. 

Trim Multiple (TM) deletes the portions of more 

than one line, arc, or complex curve that extend 

beyond any other object except a complex curve. 

Trim Intersection (IT) deletes the portions of 

crossing double lines that lie within their intersection. 

To trim a single line: 

1. Click the Trim Single tool from the toolbar, and 

then click the line you want to trim, on the end 

you want to retain. 

2. Click the object to which you want to trim the 

line. 

3. Continue steps 1 and 2 as desired to trim 

additional objects. 

4. Press ESC or Pen Up to finish the command. 

To trim several lines at once: 

1. Select the lines you want to trim, and then click the Trim 

Multiple tool from the toolbar. 

2. Select the object to which you want to trim the selected lines. 

3. Move your cursor from one side to the other of the object for a 

preview of trim options, and then click when you see the 

option you want. 
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To trim double lines at their intersection: 

1. Click the Trim-Intersection tool from the toolbar 

 

 

 

2. Click inside the crossing of the two pairs of lines. 

 

 

 

3. Move your cursor around the intersection for a preview of trim options, and then 

click when you see the option that you want. 

Reshaping and Moving Objects  

In Visual CADD™, you can reshape any object except a symbol. When you reshape an 

object, you move some of its construction points without moving others. When you 

stretch an object, all selected construction points move. You can also move an object 

without changing its shape. 

You can change the shape of an object by selecting one construction point and moving it 

with the Move Point command. Using Move Point in combination with the Near Point 

snap, you can also change the shape of multiple objects at one time if they each contain a 

construction point at a common location. Note that the Move Point command simply 

moves a symbol. You must explode a symbol before you can move points within it. 

You can move an entire object precisely with the Move command. Move an object 

quickly but imprecisely by simply selecting it and then click and hold the mouse down as 

you drag it around the drawing. 
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To reshape an object or objects by stretching: 

1. Select an object or objects, select Modify>Stretch or click on 

the toolbar button. 

2. Draw a selection frame around the points you want to 

stretch. 

3. Place a reference point establishing the stretch’s starting 

point. 

4. Move your cursor to preview stretch results. 

5. Place a reference point to establish the end point of the stretch. 

To reshape an object by moving a point: 

1. Select Modify>Move Point, and then select an object. 

2. Place a reference point establishing the move’s starting 

point. 

3. Place a reference point establishing the move’s end point. 

To reshape multiple objects by moving a common 
point: 

1. Select Modify>Move Point. 

2. Move the cursor near the common point, and then type NP. 

3. Place a reference point establishing the move’s end point. 

To move an object or objects to a precise location: 

1. Select an object or objects, and then select Modify>Move or click 

the button on the toolbar. 

 

 

2. Place a reference point defining the move’s starting point. 

Use a snap tool for precision placement. 

 



 

90 Modifying Objects 

 

 

 

 

3. Place a reference point defining the move’s end point. Here again, a snap tool will 

precisely place the move end point. 

Resizing Objects  

When you draw an object and later want to resize it, or when you merge one drawing into 

another and want them at the same scale, you can use two scale commands. 

The Scale command resizes an object at a ratio you specify. The Fit Scale command 

resizes one object to match the size of a second. 

When you resize an object by using the Scale command, you can resize in both X and Y 

directions independently, thereby distorting the object. To avoid distortion and resize an 

object or group of objects proportionally, enter equal values for both X and Y axes. 

Scale values of 1.0 are equivalent to full-size, or 100%. Values less than 1.0 reduce the 

selected object’s size. Values greater than 1.0 increase the selected object’s size. 

In most cases, changing the X scale value for an object resizes the object in the horizontal 

direction, and changing the Y scale value resizes it in the vertical direction. The X and Y 

scale values of rotated text and symbols, however, rotate with them. For example, text 

rotated to a 90° angle resizes in the vertical direction when you change the X scale value. 

Changing Scale Values 

Tip 
Mirror an object around its X axis by entering a negative X value. Mirror an 
object around its Y axis by entering a negative Y value. 
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To resize an object by changing X and Y scale values: 

1. Select the object or objects, select Modify>Scale or click the button 

on the toolbar. 

 

2. Place a reference point establishing the point from 

which the object(s) will be resized. 

3. Enter scale values for X and Y factors on the scale 

speedbar, and then click [OK]. 

To resize an object by example: 

1. Select the object or objects, select Modify>Fit Scale. 

2. Place two reference points within the selection to serve 

as the base distance to resize. 

3. Place two reference points anywhere in your drawing 

to establish the distance to which you want to resize the 

selected object or objects. 

Skewing an Object  

Use the Skew command to change the shape of selected objects in the drawing. You will 
find the command useful on a wide range of objects, from rectangles and polygons to 
circles and arcs. The example shown is a rectangle that has had the Skew command 
applied. 

To skew a selection: 

1. Select the object(s) you want to skew. 

2. Start the Skew command from the Modify menu or type KW. 

3. Place an origin point. A speedbar will appear, prompting you 

for a Skew Angle. 

4. Type in an Angle. 

5. Click the [OK] button on the speedbar or press enter. 

6. As an alternative, with Ortho off, use the mouse to drag the object to set the angle. A 

dotted rubberband will show you a preview. Left click the mouse to set the skew 

angle. 
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Rotating Objects  

You can rotate an object or group of objects around any point that you place in your 

drawing. You can rotate precisely by entering an angle value; or you can rotate by 

moving the mouse (with Ortho off). The dotted rubberband will give a preview. 

Rotation Angle 

Rotation angle 0° measures counter-clockwise from a 3 o’clock position. 

If the object you want to rotate already lies at an angle, add the object’s base angle to the 

angle of rotation for the new base angle. 

 

To rotate an object: 

1. Select an object or objects, and then select Modify>Rotate or 

click the Rotate button on the toolbar or type RO. 

 

2. Place a reference point for the center of rotation. 

 

3. Enter a Rotation Angle value in the rotate speedbar, and then click 

[OK], or move the mouse and then click to set the rotation.  
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Tip 
Set the rotation angle quickly after Step 2 by clicking the match button on the 
speedbar and then select an object in the drawing whose angle you want to 
match. Press the [OK) button to finish. 

Moving and Rotating Objects in One Operation 

To move an object(s) and change its angle at the same time, use the Align command. The 

Align command changes the orientation of an object or a group of objects to match that 

of an existing object or an angle that you create by placing points. 

Moving and rotating is a three-step process. First, you define reference points on the 

selected object, then you define a target point to which the first reference point on the 

selected object(s) moves, and finally you define a target point that establishes the new 

angle of the moved object(s). 

To move and rotate an object: 

1. Select one or more objects, then select Modify>Align. 

2. Place two reference points on the selected object to define the 

move and rotation points. 

 

3. Place a target point to establish where you want to move 

the first reference point on the selected object to. This can 

be a snap to an endpoint of an existing line, for example, 

or a click on a blank space in the drawing. 

 

4. Place a second target point that defines the new angle of 

the selected object. Snap to the other end of an existing 

line, or click a second point in the drawing. 

5. The first reference point of the object(s) will move to the first target point, and the 

object(s) will rotate to the angle specified by the second target point. 

Tip 
To better understand Align, draw a rectangle at 0° and a line at 45° that is longer 
in length than the rectangle. Using the steps above, select the two reference 
points on the rectangle. Snap to the lower end of the line (first target) and then 
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the upper (second target). The rectangle will move to the lower end of the line 
and match the angle of the line. 

Inserting a Chamfer or Fillet Between Two Lines  

After you have drawn two lines that intersect, you can angle or curve the intersection. 

When you chamfer the intersection of two lines, a third angled line joins them. When you 

fillet the intersection of two lines, an arc joins them. 

You can also set the double line tool to automatically fillet the corners of line segments as 

you draw. Do this by setting the Auto Fillet option from the menu Utilities>Settings 

General dialog or on the Double Line Settings speedbar. 

Note 
Both the Chamfer and Fillet commands are persistent, repeating until you 
press ESC, select another tool, or choose another command. 

To insert an angled intersection between two lines: 

1. Select the chamfer tool. 

2. Right click, and then select Chamfer Dist. 

3. On the Chamfer speed bar, set the Chamfer distance(s) using 

the TAB key, and then click [OK] or ENTER. 

4. If only two entities intersect, click between them. If more than 

two entities intersect, click the two that you want to chamfer. 

To insert a fillet between two lines: 

1. Select the Fillet tool. 

 

2. Right click, and then click Fillet Radius. 

 

3. On the Fillet speed bar, set the Fillet Radius, and then click [OK]. 
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4. If only two entities intersect, click between them. If more 

than two entities intersect, click the two that you want to 

fillet. 

 

5. Move the cursor around the intersection for a preview of the 

fillet options, and then click when the preview fillet is 

located correctly. 

To curve the vertices of a double line as you draw: 

1. Start the Double Line tool. 

2. Right click, and then click Fillet Radius. Enter a value in the Fillet 

Radius box on the Fillet speedbar, and then tick the Auto Fillet 

checkbox. 

3. Tick the Preview Fillet checkbox to see the fillets as 

you draw, and then click [OK] to close the speedbar 

and begin drawing. 

 

Exploding and Joining Objects  

When you want to edit an object contained in a compound or complex object, such as a 

symbol or dimension, you must first explode the object. You can join individual lines to 

create a single object. 

Exploding Objects into Their Basic Components 

The various complex objects will explode in different ways: 

 Continuous lines, rectangles, and polygons into collections of single lines 

 Continuous Bézier and spline curves into collections of single Bézier curves 

 Dimensions into lines, fills, and text 

 Vector text into lines and arcs 

 Symbols and attributes into the objects and text used to create them 
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 Hatch patterns into collections of individual lines 

 Fills into the lines that bound them 

You cannot explode basic objects, such as single lines, arcs, circles, ellipses, single 

Bézier curves, and TrueType text. 

If the object you are exploding contains compound objects, you may need to explode it 

several times before you are able to select the entity you want to edit. 

Tip 

Select exploded objects easily with the Select Adjoining tool found on the 
Edit menu. 

Explode continuous lines, rectangles, and polygons when you draw them by 
ticking the Explode Cont. Lines checkbox on the Utilities menu 
Settings>System1 dialog. 

To explode an object into its basic components: 

1. Select the object that you want to explode. 

2. Select Modify>Explode from the menu or click on the button 

in the toolbar. 

Joining Objects 

The Join command creates one object from a series of lines that are connected. For 

example, if you create a series of line segments using the Continuous Line tool, and then 

explode it to create separate segments, you can rejoin the lines using the Join command. 

To join a series of line segments: 

1. Select the line segments you want to join. 

2. Select Modify>Join. 

Creating Copies of an Object  

Visual CADD™ provides you with several ways to copy a selected object or objects: 

 Copying to and pasting from the Windows clipboard 
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 Using one of the Copy commands 

 Creating a mirror-image copy 

The Cut and Copy commands on the Edit menu place copies of selected objects on the 

Windows clipboard. When you choose Paste from the Edit menu, Visual CADD™ copies 

the object from the clipboard to your drawing. The Copy and Paste commands are the 

easiest way to copy part or all of one drawing into another open drawing (you can also 

Paste the clipboard contents into other Windows applications). 

The Mirror, Multiple Copy, Linear Copy, Single Copy, Radial Copy, and Array Copy 

commands let you copy objects precisely in your drawings using the Snap commands. 

A mirror-image copy is useful when you are drawing an object with axial symmetry; 

draw only half the object and use Mirror to create the other half. 

Four copy commands—Multiple Copy, Linear Copy, Radial Copy, and Array Copy— 

can produce as many copies of an object or objects as your computer’s memory allows. 

You provide spacing and angle parameters, and the objects are arranged as you specify. 

Single Copy makes one linear copy of the object or objects you select. 

Choosing a Technique for Creating Copies of an Object 

Multiple Copy 

Multiple Copy places duplicates of selected objects wherever you click in your drawing. 

You continue placing copies of the original until you click Pen Up or press ESC. 

Linear Copy 

Linear Copy arranges duplicates of selected objects in a line. 

You set the number of copies you want, define the distance and 

direction between the original object and the first copy, and 

then set the distance between each object. 

Single Copy 

Single Copy works the same as Linear Copy but duplicates the 

selection only once. 
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Radial Copy 

Radial Copy arranges duplicates of selected objects 

equidistant from a center point you place, rotating 

each to maintain the same relationship as the original 

object to the center point. You set the number of 

copies you want and the angle that the original and 

its duplicates will span. 

Array Copy 

Array Copy arranges duplicates of selected objects in 

evenly spaced rows, forming a grid. You set the number 

of copies you want and the number of rows. You define 

the distance and direction between the original object and 

the first copy, and then define the distance and direction 

between rows. 

Mirror 

Mirror creates a mirror-image copy of selected objects around an axis you define. 

To create a mirror image copy: 

1. Select one or more objects, and then click the 

Mirror tool from the toolbar. 

2. Place a reference point defining the first point of 

the axis around which to mirror the object(s). 

3. Place a reference point establishing the second 

point of the axis and setting the copy’s position 

To create multiple copies: 

1. Select one or more objects, and then click the Multiple-Copy tool. 

2. Place a reference point on the object(s) to create a handle. 

3. Click in your drawing to place each copy. To finish, right click and then select Pen 

Up. 
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To create a single copy: 

1. Select one or more objects, and then click the Single Copy tool. 

2. Place a reference point to define the starting point of the copy. 

3. Place an offset point to define the location of the copy in the drawing. 

To create a linear copy: 

1. Select one or more objects, and then click the Linear Copy 

tool from the toolbar. 

2. On the Linear Copy speedbar, enter the number of copies (not 

including the original object), and then click [OK]. 

3. Place two reference points anywhere in your drawing to 

establish the distance between each. 

To create radial copies: 

1. Select one or more objects, and then click the Radial Copy 

tool from the toolbar. 

2. On the Radial Copy speedbar, enter the number of copies 

(including the original object) and the span angle, and then 

click [OK]. 

3. Place a reference point anywhere in your drawing to define 

the center point of the circular array. 

To create an array copy: 

1. Select one or more objects 

2. Click the Array Copy tool from the toolbar. 

3. On the Array Copy speedbar, change the 

number of copies to be in each row (not 

including the original object) and the 

number of rows, and then click [OK]. 

4. Place two reference points anywhere in your drawing to define the distance and 

direction between the original object and the adjacent copy. 

5. Place a reference point to define the distance between rows. 
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Note 
Copied objects always take on the properties of the object(s) you are copying 
from, no matter what settings are current in the drawing. Objects that are Offset 
(described below) always take on the current drawing properties. 

Offsetting Objects from an Original Object  

Use the offset tool to create an object that is parallel to and around or inside the selected 

objects. The offset tool often makes a scaled copy of the original object, but it also 

frequently results in an object that is quite different from the original. 

You can offset a single entity or an object composed of multiple entities. You also can set 

the distance of the offset copy from the original visually or numerically. 

Typical Offset Results 

Use the offset tool to make scaled copies of many regular object. 

Several entities change type when they are offset: 

 Continuous Bezier becomes a Single Bezier curve 

 Ellipse becomes a Continuous Bezier curve 

 Elliptical arc becomes a Continuous Bezier curve 

 Spline curve becomes a Single Bezier curve 

To offset an object: 

1. Select an object, and then click the Offset tool. 

2. To preview more than two offset options, make 

sure Fixed Distance is unchecked. To specify a 

precise offset, enter a value in the Offset Distance 

box, check Fixed Distance, and then click [OK]. 

3. If Fixed Distance is unchecked, move the cursor inside and outside the original object 

to preview the offset options, then click when you see the option you want. 
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Note 

An object created by the Offset command takes on the current property settings, 
which may be different than the properties of the original object. This is different 
than the Copy command, in which the copy retains the properties of the original 
object regardless of the current settings. 

Dividing Objects into Equal Parts  

With the Divide command you can divide lines, arcs, and circles into any number of 

equal segments. You have the option of simply placing Points on the entity or actually 

breaking it into new objects of equal length. 

There are many uses for this tool while drawing and editing. For instance, you could 

draw a line from floor to floor in a building section and then divide the line into equal 

spaces to locate where the stair treads and risers will be placed. 

To Divide objects: 

1. Select an object or objects to divide. 

2. Begin the command by selecting Modify>Divide from the menu or typing IV. 

3. Input the number of segments that you want to divide the object into. 

4. If needed, change the setting to either add points or actually break the object. 

5. Click [OK] to complete the command. 

Combining Objects to Create a New Object  

Sometimes creating an object by combining existing entities is easier than drawing it 

from scratch. The Boolean command joins two selected, overlapping closed objects of 

any type into a mixed entity path, enabling you to preview and choose from at least three 

variations. You preview these options by moving your cursor around the selected objects. 

The variations create an object that results from: 

 The union of the selected objects, retaining all outer portions 

 The intersection of the selected objects, retaining only those portions that intersect 

 The subtraction of one object from the other, retaining portions that lie outside the 
limits of the other 
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Boolean Variations 

To create a new object from existing entities: 

1. Select two overlapping closed objects, then select Modify>Boolean. 

2. Move your cursor around the objects for a preview of Boolean options, and then click 

when you see the option that you want.  

Using Polygon Merge and Split 

You can split or merge polygons using these commands. 

Polygon Merge 

The Polygon Merge command joins together two polygons that are touching or 

overlapping. 

To merge two polygons: 

1. Select two polygons that are touching or overlapping. 

2. Select Modify>Merge Polygon. The two polygons join to become one object. 

Polygon Split 

The Polygon Split command, splits a single polygon into two or more polygons along one 

or more cut lines that you specify. 

To split a polygon: 

1. Select the polygon that you want to split. 

2. Select Modify>Split Polygon. Notice that the Status Bar prompts you to enter a start 

point. 

3. Click in the drawing area (or enter coordinates) to specify the start and end points of 

the line that will split the polygon. 
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4. If you want to split the polygon into more than two objects you can create more line 

segments to split the polygon. 

5. When you have finished defining the cutting lines, double click or right click and select 

Pen Up. The polygon is split into two or more separate objects. 

Draw Order  

The four Draw Order commands change the display and Print/Plot order of objects 

already placed in Visual CADD™. In addition to moving objects to the "front" or "back" 

of the sort order, you can order objects relative to another object (that is, above or below 

a selected object). 

As new objects are drawn, they are placed last in the draw order database, so they draw 

first, or in front of other objects. Draw Order maintains a separate list that keeps track of 

objects in relation to each other, allowing for precise placement when you modify an 

object with one of the four commands. 

Bring to Front (DWF) 

Moves the selected object(s) to the top of the order of objects in the drawing, so that they 

draw last. 

Send to Back (DWB) 

Moves the selected object(s) to the bottom of the order of objects in the drawing, so that 

they draw first. 

Bring Above Object (DWA) 

Moves the selected object(s) above a specified reference object. After selecting an object 

and starting the command, the tool will prompt you in the status bar to specify the 

reference object that you want the selected object to draw above or on top of. 

Send Behind Object (DWH) 

Moves the selected object(s) below a specified reference object. After selecting an object 

and starting the command, the tool will prompt you in the status bar to specify the 

reference object that you want the selected object to draw behind or under. 
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Changing Properties  

Use the Change command from the Modify menu to make changes to the 4 basic 

properties of selected objects: layer, color, linetype, and width. 

To change the properties of selected objects: 

1. Select one or more objects. 

2. Start the Change command from the Modify menu or by typing CG. 

3. A speedbar appears with 4 dropdown boxes. If a single object or multiple objects 

with the same properties are selected, the current properties are displayed. If multiple 

objects with different properties are selected, three stars (***) will be shown in the 

dropdown box. An example would be where one object has the color red and another 

has the color blue. 

4. Click on the dropdown box to expand the list of the property you want to change, and 

make a selection. Repeat for other properties if desired, then click [OK] or ENTER 

from the keyboard to complete the command. 

Tip 

A quick way to change all properties of an existing entity to match those of 
another is to select an object(s), type CG then = sign, and click the entity 
that you want to match. 

To change properties quickly from the keyboard, position the cursor on the 
Change speedbar, click the right mouse button, and click Fast Properties. 
The expandable dropdowns will disappear and are replaced by edit boxes. 
This allows you to type changes without having to move the mouse up to the 
speedbar. For example, typing CL15 and then ENTER will immediately set the 
current layer to 15 without having to even look at the speedbar. In addition to 
CL for layer, other keyboard shortcuts to use with this method are CP for 
color, TL for linetype, and WP for linewidth. 

You can also make changes to the properties from the dropdowns on the 
main toolbar. Select one or more objects, drop down a list and make 
changes. Repeat to change other properties. When finished, click in a blank 
area of the drawing or start a command to deselect selected entities. 
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C H A P T E R  

9 
DIMENSIONING AND MEASURING 

Dimensions enhance the clarity of graphical information in a drawing. They provide a 

sense of scale, and they define geometric relationships. 

To create dimensions in hand drafting, usually the dimension is scaled to represent lines 

and other objects that are often much larger or smaller in the real world. In Visual 

CADD™, you always draw at real-world scale, also known as 1:1, so you do not need to 

think of scale when creating dimensions. Simply define the points or objects to 

dimension, and Visual CADD™ creates an accurate dimension. You can override Visual 

CADD™’s measurement and provide your own dimension values if needed. 

Dimension settings and properties allow you to match your Visual CADD™ drawings to 

your drafting standards. You can also adjust all or part of a dimension for legibility, after 

they are placed. 

Visual CADD™’s dimensions update when you make changes to your drawing. You can 

stretch or scale objects, and their dimensions will update to reflect the changes, as long as 

the dimension is also part of the selection set. This is called associative dimensioning, 

and it makes it easy to revise drawings. 

You can create Leaders, sometimes referred to as callouts, to describe an object or 

assembly. A leader has text with a line and arrow pointing to the objects. 

Visual CADD™ has several tools for quickly finding distances, areas, and angles, so you 

can make measurements in a drawing without creating permanent dimensions. 

Visual CADD™ has a Multiple Dimensions command, allowing you to quickly 

dimension several objects at once with a single command. 
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Adding Dimensions to a Drawing  

Adding dimensions to your drawing does not require knowledge of dimension settings; 

you can use the default Visual CADD™ settings to get started, and you can also change 

dimension settings before, during, or after creating a dimension. 

Selecting points and objects precisely is crucial to accurate dimensioning. While creating 

dimensions, use the snap commands to select precise points on the drawing geometry 

rather than estimating endpoints or intersections. 

To create a single linear dimension: 

1. Click the Linear Dimension tool. 

2. If it is not already set, right click and select Dim 

Mode : Single from the popup menu. 

3. Click anywhere on a line, or snap to the start and end points of the line for the 

dimension. 

4. Drag the dimension away from the line with the mouse and click where you want to 

place it. 

To create a chain of linear dimensions: 

1. Draw 3 horizontal lines that share common 

endpoints. 

2. Click the Linear Dimension tool. 

3. If it is not already set, right click and select Dim Mode : Partitioned from the popup 

menu. 

4. Click on the first line or the start and end points for the first dimension of the chain, 

and then click where you want to place the dimension line. 

5. Snap to the endpoints of the remaining lines and the dimensions will be automatically 

placed. 

6. Right click and select Pen Up to end the command. 

To draw a baseline dimension: 

1. Draw 3 horizontal lines that share common 

endpoints. 

2. Click the Linear Dimension tool. 
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3. If it is not already set, right click and select Dim Mode : Cumulative from the popup 

menu. 

4. Click on the first line or the start and end points for the first dimension of the chain, 

and then click where you want to place the dimension line. 

5. Snap to the endpoints of the remaining lines and then place the dimension lines. 

6. Right click and select Pen Up to end the command. 

To Dimension an angle: 

1. Click the Angular Dimension tool. 

2. Click the arc or the three points that define the angle. 

 

 

 

3. Drag the cursor and then click where you want to place 

the dimension arc. 

 

 

To dimension the radius of an arc or circle: 

1. Click the Radial Dimension tool. 

2. Click on the circle or arc that you want to dimension. 

 

 

3. Drag the cursor and click where you want to place the dimension. 

To dimension the diameter of an arc or circle: 

1. Click the Diameter Dimension tool. 



 

108 Dimensioning and Measuring 

 

2. Click on the circle or arc that you want to dimension. 

3. Drag the cursor and then click where you want to place the dimension. 

To dimension a series of offsets from a basepoint:  

1. Click the Ordinate Dimension tool. 

2. Snap to establish a basepoint from which to measure the 

subsequent dimensions. In this example it is the lower 

right corner of the window sill. 

3. Drag the cursor in the direction that describes the 

positive axis of your measurements and click to set the 

direction. A rubberband appears with the first 

dimension. Drag it to the desired location and click to 

set. 

4. Snap to or click the points that you want for the 

remaining dimensions, then right click and select Pen 

Up to finish. 

To create a datum dimension  

1. Click the Datum Dimension tool. 

2. Snap to or click the point to dimension. 

3. Click additional points to draw the leader, right click, and 

then select Pen Up to complete the leader line. 

4. Press [OK] on the speedbar or press ENTER twice to place 

the datum text and complete the command. 

5. If you want to flip the datum text before completing the 

command, as shown in the illustration at right, click on the 

dimension, drag the cursor left or right, click again, then 

[OK] or double ENTER. 

To Place Multiple Dimensions 

1. Select the number of lines you want to dimension and then start the Multiple 

Dimension command from the Draw>Dimension menu or type MM. 

2. The first dimension will appear with a prompt to place it. The cursor will then 'jump' 

to your next selected line and prompt you to place a dimension. 

3. Continue placing dimensions. The command will end when you have placed the 

dimension of the last selected entity. 
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To get an idea how the tool works, draw a rectangle, use a selection window to select the 

entire rectangle, type MM, and place dimensions as prompted. 

Tip 

When placing a dimension, the Dim String tab on the speedbar shows the 
current actual value of the dimension. You can overwrite this value. After 
starting the dimension, tick the overwrite dimension checkbox in the speedbar, 
then type in a new dimension value. Clicking OK or pressing ENTER key 
updates the value and closes the speedbar. Finish placing the dimension with a 
left mouse click. 

Modifying Existing Dimensions  

In addition to modifying the properties associated with a dimension, you can also move 

dimension lines and text. 

To find the commands for modifying dimensions, right click after you select the 

dimension that you want to change. The options will vary according to the type and 

number of dimensions you select. 

To modify dimension properties: 

1. Select one or more dimensions that you want to edit. 

2. In the drawing area, right click and select Dimension Edit, or type ED. 

3. Modify the dimension properties that you want to change and click [OK]. 

To move dimension text: 

1. Select the dimension. 

2. In the drawing area, right click, and then select 

Dimension Text Move. 

3. Drag and then click where you want to relocate the 

dimension text. 

To slide dimension text along a dimension line: 

1. Select a linear, ordinate, diameter, angular or radial 

dimension. 

2. Right click, and then select Dimension Text Slide. 

3. Slide the dimension text along the dimension line, and click where you want to 

relocate it. 
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To move a dimension line: 

1. Select a linear dimension. 

2. Right click, and then select Dimension Line Move. 

3. Drag and then click where you want to relocate the 

dimension line. 

To move a dimension arc: 

1. Select an angular dimension. 

2. Right click and then select Dimension Arc Move. 

3. Drag and then click where you want to relocate the 

dimension arc. 

Adjusting Dimension Settings  

Dimension settings control dimension and extension lines, dimension text, and numeric 

formats. Adjusting dimension settings enables you to match dimension objects to your 

drafting standards. Each element of a dimension can be modified individually. 

Because Visual CADD™ works in real-world scale, consider your final output when 

adjusting dimension text and elements. Set the size of properties such as text and arrows 

so that the elements are legible when they are scaled for printing. 

If you place all dimensions on one layer, you can easily control when dimension 

information is visible or printable. 

Anatomy of a Dimension: 
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Dimension Settings 

This section provides a general 

explanation of the settings on the 

Dimension dialog. For more 

detailed and specific info about each 

setting please see the Help file. 

Direction options 

The dimension direction is the 

orientation used to measure a 

distance when adding dimension 

lines. This direction is usually but 

not always aligned with the object 

being dimensioned. Measured distances on an object can be projected onto the dimension 

direction. For example, the horizontal dimension of a line drawn at a thirty degree angle 

represents the horizontal component of the true length of that line. The actual length of 

the angled line will be longer than the horizontal dimension. 

The four direction options are Horizontal, Vertical, Aligned, and Angle. The first two 

constrain the dimension to the stated orientation. Aligned sets the dimension direction to 

parallel the object selected or the points at each end of a line or other object you snap to. 

Angle sets the dim line to a specific angle you choose, regardless of the angle of the line 

or other object you are dimensioning. 

Arrow options 

Visual CADD™ has 7 different arrow types, as shown in the illustration on the previous 

page. Note that Leaders, discussed later in this chapter, have the same arrow choices, and 

that the Dimension and Leader arrow types can be set independent of each other. 

You can set both the size and angle of most arrows (the circle options do not have an 

angle). 

The Flip Arrows option flips or reverses the dimension line and the arrows so that they 

are outside the extension lines. Use this option when you have a short dim string and 

need more room to display the dimension text between the extensions. 
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The Left Flip and Right Flip options set the length of the dimension line segment outside 

the extensions when the arrowheads are reversed. 

Tip Many users set the arrow size the same as the text size. 

Extension options 

Extension lines visually connect the ends of the dimension line to the object being 

dimensioned. They are always drawn perpendicular to (and usually beyond) the 

dimension line. Extensions typically have an Offset that creates a space between the end 

of the extension line and the object being dimensioned. 

The Above setting adjusts the distance that the extension extends past the dimension line 

and away from the drawing object. 

The Below setting adjusts the distance of the extension from the dimension line and 

towards the drawing object, when Stretch is unchecked. 

When Stretch is checked, the extension lines stretch to reach the drawing object (minus 

the Offset distance). When unchecked, the Offset setting is ignored, and the extension 

lines follow the setting of the Below distance. 

Proximity Fixed when checked places the dimension line at a fixed distance (Offset plus 

Below) from the drawing object. 

With Proximity Fixed unchecked, you can place the dimension line at any distance away 

from the object by dragging it with the mouse before setting it with a left click. This 

means that either the Offset distance or the Below distance must "give." If Stretch is 

checked, the Below section of the extension line will stretch to fill the gap between the 

Offset distance and the dimension line. If Stretch is unchecked, the Below distance will 

remain constant and the Offset distance will "give" to fill the gap. 

Mode options 

There are three mode options: Single places one dimension and ends the command. 

Cumulative places a sequence of dimensions, each originating from the first point. 

Partitioned places a string or chain of connected dimensions, placed end-to-end. 
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An ESC or Pen Up is required to end the Cumulative and Partition options. 

Display options 

The elements that make up each dimension include the dimension line, left and right 

extension lines, left and right dimension arrows, and the dimension text. Visual CADD™ 

gives you total control over the visual properties of each dimension element independent 

of the others. Changing the properties of dimension elements will not affect previously 

drawn dimensions. 

Visual CADD™ has a tree control for setting dimension display options. Single click 

anywhere on a line to select an element, then click again to dropdown an arrow to change 

settings for each element. Uncheck the checkbox if you do not want to display an element 

of a dimension. 

Select all elements in the tree by selecting the first item in the list, hold down the SHIFT 

key, and click on the last item. Hold the CTRL key and left click to select only some of the 

items in the tree. An example: if you want to change the line width of the arrows, select 

Left Arrow, hold CTRL key and select Right Arrow, then from the line width dropdown of 

either arrow change the setting, and it will change for both arrows. 

Dim Radial 

Far Side Arrow - for Radial dimensions where the dim is placed outside of a circle or 

arc, this gives you the option of having the arrow point to the far side. For example, draw 

a circle and place a radial dim outside the circle. It will look much like a Leader. Select 

the dimension and type either ED or DE to open the Dimension Edit command. Tick the 

Far Side Arrow checkbox and ok to close the dialog. The dimension line and arrow has 

stretched to the far extent of the circle. 

Layer 

By default dimensions are placed on the layer that is current in a drawing. If the Use 

Dimension Layer box is checked, Visual CADD™ will maintain a separate layer for 

dimensions, independent of the current layer. 

The dropdown list to the right of the checkbox is used to choose the layer on which 

dimensions will be placed. 

Dimension Text Settings 
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Click on Settings in the Utilities 

menu, then click on the Dimension 

Text dialog option to change 

settings. 

Text Settings 

Sets standard text characteristics for 

dimensions. Visual CADD™ 

supports both TrueType and vector 

fonts, and some settings will apply to 

one type and not the other. See the 

Help file for more specific 

information on each item. 

Dimension Text Offset and Placement Options 

You can place dimension text to be horizontal, regardless of the angle of the object and 

dimension line, or always aligned parallel to the dimension line. 

The Vertical Position options define where the dimension text sits in relation to the 

dimension line. In-Line places the text in the dimension line, and Above-Line always 

places the text directly above the dim line, no matter the angle of the dimension. 

Outside specifies that dimension text is placed parallel to the dimension line, but never 

between the dim line and the object being dimensioned. 

The In-Line Distance sets the offset distance of the dimension line from the text. Above 

Distance sets the offset of the text above the dim line. 

Centered places the text at the midpoint of the dimension line. Unchecked, you can drag 

the text with the mouse and left click to place it at any point on the line. 

When Alt Rotate is checked, dim text on aligned or angled dimensions will be rotated as 

necessary so when printed output is read from the right side, no dim text will display 

"upside down". 
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Dimension String & Prefix/Suffix 

Checking the Overwrite box replaces the calculated dimension text with text that you 

type in the adjacent edit box. Dimension text is no longer associative if you stretch the 

objects(s). 

The Prefix/Suffix options let you add a custom prefix and/or suffix to the angle or 

distance that Visual CADD™ calculates, without losing the associative property of the 

dimension. This text is placed on the same line as the dimension text. 

You can edit a dimension after it is placed so that the suffix text is displayed on a 

separate second line below the dimension text and dimension line. Use the text settings 

on the Edit dialog to further change the suffix, for example to center text under the 

dimension string or increase the line spacing. 

Tolerance options 

Tolerances specify allowable variations in dimensions, and are often used in high-

precision work. Visual CADD™ lets you specify and display tolerances, with four 

choices: Basic. Min/Max, Stacked, and Fixed. The Basic option draws a box around the 

text. For an illustration of the other three, see the illustration earlier in this chapter. Text 

Settings - sets standard text characteristics for leaders. See the Help file for more detailed 

information. 

Other Options 

Dim Scale - sets the factor by which dimension values are scaled from the standard 

drawing units. Used when details or drawings of mixed scales are plotted on the same 

sheet. This factor allows details to be enlarged beyond real-world size, and dimensioned 

correctly without having to reset size-related dimension properties. 

Distance/Angle Display - sets the display of the dimension text with regards to distance 

and angle. There are four options. The first is Default, the legacy setting from earlier 

versions, and it varies depending on the dimension command. For example, default for 

Linear Dimension is the distance, and the default for Angular Dimension is the angle. 

The fourth option, Opposite of Default, flips these settings. A Linear Dimension will 

show the angle rather than distance. An Angular Dimension will show the length of the 

arc rather than the angle. 
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The second and third options are Angle then Distance and Distance then Angle. These are 

used when you want to show both the distance and the angle as part of the dimension text 

string. 

Flip the Reference - toggles the angle in the setting above to its opposite state. This can 

be useful if you are placing surveyor labels. For example, toggle between N23:34:45W 

and S23:34:45E, or 44 degrees and 224 degrees. 

Note 

Dimensions also have numeric settings that affect their appearance in a 
drawing. Settings include the unit (for example, inches or millimeters), number of 
decimal places, and the format for display of angular dimensions. For complete 
details, see Numeric Settings in Chapter 3. 

 

Tip 
You can save dimension settings as a Style and then retrieve them to 
quickly adjust all settings for the next dimension you will place. See Chapter 
4 for more information. 

Drawing Leaders  

A Leader is an arrow and lines with a text string attached, and allows you to visually 

connect text information to drawing objects and/or assemblies. 

Use leader settings to adjust the arrow, line, and text properties of the leaders in your 

drawing. Leader settings also control the format of datum dimensions. 

Leader Settings has two dialogs: Settings, dealing with arrows and lines and display 

properties; and Text, where you set font, height, alignment, and other Leader text settings. 
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Leader Settings 

Click on Settings in the Utilities 

menu to open the dialog. 

Leader Line Settings - choose a 

straight or curved leader line, set 

options for offset to text and length 

and angle of the shoulder, or draw a 

border around the leader text. 

Leader Display Properties - gives 

you total control over the visual 

properties of each leader element 

independent from the others. Tick the checkboxes to control display of text, line, arrow, 

and border, and specify different color, linetype, and lineweight for each if desired. Tick 

the User Leader Layer checkbox and select the layer if you want all leaders to be placed 

on a single layer. 

Leader Arrow Settings - sets the type, size, and shape of 

the arrowhead. In the illustration at right, note the shoulder 

that is discussed in the leader line section above. 

Datum Dimension - instructions for placing a datum dimension were described earlier in 

this chapter. Click on a button to set the datum dimension style to display X values, Y 

values, both, or none. 

To draw a leader: 

1. Click the Leader tool or type LE. 

2. Click the start point for the leader. This 

places the leader arrow. 

3. Click additional points to draw the leader 

line, then right click, and select Pen Up. 

4. Type the leader text and it will appear 

onscreen as well as in the speedbar. Click 

[OK] or press ENTER twice to complete the 

command. 
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If you want to flip the leader text before completing the command, click on the leader, 

drag the cursor left or right, click again to set it, then [OK] or double ENTER. 

To reshape a leader: 

1. Select Modify>Move Point. 

2. Click anywhere on the leader line, and then click the point that you want to move. 

3. Click the new location of the point. 

To flip text of an existing leader: 

1. Select an existing leader in the drawing. 

2. Type LE or click the Leader tool on the toolbar. 

3. Click on the leader, drag the cursor left or right, click again to set it, then [OK] or 

double ENTER. 

Tip 

To modify a leader in the drawing, select it, right click and click Leader Edit to 
bring up the edit dialog. Or right click and click Leader (or type LE) to edit the 
text onscreen and change settings from the speedbar tabs. Changes made to 
the speedbar will update onscreen in real time. 

 

Leader Text Settings 

Click on Settings in the Utilities 

menu to open the dialog. 

Text Settings - sets standard text 

characteristics for leaders. See the 

Help file for more specific 

information on each item. 

Text Alignment - the Vertical Align 

option determines the relationship 

of the leader shoulder line to the 

text. Use it on a leader with multiple 

text lines to control the appearance of the text. 



 

Visual CADD 7 User Guide 119 

 

Text Rotation determines the angle of the text to the shoulder line.  Note that 

you can also set a shoulder angle on the Leader Settings dialog, so it is 

possible to have both leader text and shoulder line at the same angle to the 

main leader line. An illustration of these new features is shown at right. 

Measurements and Getting Object Information  

To measure the distance between two points: 

1. Select Utilities>Measure Distance & Angles. 

2. Select two points, and then read the distance from the 

speedbar. 

 

 

To measure the distance along a perimeter: 

1. Select Utilities>Measure Distance & Angles. 

2. Select points along the perimeter, and then read the distance from the speedbar. 

 

To measure the angle between two points: 

1. Select Utilities>Measure Distance & Angles. 

2. Select two points defining the line, and then read the angle 

from the speedbar. 

To measure the angle between two lines: 

1. Select Utilities>Measure Distance & Angles. 

2. Select three points defining the angle to measure, and then 

read the angle from the speedbar. 
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To measure the area of a region: 

1. Select Utilities>Measure Area. 

2. Select the points defining the perimeter of the 

area to measure, and then read the area from 

the speedbar. 

 

 

Tip 

Use the snap commands to place accurate points when measuring 
distances, angles, and areas. 

To avoid selecting more points than you want when measuring an area, hide 
layers that are not needed, or make the layer you are measuring the current 
one, then type AL to toggle All Layers Off so that you can only pick objects on 
the current layer. 

Basic Information About an Object 

To see basic information about an object: 

1. Select an object and place the cursor over it. 

2. Read the information displayed on the status bar. 

The information will vary depending on what type of 

entity is selected. In all cases you will see the name of the object type and the layer it is 

on. In the illustration above a Circle also shows radius and area. Other examples: a Single 

Line will show length and angle; a Text object shows font name, height, rotation, and 

justification; and a Hatch object will display the hatch name, length of perimeter, area 

and hatch scale. 

Getting Additional Information About an Object 

The Object Information window opens when you select Utilities>Object Info or type OI. 

The Object Information window displays the order of each selected object in the drawing 

database, the coordinates of points, the lengths of segments, the object’s area, and all 
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object properties. For example, the object information for a circle includes not only 

coordinate data, layer, color, linetype, and linewidth, but radius and diameter as well. The 

information for text includes its starting point, font, font height, justification, and 

character spacing. 

 

If no entities are selected, the Object Information window displays information about the 

current drawing window, such as the total number of entities in the drawing (including 

deleted entities available from memory for undo operations), valid (undeleted) entities in 

the drawing, and the extents of the drawing, with coordinates of the lower left and upper 

right corners. 

Information from this window can be copied and pasted into other Windows applications. 

Select the desired text, right click, and choose Copy. 
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C H A P T E R  

10 
WORKING WITH TEXT 

Text has many uses in a drawing. For example, you might use it to clarify details and 

label objects, provide building specifications, or to create title blocks. 

Visual CADD™ offers an easy to use set of tools for creating and modifying text, 

importing text from other applications, checking spelling, and converting AutoCAD and 

Generic CADD fonts into Visual CADD™ vector fonts. 

Each text object that you add to a drawing has properties that define its appearance such 

as font, size, angle of rotation, color, and layer. You can set these properties before you 

create the text or while you are creating it, and you can edit both the properties and the 

text string after you have added it to the drawing. Text properties apply to all text within 

a text object rather than individual characters. 

Visual CADD™ ships with a number of vector fonts that are optimized for plotters and 

other vector output devices. Although the TrueType fonts supplied with Windows tend to 

redraw faster than vector fonts, they are less accurate and can cause problems with many 

older output devices. 

Some text elements of your drawing require specialized tools. Dimensions, Leaders, and 

Attributes include text, but you use dimensioning and attribute commands rather than text 

commands to create and edit them. 

Adding Text to a Drawing  

Two different text tools are available: the Text Line and the Text Editor. Both tools allow 

you to place and edit text, but they do so in very different ways. 
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The Text Line tool displays text onscreen in real time while you type (as well as one line 

at a time in the speedbar). You edit already placed text while viewing it onscreen. 

The Text Editor tool opens a dialog that displays multiple lines of text along with their 

associated settings. This tool is good for editing longer text objects. The Text Editor tool 

also provides an option for importing text from sources outside Visual CADD™. 

While using either tool, you can adjust properties at any time. Properties can also be set 

before using either tool by selecting Settings from the Utilities menu and then the 

Drawing>Text dialog. 

Working with Text 

You can set Visual CADD™ to place all new text objects on the current layer, or on a 

specific text layer regardless of the active current layer. You can also choose to set any 

combination of text color, linetype, and linewidth settings to be either on the current layer 

or a specific layer you choose. 

To set the properties display of text objects: 

1. Select Utilities>Settings. 

2. In the Settings dialog, click the Drawing>Text option. 

3. Change settings for Text Display Properties as desired by 

clicking the arrow and selecting from the dropdown list for 

each of the four properties. Selecting <current> means that 

the text will take on the property that is current in the 

drawing when a text object is placed. 

Placing Text in Your Drawing 

Drawing Scale and Text Size 

Because text size is in real-world units, you will 

need to adjust it to be legible when printed, 

especially at smaller scales. For example, if text 

height is set at 4 and Numeric units to inches, text 

will print 4” tall on paper when the output scale is 

1:1. If scale is 1:48 (1/4”=1’), text will print at 
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5/64” (4 divided by 48 and rounded). This size is legible for general text at the 1:48 

output depending on the font used. A bit of experimenting will help you decide the best 

text sizes for your output. 

Cursor Size 

When you select a starting point for 

your text, the cursor becomes an I-

beam. The size of the I-beam 

represents the actual size of the text. If 

you zoom in too far, the I-beam is too 

big to fit on the screen. If you zoom 

out too far, the I-beam appears as a 

tiny dot on the screen. Zooming in or out will make the text appear at a more manageable 

size. 

Setting Text Properties  

 You can set text properties from several different places: on the Text Editor dialog, in 

the Text dialog accessed from the Utilities>Settings menu, and from the speedbar at the 

top of screen after starting the Text Line tool. 

The two dialogs may be a better choice if you are making wholesale changes to text 

properties, because all settings are visible in one place, whereas with Text Line you will 

have to click a few different tabs to access all settings. But the Text Line tool offers one 

powerful feature the others do not have: changes are updated onscreen in real time. If 

your text height is set to 4” and you change it to 8” on the speedbar while placing text, it 

doubles in size onscreen. If you change the rotation to 45 degrees, the text rotates 

immediately when you click in the drawing after typing in the change. 

Below we will look at setting text properties on the Text Line speedbar tabs, but as 

mentioned all these settings are available on the other dialogs. 

Text Line Tab: 

This tab opens when you start the Text Line tool and left click to place the insertion point 

for the text object in the drawing. As you type, text will appear in the edit box as well as 
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onscreen. If you click the match button on the right side of the bar, and  

then click on another text object in the drawing, all properties of that text object will be 

applied to the new text line. 

Text Settings Tab: 

The Text Settings tab contains some settings that affect text placed with all fonts and 

other settings that affect only text created using a TrueType font. 

Font - sets the font of the current text object from the dropdown list. 

Height - sets the height of the text. 

Rotation - adjusts the rotation angle of the text object. 

Aspect - adjusts the height-to-width ratio of characters. An aspect of 1.0 yields characters 

that are as tall as they are wide and is the default setting. 

Line Spacing - sets spacing between text lines as a percentage of the text height. For 

example, 200% yields double spacing. 

Color - sets the color of the text object from the dropdown menu. 

Format - with TrueType fonts, adds Bold or Italic. With both TrueType and vector fonts, 

adds Underline to the text object. 

Justify - sets the alignment of the text to left, center, or right. 

Vector Settings Tab: 

The Vector Settings tab contains settings that affect text placed with a vector font. 

Character Spacing - spacing between characters, as a percentage of character size, 

100% creates one full character width between each character in the text object. 
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Slant Angle - similar to italics in a True Type font, except that you can slant text to any 

degree and also backwards by entering a negative number. 

Fill Text - when unchecked, characters are displayed in outline, which makes redrawing 

and printing faster. Does not apply to single stroke vector fonts. 

Monospace - when checked, all characters are the same width, Unchecked, wide 

characters (M, W) take up more space than narrow ones (I, l). 

The match button on these last two tabs works a bit differently than on the Text Line tab. 

Click the button on the speedbar, click in one of the edit boxes or dropdowns, then click 

on a text object in the drawing to match only that one property. For instance, clicking in 

the Rotation box on the Text Settings tab, then on a text object in the drawing, matches 

only the rotation angle while leaving all other properties unchanged. 

To create a short text object: 

1. Click the Text Line tool, then click in the drawing to place the start of text line. 

2. Type the text. It will appear in the drawing and in the speedbar. 

3. Press ENTER once to start a new text line. 

4. Hold down the CTRL key while pressing ENTER twice if you want to insert a blank line 

and then begin a new paragraph. 

5. When done typing text click [OK] or press ENTER twice to finish the command. The 

cursor must be at the end of the text object to use the double ENTER. 

To create a longer text object: 

1. Click the Text Editor tool. 

2. Click where you want to locate the 

text in the drawing. 

3. In the Text Editor dialog, type the 

text to be added. Adjust properties if 

needed. Click [OK] to complete the 

command and close the dialog. 

See the Text Editor topic in the Help file 

for more detailed information on the 

settings at the bottom of this dialog. 
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Tip 
To see cut, copy, and paste functions inside the Text Editor tool, right click 
inside the large text box area of the Text Editor dialog. 

Modifying Text  

When modifying existing text, you can change the text string, the properties of the text 

object, or both. The same tools that you use to create text are also used to modify it. 

Choosing a Tool to Modify Text 

Often the Text Line tool is used to modify shorter text objects, while the Text Editor is 

used for longer objects. The main reason is that on the Text Editor dialog you can 

navigate quickly through large amounts of text using the scrollbars or scroll wheel as well 

as the mouse to jump to different sections, or to highlight a portion of the text to copy or 

delete. 

With Text Line, you can edit text directly onscreen and see the results in real time, but 

are limited to keyboard navigation with the arrow keys, Backspace, and Home and End. 

If you are changing properties such as text height or rotation, using Text Line will show 

you those updates on the screen in real time. With Text Editor, you make changes in the 

dialog and updates are not applied until you click [OK]. 

Both tools apply to a single text object that you have selected. If you select 2 or more text 

objects, the Text Change command is used instead. With multiple selections you can 

change text properties but not the text string itself. 

To modify a short text object: 

1. Select the text object that you want to modify. 

2. Click the Text Line tool. 

3. In the text speedbar, make changes to the text properties. Modify the text string 

directly onscreen or in the speedbar edit box. 

4. Click [OK] on the speedbar or press ENTER twice to finish. If you use ENTER to end 

the command, the caret (cursor) must be at the end of the last line of the text object. 
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To modify a longer text object: 

1. Select the text object that you want to modify. 

2. Click the Text Editor tool. 

3. In the Text Editor dialog, make changes to text and properties. 

4. Click [OK] to finish. 

To change the properties of multiple text objects: 

1. Select the objects of text that you want to 

modify, then click the Text Change tool 

from the Draw menu or the side toolbar.   

You can also type ED to open the dialog. 

Edit (ED) is a powerful command, as it 

will open the relevant dialog of any object 

you select to modify. 

2. Modify the text properties and click [OK]. 

 

 

Note 
The Text Change dialog displays the symbol -***- when the properties for a 
particular text setting are different among the selected text objects. 

Checking Spelling  

 You can check the spelling of text objects and leaders in your drawing. By default all of 

the text and leaders in the drawing are spellchecked when you run the command. If you 

instead select one or more text objects or leaders, only those selections are checked. 

Text objects and leaders within a symbol, and text that is part of an overwritten 

dimension, are not spellchecked. 

Start the command from the Utilities 

menu or type SK, and a dialog pops up 

when the spellchecker first encounters 

a word that is not in a Visual CADD™ 

dictionary. The word is displayed in an 
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edit box at the top of the dialog. There are several choices at that point: you can ignore 

the message and retain the spelling, add the word to a custom dictionary, or change the 

word to one in the Suggestions list. If the list does not contain the word you want, type it 

directly into the top edit box. 

 Spelling Options allows you to specify various choices, such as how to handle words 

that begin with a capital letter or words that contain only capital letters. You can also 

change to a main dictionary in a different language if alternates are shown in the 

dropdown list (if not you can check the Support section of our website to see if there are 

others available for download). The Spelling Options dialog can be called up from the 

main spellcheck dialog or directly from the Utilities menu. A complete description of 

each option can be found in the Help file. 

Editing the User Dictionary 

When the spellchecker encounters a word that is not found in one of the supplied 

dictionaries, it gives you the option of clicking the [Add] button. When you do so the 

word is added to a custom dictionary and is “remembered” in all subsequent documents 

that you spellcheck. 

You can directly edit this custom dictionary by 

clicking on the [Edit User Dictionary] button on 

the Spelling Options dialog. 

Pressing the button opens a dialog with a 

scrollable list of all words in the dictionary. You 

can add a word directly to the list by typing it in 

the top edit box and clicking [Add Word]. Delete 

a word by selecting it from the list and clicking 

the [Delete Word] button. 

Use the [Import] button to add the contents of a 

.txt file to your custom dictionary. All words in 

the file will be added to the list. Press the [Export] button to save the contents of your 

dictionary to an external .txt file. 
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Choosing Fonts  

In Visual CADD™, you can use two types of fonts to create text—standard Windows 

fonts (TrueType and printer fonts) and vector fonts. TrueType (TT) fonts redraw more 

quickly and appear smoother on the screen, but vector fonts have several advantages: 

 Vector fonts are accurate. They are defined by the same mathematics that define 
CADD entities. Fitting text within a particular space and aligning it precisely is easier 
with vector fonts. With standard Windows fonts, what prints may not exactly match 
what you see on the screen. 

 Vector fonts are flexible. You can control the spacing between vector font 
characters, adjust the fill of the text (solid, transparent, or color), assign a slant angle 
(simulating italics), and choose between fixed or proportional spacing. These options 
provide variations not possible with a standard Windows TrueType font. The new 
Font Manager gives you the option to convert TT fonts to Vector on-the-fly to use 
these features in Visual CADD™ drawings. 

 Vector fonts are predictable. Some plotters and other output devices that use a shape 
description language - such as PCL - make a reasonably accurate representation of 
standard Windows fonts. Those using a vector language - such as HP-GL/2 - attempt 
to assign each Windows font to an internal plotter font, which can have unpredictable 
results. To avoid discrepancies, use vector fonts in your drawing, and the vector 
output device will plot them accurately. 

Visual CADD™ comes with a number of vector fonts, including several filled fonts that 

emulate TrueType fonts. 

Font Manager  

The Font Manager helps to better control font settings in your drawings. You can control 

the fonts that are listed in the font list. You can designate a few fonts as your favorites so 

that you do not have to wade through all of the Windows fonts to find the ones that you 

want. You can choose to display only vector fonts (VCF) or TrueType fonts. 

Fonts used in a drawing are always shown in the list, whether VCF or TT, so you can find 

what fonts are used in a drawing by clearing the three filter checkboxes at the top. 

All of the columns on the dialog can be sorted by clicking on the column headers. 
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Displayed Fonts 

There are three choices. Favorites are the fonts you select. The other options will display 

all the TrueType fonts and/or Vector fonts. 

Draw Truetype fonts as Vector fonts 

Visual CADD™ can convert TrueType fonts to vector fonts on-the-fly. That means that 

you can use a TT font and still take advantage of some of the font features that are 

specific to VCF vector fonts. To enable "Draw as Vector" for a TT font click on No in the 

Vector column so that it changes to Yes. 

 

Draw TrueType Fonts at full height 

Visual CADD™ does not draw TrueType fonts at their full nominal height, which causes 

a slightly different appearance in drawings. Visual CADD™ has an option to draw a 

TrueType at full height. Click on the Full column to change the setting to Yes. 
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Embed VCF fonts 

VCF vector fonts can be embedded in drawings so that the VCF font files do not need to 

be shipped when sharing drawings with others. Click Yes in the column to embed the 

fonts with a drawing. 

Substitute font 

You may specify both the type and name of the font to be used as a substitute for a 

missing font. Click on the font type icon under Substitute to toggle it. Click on the 

Substitute name to choose the substitute font from a list. 

The font filtering feature of the Font Manager is useful, but there are occasions when you 

may want to use a font that is filtered from the list. To avoid having to go to the Font 

Manager to change the filter settings, you can right-click on the font list combobox in any 

of the text/font dialogs. A popup menu will appear with both the filter settings and the 

sort order. 

Converting AutoCAD and Generic CADD Fonts  

You can add more vector fonts to your system by translating fonts created for use with 
AutoCAD or Generic CADD. 

If you have AutoCAD or Generic CADD vector fonts and want to use them with 
Visual CADD™, you can use the Font Converter to create a vector font in the .vcf 
format. The Font Converter converts AutoCAD font files (.shx) or Generic CADD 
font files (.fnt), but it cannot convert AutoCAD’s big-font files. 

To convert an AutoCAD or Generic CADD vector font: 

1. Select Utilities>Font Converter. 

2. From the Files of Type list in the Font Converter dialog, select the type of file that 

you want to convert. 
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3. Select the font files to convert, and then 

click [Open]. 

Note 

The Visual CADD™ Font Converter does not support Unicode fonts. Most .shx 
fonts in later AutoCAD releases are Unicode and will not convert. You can find 
earlier versions (R12) of most .shx fonts with the same name at the various 
AutoCAD shareware sites on the Internet. 
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C H A P T E R  

11 
SYMBOLS AND HATCHES 

Symbols are a group of objects you can insert repeatedly in a drawing. They save you 

from having to draw the same objects over and over. You can create new symbols and 

add them to Visual CADD™’s symbol libraries, or modify existing symbols. You can 

create and attach Attributes as text information associated with a symbol. 

Hatch patterns and fills give texture to a drawing, and help objects or assemblies stand 

out from surrounding objects, making them easier to identify. 

Using Symbols to Keep Drawing Elements Together  

Symbols have advantages beyond not having to always draw the same thing: 

 Using symbols can reduce the file size of your drawing. Each symbol is defined only 
once in the drawing database, even when you insert it at different sizes and at different 
angles. 

 In one step, you can delete all occurrences of a symbol in your drawing, or replace all 
occurrences of one symbol with another. 

 You can attach attributes to a symbol (for example, manufacturer, model number, and 
size of equipment). 

You can apply the current color to a symbol as it is placed, but you cannot change the 

line type or width unless the symbol is exploded. You can choose to explode a symbol 

into its individual components as it is placed. You can then edit these objects, but you 

cannot attach an attribute to an exploded symbol. Exploded symbols also enlarge the 

drawing file. 
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Using Symbols in your Drawing 

Use a symbol as a company standard detail. A project team can work with a single library 

of symbols to standardize drafting conventions. 

Use a symbol to group a collection of objects that you draw frequently.  Use a symbol to 

search for and replace an existing symbol. 

Symbol Manager Options 

Open the Symbol Manager from the main 

toolbar or the Symbols menu. Use the 

manager to drag and drop an existing 

symbol directly into your drawing, or create 

a new symbol by selecting a group of 

objects in the drawing and dragging them 

into the Symbol Manager. 

A - the View menu provides options for 

changing the icon view in the Symbol 

Manager list, and lets you view already 

loaded symbols or symbols on a hard drive. 

B - with Symbols on Disk option selected in 

the View menu, shows the selected folder 

containing symbols. 

C - previews a symbol selected from the 

symbol list. 

D - sets the size of the symbol when you 
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place it. A scale value of 1.0 is equivalent to full size or 100%. A negative value flips the 

symbol. Click the -X button to flip the symbol horizontally or the -Y button to flip it 

vertically. 

E -displays a list of symbols and subfolders if they exist in the selected folder. 

F - the Options menu provides several choices for specifying the behavior of a symbol 

when it is placed. 

G - sets the symbol’s angle of rotation. Enter a value in the text box, or click buttons to 

add 45° or 90° to the current angle, or reset the angle to 0°. Positive values rotate symbols 

counterclockwise. Negative values rotate clockwise. 

H - when pressed, these buttons will, from left to right, autoexplode symbols on 

placement, use placement color (current color), and show a view in the list of the symbols 

loaded into Visual CADD™ memory rather than those on your hard drive. 

I - sets the angle and other properties of the selected symbol to match those of the next 

object you click in your drawing, before you place the symbol. 

Tip 

Double-clicking the Symbol Manager title bar rolls the dialog up or down. 
Right click in the symbol list to see different display options. 

In the symbol list, double click on the Up folder icon at the top of the list to 
view the next folder up. If you click in the list to give it focus, the Backspace 
key will do the same thing. To open a folder, click on it and press the ENTER 

key, or double click. 

 Placing Symbols 

You can place symbols in Visual CADD™ by dragging them from the Symbol Manager 

into your drawing. A symbol is automatically loaded into memory when it is placed in a 

drawing. Any symbols that are already in an existing drawing that you open are also 

loaded into Visual CADD™’s memory. If you have multiple drawings open you can use 

any of these loaded symbols in any and all drawings until you exit Visual CADD™. 

To place and load a symbol in your drawing: 

1. If the Symbol Manager is closed, open it by selecting Symbol>Symbol Manager, or 

click the main toolbar button. 
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2. If necessary use the dropdown list in the upper part of Symbol Manager to navigate 

to the drive or folder that contains your symbols. By default this will by the Symbols 

folder the first time you use Visual CADD™. 

3. In the main list of the Symbol Manager, double click a folder of symbols to open a 

subfolder that contains symbols. 

4. When you reach the desired folder, a list of symbols is displayed. Click a symbol 

from the list to display it in the highlight box. 

5. If needed, use the controls in the top part of the Symbol Manager to rotate or scale 

the symbol before you place it. 

6. Click in the highlight box and an outline of the symbol is attached to your pointer. 

Drag the symbol into your drawing to place it, using snaps and/or the Tracking 

command if required for accuracy. 

Tip 
If you do not need to scale or rotate the symbol, and do not need to view it in the 
larger preview window, just click on the symbol in the list and drag it into the 

drawing. 

Loading Symbols 

Symbols are automatically loaded into memory when you place them in your drawing. As 

an alternate to Symbol Manager, you can load symbols without first placing them by 

using the Symbol>Load Symbol command. 

You can also choose to specify that only loaded symbols be displayed in the Symbol 

Manager. 

To load a symbol: 

1. On the main menu, click 

Symbol>Load Symbol (YO). 

2. Select the symbol or range of 

symbols that you want to load, and 

then click [OK]. 

To view only symbols that are loaded: 

1. If the Symbol Manager is closed, open it by selecting Symbol>Symbol Manager. 

2. In the Symbol Manager, click View>Symbols Loaded or press the View Symbols 

Loaded button in the Settings area at the top of the dialog. 
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Tip 

Once a symbol is loaded, you can also use Symbol Place (YP) to place the 
symbol in the drawing. This displays the Symbol speedbar where you can click a 
symbol in the picture box after selecting it from a dropdown list, and drag it into 
the drawing. You can also rotate and scale the symbol before placing it. The 
advantage of placing symbols this way is that the Symbol Manager does not 
take up any room in the drawing area. 

Creating and Working with Symbols  

To create a symbol: 

1. Select the objects that will form the symbol. 

2. Select Symbol>Create Symbol (YC). 

3. In the speedbar, enter a name for the new symbol, then click [OK]. The selected 

objects in the drawing that form the new symbol can be converted to that symbol if 

you check the box on the speedbar. 

4. You are prompted in the status bar to enter a Handle Point for the symbol. Any of the 

snaps can be used to accurately place the handle point on an object. 

5. The symbol is now loaded into memory. If you open the Symbol Place speedbar 

(YP), or the Symbol Manager and select View>Symbols Loaded, the name of your 

new symbol is displayed in the list. 

Note 

A Symbol Handle is the point on a symbol that is attached to the cursor when 
you place the symbol in the drawing.  You can change this handle during 
placement by right clicking and selecting New Handle (or type NH), click to 
temporarily place the symbol, snap to a different point on the symbol, then place 
the symbol (typically using a snap). 

 

To Save a symbol to disk for use in other drawings: 

1. Select Symbol>Save Symbol. 

2. Select the symbol from the Symbols list at the 

right of the dialog, and then select a folder to 

store it in. Select multiple symbols by holding 

down the SHIFT key for a range of symbols, or 

CTRL key to pick multiple symbols not in a 

range. 

3. Click [Save] to finish. 
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To replace all occurrences of one symbol with another loaded symbol: 

1. Select Symbol>Replace Symbol (YR). 

2. On the symbol replace speed bar, select the symbol you 

want to replace from the Replace Symbol list. 

3. Select the name of the symbol you want to replace it with from the With list. For a 

symbol to be available, it must be loaded into memory. 

4. Select [Replace], then click [OK]. 

Tip 

Replace only certain occurrences of a symbol by selecting each copy of the 
symbol you want to replace before clicking Replace on the Symbol Replace 
speed bar. 

To both create and save a Symbol in one step, select objects for the new 
symbol and drag them onto the open Symbol Manager. You will be 
prompted for name and handle. 

To snap the cursor to any point or entity within a symbol, make sure Symbol 
Snap is checked on the Symbol Manager Options menu or 
Utilities>Settings>General. 

To explode a symbol into its basic components upon placement: 

In the Symbol Manager, select Options>Auto Explode on Placement. Now any symbol 

you place on your drawing will be exploded into its component parts. 

Note 
You can specify the layer on which to place the components of an exploded 
symbol in the General section of the Settings dialog. Access this dialog by 
selecting Utilities>Settings. 

To remove all occurrences of a symbol from all open drawings: 

1. 1. Select Symbol>Remove Symbol (YV). 
2. Select a symbol or symbols from the list, and then click the [Remove] button, or 

3. Click the [Select Unused Symbols] button. 

4. Click the [Close] button to finish. 
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Creating and Attaching Attributes to Symbols  

An attribute is textual information relating to a symbol. This information can be the 

model number, price, color, and manufacturer of the fitting, fixture, or equipment that the 

symbol represents. Only symbols can have attributes. You can display or hide attributes 

in the drawing. 

You must either create an attribute within the current drawing or load an existing attribute 

file into the drawing before you can attach it to a symbol. You can attach an attribute to 

one symbol in your drawing, or you can embed it in the symbol definition, so that it 

attaches automatically each time you place that symbol. 

Parts of an Attribute 

Each attribute can contain up to 128 lines of text. 

Each line consists of a field (sometimes referred to 

as a label), a punctuation separator (typically a 

colon), and a value. Each field and value can 

contain up to 79 characters. Enter text in each edit 

box, add the separator, and then click [Add] to add 

it to the preview list below the edit boxes. 

You can edit an attribute after you have attached 

or embedded it to a symbol. 

Tip 
Delete an attribute field and default value when creating an attribute by selecting 
the field and then clicking [Delete]. 

Displaying Attributes 

Attributes are visible in your drawing when Display 

Attributes is checked on the Symbol dialog of the 

Utilities>Setting menu. Labels are visible when both 

Display Attributes and Display Fields are checked. The 

display of attributes is further affected by choosing either 

Global or Local display. See the Help file for more 
information. 
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Positioning Attributes 

Once you have attached an attribute to a symbol, it 

maintains its position relative to the symbol, even when 

you move the symbol. You can however move the 

attribute separately, by selecting a symbol, right 

clicking and selecting Attribute Move, then clicking on 

the attribute to drag it to a new location. 

Changing the Properties of Attributes 

When you change the font of attributes on the Symbols 

dialog on the Settings menu, the change applies to all 

attributes in your drawing. Changes made to other 

properties apply only to those attributes placed after you have made the changes. 

Creating an Attribute 

To create an attribute: 

1. Select Symbol>Create Attribute (TC is the keyboard shortcut). 

2. In the Create Attribute dialog, in the Name box, type a name for the attribute. 

3. In the Field box, type a label for an attribute. 

4. Type a colon or other separator in the box between Field and Default Value. 

5. In the Default Value box, type text or numbers that you want to appear beside the 

label. For example, a field labeled Color might be followed by a colon (:) and the 

color Blue as the default value. 

6. Click [Add] to add the item to the list of attributes. 

7. Continue adding fields and default values to the attribute, and then click [OK]. 

To save an attribute or attributes for use in other drawings: 

1. Select Symbols>Save Attribute (TS). 

2. In the Save Attribute dialog, select an attribute file or files, locate the folder in which 

you want to save it, and then click [OK]. 

Load an attribute or attributes: 

1. Select Symbols>Load Attribute (TO). 
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2. In the Load Attribute dialog select an attribute file or files (.VCA), and then click 

[OK] to load the file into memory. The attribute can now be attached to any symbol 

in any drawing open in Visual CADD™. 

To attach an attribute to one occurrence of a symbol: 

1. Select a symbol in your drawing. 

2. Select Symbol>Attach Attributes (TA). 

3. Select an attribute from the Attributes list. (If necessary, make 

changes in the Values text box, and then click [Update].) 

4. Click [OK] and then place the attribute in your drawing next to 

or on the symbol. 

To attach an attribute to a symbol definition: 

1. In your drawing, select the symbol to which you want to attach the 

attribute. 

2. Select Symbol>Embed Attribute (TD). 

3. Select an attribute from the Attributes list. (If necessary, you can make changes in the 

Values text box, and then click [Update].) 

4. Check Prompt Values if you want to be able to edit attribute values each time you 

place the symbol. Check Prompt Insert Point if you want to manually position the 

attribute each time you place the symbol. Click [OK]. 

5. Place the attribute in your drawing to set its default location, select Symbol>Save 

Symbol, enter a name for the symbol, and then select a folder to save it in. 

To move an attribute after it is attached to a symbol: 

1. Select the symbol with the attribute you 

want to move. 

2. Right click and select Attribute Move. 

3. Click the attribute you want to move, and 

then drag it to a new location. 

To edit an attribute after you have placed it: 

1. Select the symbol with the attribute you want to edit. 

2. Right click, and then select Attribute Edit. 

3. In the Attribute Edit dialog, make any changes and click [OK]. 
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Rendering Hatch Patterns and Solid Fills  

Use hatch patterns and fills to differentiate between solid and hollow objects and between 

different types of materials. They can help an object or objects stand out in a crowded 

drawing. When you hatch or fill an object, you create a new entity with the same shape as 

the selected object. Each hatch or fill entity has its own properties, such as color, layer, 

and linewidth. 

You can define new hatch settings and a fill color with the Hatch/Fill dialog on 

Utilities>Settings. Alternately, use the Hatch Settings command (HT) to set hatch options 

from a speedbar.  Once placed, you can change basic properties of a fill or hatch pattern 

using Modify>Change.  Edit other hatch settings as well as the basic properties with the 

Hatch Change command. 

Hatch and Fill Settings 

Pattern - lists the available hatch patterns. 

A Preview window shows the selected 

pattern. The buttons zoom in and out on 

the preview only and do not affect the 

hatch scale. 

Offsets - offsets the hatch pattern in the X 

or Y direction when you type in a positive 

or negative value. 

Scale - sets the scale of the selected hatch 

pattern (1.0=100%). X and Y scales can be 

set differently, and also locked so that both 

are the same ratio. 

Boundary - displays fill and hatch boundaries as lines on the screen. 

Angle - sets the selected hatch angle. Type a positive or negative value between 0 and 

360. 

Alignment - offers four options to set (or edit) the starting point of a hatch pattern: 

Center, Origin, Lower Left corner and First Point. Use these options to align hatch 

patterns of the same type that are placed adjacent to each other. 
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Hatch Display Properties - set any or all settings for layer, color, linetype, and 

lineweight to a specific setting so that they apply to all hatches drawn. You also have the 

option to set any property to <current> so that it takes on the setting that is current in the 

drawing when the hatch is placed. See the Help file for complete details. 

Fill Settings - sets the fill color for the next fill drawn. If you select <current> the fill will 

be drawn with the color current in the drawing when the fill is placed. 

To hatch a closed object with the current hatch: 

1. Select an object or objects. 

2. Click the Hatch Selection tool. 

To fill a closed object with a solid color: 

1. Select an object or objects. 

2. Click the Fill Selection tool. 

To draw an irregular polygon and add a hatch 
pattern or solid fill: 

1. Click the Hatch Boundary tool or the Fill 

Boundary tool. 

2. Place points defining the vertices of the closed 

polygon. 

3. To finish, right-click, and select Pen Up (PU) from the local menu. 

Tip 

To use the Selection and Seed tools for hatches and fills, the objects you select 
MUST have a closed boundary. Otherwise you will get an error message and 
the hatch will not be applied. Use the Trim and Extend tools to create a closed 
boundary before hatching. 

Changing the Hatch Pattern of a Hatched Entity 

Materials and finishes sometimes change in the life of a project. To change the rendered 

material in your drawing, you change the hatch pattern and perhaps some of the 

properties associated with it. In Visual CADD™ you can change a hatch pattern after it is 

applied to an object. Use the Hatch Change dialog to change the pattern, angle, scale, 

alignment, offset, and basic properties such as layer, color, or linewidth. You can change 



 

Visual CADD 7 User Guide 145 

 

one or several properties of more than one hatched object, even if the objects contain 

different hatch patterns. 

Hatch Change Dialog 

Select a hatch and start the command from the Draw menu 

or type HC (or ED). The same settings described earlier for 

the Hatch/Fill Settings dialog apply to the Hatch Change 

dialog. If you drag the dialog to the side of the screen so 

that the hatch is visible, you can see the result of your 

changes by clicking the Apply button. When you are 

satisfied, click [OK] to finish. 

You can enter offset values to incrementally “bump” 

adjacent hatches of the same pattern along the X and Y 

axis so that they align with each other. 

To change the hatch pattern of a hatched entity: 

1. Select one or more hatched objects. 

2. Select Draw>Hatch>Hatch Change. 

3. Make changes to the hatch settings, and then click [Apply]. Click OK when you are 

done with the changes. 
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C H A P T E R  

12 
PRACTICAL AND ADVANCED TECHNIQUES 

In conventional drafting you use a variety of techniques to draw quickly and efficiently. 

Beyond the basic drafting commands such as lines and rectangles, Visual CADD™ offers 

many advanced tools to speed up your work. 

You can match some or all properties of an object already in the drawing and apply them 

to the next object you draw. You can quickly change an existing object to match another 

in the drawing. Other tools allow you to quickly set distances and angles. 

Another feature is the ability to add graphic images such as JPG or GIF into your 

drawings. 

By using Reference Frame entities, you can combine information from one or more 

drawings into another drawing, at varying scales. You can control the scale and the layer 

visibility of each reference frame entity that you insert into another drawing. For 

example, you can create a larger detail within a main drawing that might contain a floor 

plan or building section at a smaller scale. 

Use a Digitizer to create drawings in Visual CADD™ based on existing hand drafted 

ones, by tracing the geometry of the paper drawing to create a CADD file. You can also 

use a digitizer as a Windows pointing device instead of a mouse. 

Setting Properties and Drawing Tools by Example  

When you want to draw an object with the same properties as an existing object in the 

drawing, you can use the existing object as an example. You can also match the 

properties and start a drawing tool in one step. 
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This is an easy way to set properties for all subsequent objects you draw. For example, if 

you select a line, use the Match Entity tool to set the current layer and line color, type, 

and width. If you select a dimension, use the Match Entity tool to make all dimension 

settings match a dimension already in the drawing, including arrow types and styles, 

offsets, text size, aspect, and spacing. 

You can use the Match button on the Change and Ortho Angle speedbars to change all or 

selected properties for existing entities and to set an angle for the next object you draw. 

Note 

If you match the color, linetype, or linewidth of an object whose properties are 
set to LP (layer properties, see chapter 4), the properties may appear to be 
different than those of the object you match, depending on the layer properties 
of the new layer. 

Matching Properties and Tools 

Match Tool sets the properties and then starts the tool 

of the next entity you draw based on an object you 

select in the drawing. 

Match Entity tool sets the properties of the next entity 

you draw based on an entity you select. 

The Match Entity tool on a speedbar sets the selected 

property of the entity you are drawing based on an 

entity you select. 

When you click the Match tool or Match 

Entity tool, the cursor appears with an 

equal sign (=) until you click on the entity 

you want to match. 

 

To … Do This … 
Set all properties of the 
entities you are about to 
draw to match another 
entity’s properties: 

Click a drawing tool, click the Utilities menu, click 
Match Entity, and then click an entity whose 
properties you want to match. 

Change a single 
property of an existing 

Select an object in the drawing, then select 
Modify>Change, click the Match Entity button on 
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entity or entities to 
match another entity’s 
property: 

the speedbar, and then click in the property box 
you want to change on the speedbar. Now click an 
entity in the drawing whose property you want to 
match. 

Use the angle of a line 
as an example for the 
line you are drawing: 

While drawing, select Snaps>Ortho Angle, click 
the Match Entity tool on the ortho angle speedbar, 
click the object whose angle you want to match, 
click [OK] to close the speedbar, and then 
continue drawing. 

 

Tip 
A quick way to change all properties of an existing entity to match those of 
another is to select an object(s), type CG then = sign, and click the entity 
that you want to match. 

Setting Distances and Angles Quickly  

When you want to use an example to enter or change a setting for a length, height, or 

angle in a speedbar, but the object with the desired length, height, or angle does not exist 

in your drawing, you can use distance, angle, and vertex input options. You can only use 

distance, angle, and vertex input options within other commands, settings, and any 

distance or angle text boxes. 

To enter a distance by creating an example: 

On a speedbar, click the distance, height, or length text box, type D, and then place two 

points in your drawing that establish the distance you want. When you type D, it is not 

shown in the box, but the Status Bar prompts you to enter a start point and then an end 

point. 

For example, to specify an offset distance by creating an example, select an object in the 

drawing and then select Modify>Offset. Then in the speed bar, type D for the offset 

distance. The D does not appear, but the Status Bar prompts you to enter a start and end 

point. You then set two points to define the distance. 

To enter an angle by creating an example: 
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On a speedbar, click the rotation angle box, type A, then place 

two points in your drawing to show the angle. 

 

To enter a vertex angle by creating an example: 

On the Radial Copy speedbar, click the Span Angle box, 

type V, then place three points in your drawing to show the 

vertex angle you want. 

Note 
When you enter a D, A, or V in a speedbar edit box, the letter is not shown. After 
you type the letter, the Status Bar prompts you to specify points. 

Inserting an Image  

With the Image command you may import raster image files such as JPG or GIF directly 

into the program. An imported Image is a Visual CADD™ object and as such you can 

use any command to modify it. Select an existing image in a drawing and you can move, 

copy, rotate, and scale it. You can assign it to any layer. If it has a border you can set the 

color, linetype, and lineweight for the border. 

To use the Image command: 

1. Start the command from the Draw menu, or by typing IG from the keyboard. 

2. From the dialog, select the Image file you want to open. If necessary, change the path 

and drive in order to locate the file. Use the arrow keys or the mouse to scroll through 

the list and view the images in the Preview window. 

3. If you want to change properties of the image before placement, click the Settings 

button to open a dialog. See below for details on Settings. 

4. In the list box, double-click the file name, or select the file name and click Open. 

5. The status bar prompts you to place the upper left corner of the image location. Left 

click the mouse to set the point. 
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6. Drag the mouse to the right and down to view a bounding rectangle. You are 

prompted to place the lower right corner point to complete the Image placement. A 

mouse click sets the size of the Image. 

Image Settings: 

When placing an Image from the Draw menu you can click the Settings button to make 

changes before placement. If you do an Environment Save (EN) after making these 

changes they are saved for all subsequent new placements. 

When you select an existing Image in the drawing and then type ED (or right click and 

select Image Edit from the popup), any editing changes only affect that image. They do 

not change the prior settings you chose for placement of any further new images. 

Tip 
When you want to edit or modify an existing image, click near the border to 
select it rather than in the middle. 

Embed Image - saves the image with the drawing file. Note that this increases the file 

size. 

Image Path - for an image that is not embedded, Visual CADD™ must know where to 

find the image file. The path to the image can either be an absolute one that completely 

specifies the file location - e.g."C:\Images\MyImage.jpg" - or it can be relative to the 

drawing file location - "..\MyImage.jpg”. An absolute path is useful when one image is 

used in many drawings. A relative path is useful when a drawing may be shared between 

computers that have different folder names. 

Lock Aspect Ratio - only applies to 

placement of a new image in Visual 

CADD™, to allow for odd sizing. 

To resize the image after it is placed, 

use the Scale command. 

When the checkbox is ticked the 

X/Y ratio is locked so that the 

drawing will appear with the original 

aspect. Unchecked, you can drag the 

file:///C:/Images/MyImage.jpg
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bounding box on placement to control different X and Y ratios. 

Rotation - only applies to placement of a new image in Visual CADD™. The Rotate 

command in Visual CADD™ can be used to modify the image, but it is not available 

when first placing the image. 

Flip horizontal - flips the image 180 degrees. 

Flip Vertical - flips the image 90 degrees. 

Show Image as Greyscale - displays the image with no color. 

Display Border - shows a border around the image using color, linetype, and linewidth 

that are current in the drawing. You can change these properties by selecting the image 

and making changes in the property dropdowns on the mainsbar. 

Display Image - unchecking the checkbox will cause the image to not display in the 

drawing. If you have a border set to display the border will still be visible. 

Bearings  

Bearing tools are an alternative to the normal method of entering polar coordinates, a tool 

to quickly add bearing labels to lines, and a settings dialog that offers various angular 

format options such as surveyor, radians, and grads, for example. 

An overview: 

1. Enhanced polar coordinate entry recognizes polar input without needing to use a 

comma before the less-than symbol required in earlier versions. For surveyor input 

you can now eliminate the less-than symbol and use only a comma if desired. Inputs 

of “1,<45”, “1<45”, “1,<N45W”, “1,N45W” and “1<N45W” all now work for polar 

input. 

2. On the Angular Format dropdown of the Numeric dialog you have several choices 

including Radians, Grads, and Surveyor. Coupled with the ability to set the base 

angle as described below and the polar input methods mentioned above, it supports 

options for quickly creating site and plot plans and other types of drawings. 
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3. The new Base Angle setting on the Numeric 

dialog is saved with each drawing. The default 

setting of 0 degrees at 3 o'clock can be changed to 

any angle, and the coordinates in the status bar 

will reflect the change. 

4. The Multiple Dimension (MM) command on the 

Draw menu can quickly add linear dimensions to 

selected objects. 

To give you an idea how all this works, the following 

example uses Surveyor settings to draw a simple 

rectangle that might represent a site plan for a building 

lot. Check first to see that you are using Relative entry 

(MR), Ortho Mode Off (toggle OR), Grid Snap Off (toggle SG). Any of these can have a 

negative effect on your intended input. 

To draw the building lot: 

1. On the Numeric Settings dialog, choose “Surveyor” from the Angular Format box on 

both the Numeric Dimension and Numeric Display sides of the dialog. Set both 

Decimal Places at two (0.12) . For the Unit choose Decimal Feet for both. In Base 

Angle, set it at 12 o'clock and tick the Clockwise box. 

2. Start the Continuous Line tool (LC) and place the first point of the property line. 

3. To place the second point, type 100,n45e with a comma separating the distance and 

bearing, and press ENTER. 

4. Type 100,s45e and press ENTER. 

5. Type 100,s45w and press ENTER. 

6. Type 100,n45w and press ENTER. 

7. Select Pen Up from the right mouse menu or type PU to finish. 

To dimension the lot lines: 

1. On the Dimension Settings dialog, in the Display Properties section uncheck the line 

and arrow and extension checkboxes so that only Text is displayed when placing a 

dimension. 
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2. On the Dimension Text dialog, set Font and Height and other 

settings as desired. In the lower right of the dialog, set the 

Distance/Angle Display. The default setting shows only the 

distance, but you can change it to display “Angle then Distance” 

or “Distance then Angle”. Using the latter setting in our 

example the first line will be labeled 100.00’ N45°00’00”E in the drawing. 

3. Select the four lines and start the Multiple Dimension command from the Draw Menu 

or by typing MM. 

4. Drag and place the dimensions for each line. The labels will be placed in the order 

that the lines were drawn. See the Help file or Chapter 9 of this guide for step by step 

instructions on running the Multiple Dimension tool. 

Tip 

Use the Save Style command in Visual CADD™ to set up and implement 
settings to draw plot plans or other drawings with specific Numeric settings. 
Note that Visual CADD™ includes a sample style named PropertyLines.vcsty 
that has some settings described in the example above. 

Adding Reference Frame Entities to Your Drawing  

Adding a reference frame to a drawing lets you display a selected part of a drawing 

within the frame. It is a great way to organize details of different scales in one drawing, 

or to set up layouts for printing. You can insert multiple reference frames into the current 

drawing, and these frames can be used to reference either several different files or 

different views of one file. 

Previous versions of Visual CADD™ only allowed you to insert the content of a separate 

file into a reference frame in the current drawing. In Visual CADD™ you can create 

reference frames that contain objects from the same file. 

A reference frame is a Visual CADD™ object, same as a line, polygon, or leader. When 

inserted it is placed on the current layer, but this can be changed later. If you choose to 

display a boundary around the frame, it can be modified with a different color, linetype, 

and linewidth. 

When you add a reference frame, you can either define the size of the frame and the 

referenced drawing will fit into it, or you can specify the location of the frame and it will 

be sized to display the entire referenced drawing at full scale. 

You can choose either Bind Data to insert the contents of the referenced drawing into the 

current drawing, or Link File to link the content. If you link to the referenced drawing, 
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any changes made to it will be updated in the reference frame. Linking will also greatly 

reduce the size of the drawing containing the reference frame, because bound data is 

added to the current drawing file. 

Reference frames are also sometimes used when converting an AutoCAD file to Visual 

CADD™. If the DWG has Layout Spaces and/or XREFs, they will appear as reference 

frames in the converted drawing. 

Reference frames can be displayed as opaque, or as transparent, so that grids or other 

Visual CADD™ objects such as lines or circles under the frame in the current drawing 

will also display with the latter option. 

Using Reference Frames to Display Information 

Placing A Reference Frame Creating a Reference Frame 

 

Click once in the current drawing 
to locate a frame that is sized to fit 
the entire drawing. 

Click both corners to size the drawing to 
the frame. 

To create a reference frame in which to fit a drawing: 

1. Select Draw>Reference Frame>Create. 
2. Click two points representing the corners of the reference frame. 

3. Click [Browse] to find a drawing file on a drive, or 

4. Click to check the box Insert a File already Open in Visual CADD and select a file 

from the dropdown list. 

5. Click [OK] to insert the file. 



 

Visual CADD 7 User Guide 155 

 

To place a reference frame that displays an entire drawing at full scale: 

1. Select Draw>Reference Frame>Place. 

2. Click [Browse] to find a drawing file on disk, or 

3. Click to check the box Insert a File already Open in Visual CADD and select a file 

from the dropdown list. 

4. Click the point in the drawing where you want to place the lower left corner of the 

frame. 

 

Adjusting a Reference Frame Entity  

Once you have added a reference frame entity to your drawing, you control its contents. 

You can zoom in or out by using the reference frame zoom commands. Or use a Bird’s-

eye view to display the whole drawing to which the reference frame is connected. 

If you do not want to see all of the drawing information within a reference frame, you can 

hide layers without affecting the original drawing. 

You can also change an existing reference frame to display a different drawing. This is 

useful if a drawing name changes during revisions. 

Tip 

See Reference Frame entity commands and options by selecting an existing 
Frame and right clicking to display the RF popup menu. 

To create accurate details within a drawing without copying or recreating 
entities, set a Reference Frame to display its contents at an exact scale by 
using the RF Zoom Scale command. 

Tip 

To add objects from the same drawing into a Reference Frame, use the 
Insert a File already Open in Visual CADD option then click on the name of 
the current file. 

You may use the Elliptical Boundary option to set the boundary of the 
reference frame containing objects to an ellipse shape. You can set this 
before adding the Reference Frame or edit to change the shape after 
placement of the RF. 
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Controlling What is Visible in a Reference Frame 

1. Use RF zoom commands to control the scale at which reference frames are displayed 

2. Use the RF Bird’s-eye view to quickly zoom to a different part of the reference 

frame. 

3. Use RF Layer Manager to display and hide layers of information within a reference 

frame. 

4. Uncheck Display Boundary on the right mouse menu to hide the reference frame 

border. Check Display Transparent so that entities and grid marks in the current 

drawing show through a reference frame. 

To resize a reference frame: 

1. Select a reference frame. 

2. Right click and select RF Resize from the popup menu. 

3. Drag the rubberband line up and to the right to expand the frame size, down and to 

the left to reduce it. 

4. Click to set the upper right corner and the new size of the reference frame. 

To change the zoom scale or view of a reference frame: 

1. Select a reference frame. 

2. Right click, and select one of the RF Zoom commands or the RF Bird’s-Eye View 

command from the popup menu. 
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3. Reposition the contents of the reference frame as you would with any Visual 

CADD™ zoom command. 

To adjust layer visibility in a reference frame: 

1. Select a reference frame. 

2. Right click and select RF Layer Manager. 

3. Use the icons to display or hide selected layers within the reference frame. 

To change the file that a reference frame displays: 

1. Select a reference frame. 

2. Right click and select Change Reference. 

3. Select the new file that you want the reference frame to display. 

To change display properties of a reference frame: 

1. Select a reference frame. 

2. Right click and then click on Display Boundary, Display Transparent or Use Elliptical 

Boundary. This will change the state of that particular item. 

Using a Digitizer  

With a digitizer, you can create drawings in Visual CADD™ based on pre-existing hand 

drafted ones. You create the drawing by attaching the paper copy to your digitizer and 

tracing its geometry. For Visual CADD™ to read the input from your digitizer, you must 

first align your drawing. 

Your digitizer can be used as a normal Windows pointing 

device when Visual CADD™ is in mouse mode. When in 

tablet mode, however, you cannot point to screen menus or 

buttons with the puck. Instead, you must use digitizer 

buttons, function keys, keyboard commands, and scripts. 

Tablet mode only affects the digitizer’s functioning in Visual 

CADD™, not in other applications. 

In addition to activating tablet mode, you must specify the 

relationships between the paper and the electronic drawings 
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when using a digitizer. 

You can adjust the digitizer scale by overriding the scale calculated by the Align Drawing 

command with a value of your own. For example, the Align Drawing command might 

calculate a scale of 47.65:1. If you know that the actual scale is 48:1 (1/4” = 1’- 0”), you 

can override the calculated value. 

Note 
You must have a Wintab-compliant digitizer with a Wintab32 driver to use Visual 
CADD™’s tablet mode functions. Your digitizer manufacturer can supply the 
appropriate driver. 

Digitizing a Drawing 

Use a digitizer to precisely transfer a paper drawing to editable electronic form. 

To digitize points from a paper drawing: 

1. Select Utilities>Digitizer>Tablet Mode (or type GM). 

2. After using the Align Drawing or Digitizer Scale command, click 

points on the digitizer to draw scaled entities in Visual CADD™. 

 

 

To align a drawing for digitizing: 

1. Securely attach your paper drawing to the 

digitizer. 

2. Select Utilities>Digitizer>Align Drawing (or 

type GA). 

3. Draw a line that represents a line on the paper 

whose length and angle you know. 

4. Align the digitizer crosshairs at each end of the line on the 

paper and click at the endpoints, noting the dimensioned 

length of the line. 
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5. In Visual CADD™, move the cursor to one end of the line, type NP (Near Point 

Snap), move the cursor to the opposite end of the line, and then type NP again. 

6. Confirm the displayed scale value or type a new value on the trace scale speedbar. 

To adjust the digitizing scale: 

1. Select Utilities>Digitizer>Dig Scale (or type GZ). 

2. Enter a reference distance as measured on the surface 

of the paper. 

3. Enter the real-world distance represented by the 

previous measurement. 

Running Visual CADD™ at Top Speed  

Turn off unnecessary display elements. Construction points, line types and widths, 

handle points, fills, hatches, and fonts containing fills are all elements that must be 

redrawn. You can hide these elements on the System1 section of the Settings dialog 

(many of them also have keyboard shortcuts for toggling on and off). Turning off the 

display of attributes on the Symbol dialog on Settings can also speed redraw time. 

Work at a close in view, and change views using 

Bird’s-Eye view. Because Visual CADD™ searches 

through only the entities on the screen when you snap 

to a point or an object, the greater the magnification of 

your view, the faster Visual CADD™ will snap to a 

point. Draw a selection frame in the Bird’s-Eye View 

window to select the view and level of magnification 

in one step. 

Hide layers containing objects you do not need to see. Only display the layers on 

which you need to work so that Visual CADD™ does not redraw unused objects. 

Stop redraw after Visual CADD™ redraws what you want to see. Shorten the time it 

takes to zoom in on the most recently drawn entities in your drawing by selecting 

Zooms>Backward Redraw. When you next choose a zoom command, wait until what you 

want appears on the screen, and then press ESC to stop the redraw. 

Use the Pack Data command periodically to delete all record of objects that have 

changed, freeing memory, and restoring optimal system performance. When you 

modify objects with commands such as Move and Erase, the objects are not deleted from 
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the database; they simply do not display in the drawing. They remain in the database so 

that the Undo and Redo commands can be used to bring these objects back into the 

drawing display if desired. As the database grows in size it can affect the performance of 

Visual CADD™ and of your computer. Pack Data compacts the database by deleting 

these objects. 

Note 

Newer computer systems have enough horsepower so that many of these 
suggestions may not be necessary. Try them if you have performance problems. 
No matter the computer power though, we recommend running the Pack Data 
command often to keep file size small and avoid possible data corruption. 
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C H A P T E R  

13 
CUSTOMIZING VISUAL CADD™ 

CADD software “out of the box” may not conform to your unique drawing style and 

needs. In Visual CADD™, you can customize most of the drawing interface, including 

menus, buttons, toolbars, and keyboard shortcuts. You can create new linetypes and hatch 

patterns. And you can create scripts and custom commands that run a series of actions 

with a couple of keystrokes. 

Some customizing is done in standard Visual CADD™ dialogs. In some cases you will 

need to edit files, and Visual CADD™ gives you tools to do this from within the 

interface. 

Automating Actions with Scripts  

If you repeat actions often when drawing in Visual CADD™, you can write a script and 

assign it to a single key or a combination of keystrokes. The next time you want to repeat 

those actions, press the key combination you have assigned to it. 

Using the Assign Script command, you can assign a script to function keys, key 

combinations, and mouse and digitizer buttons. The Assign Script dialog lists all Visual 

CADD™ native commands. To write a script, enter either the native command name or 

the equivalent keyboard shortcut. If you will trade scripts with others, use the full 

command name. Keyboard shortcuts can be customized and might have a different 

meaning on another person’s system, so the script may not run correctly. 

Some of the elements you need to add to scripts are not listed with the native commands 

on the Assign Script dialog. These you type directly in the Edit Script text box; see the 

tables on the following page. Be sure to write a script that incorporates all steps to 

complete an operation. For example, many native commands require a parameter - a 

number or text string- to change a setting in Visual CADD™ (the native MultiLineStyle 
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shows one example in the table). The Help file has much more detailed information and 

examples about scripts, including script parameters. 

You can initiate a script when Visual CADD™ starts by adding a script to the Startup 

section at the bottom of the Assign Script dialog, or via a Windows shortcut dialog for 

Visual CADD™. You might use this to start Visual CADD™ with a specific menu or 

drawing file, or to load a completely different System folder with customized settings. 

Script Examples 

This Script … Does This … 
CS;SX;@;@;CO; Copies objects you first select using a crossing 

window. 
MulLineStyle;1;MultiLine; Sets the Style to 1 and starts the MultiLine 

command. 
SYMROT;$SYMROT+15; Sets Symbol angle to 15° more than current 

angle. 
CS;SB;@;LE;NP; Prompts to select a leader and flips the text of 

the Leader. 
TextRot;=;TL;@; Sets text angle to the angle of an object you pick 

in the drawing and then starts the Text Line 
command. 

SetLayer;3;SetColor;12; 
SetType;6;SetWidth;1; 

Sets the properties for layer, color, linetype and 
linewidth. The next object you draw will take on 
these properties. 

Common Script Elements 

This Element … Does This … 
; Separates the commands in a script. Scripts 

must end with a semi-colon (;) as well. 
@ Tells Visual CADD™ to wait for you to type 

the coordinates of a point or for a click on the 
drawing screen. 

@@ Tells Visual CADD™ to wait for a Pen Up 
command to finish a continuous tool before 
moving to the next command. 

@@@ Tells Visual CADD™ to wait for a dilag to 
close before moving to the next command. 

$ Retrieves the current value of the variable it 
precedes. 

=;@ Matches the entity you select. 

UIoff Closes the specified speed bar. 

UIon Opens the specified speed bar. 

exename;<path to external Tells Visual CADD™ to run an external 
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application>;run; application from within Visual CADD™. 

dllname;<dll 
filename>;dllfunname;<functionname 
within the dll>;dllrun; 

Runs a function defined in a .dll 
file.dllfunname;<functionname within the 
dll>;dllrun; 

Note: Scripts never contain quotation 

marks (“). 

 

To assign a script: 

1. Select Utilities>Assign Script and make sure the Assign Script tab is current. 

2. In the Assign Script to a 

Key dropdown, click the 

down arrow and choose 

a mouse button or key to 

assign the script. Key 

options include 

FUNCTION keys, 

SHIFT+FUNCTION or 

CTRL+FUNCTION 

keys, and 

CTRL+NUMBER or 

CTRL+LETTER keys. 

3. Highlight a native command from the Command List and click the double arrowed 

button to add it to the Edit Script box to the left; or type it directly in the box (you 

can also double click a command to add it to the box). 

4. Repeat the step above to add additional commands to the script. By default each 

command added from the right side list will include and end with a semicolon. 

5. To introduce other elements as described in the table, you will need to manually add 

them. For example, the script shown in the graphic above has an equal sign and an @ 

sign that must be manually added, with a semicolon after. All scripts must end with a 

semicolon. 

6. Press [Update] to save your work and then either create or edit additional scripts, or 

press [OK] to exit the dialog. 
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To create a script that will run when you start Visual CADD™: 

1. Start the Assign Script command from the menu or toolbar (or type AS). 

2. Click the arrow at the right of the Assign to Key dropdown box. 

3. Scroll to the end of the list and select the item labeled Startup. If the Startup entry has 

already been assigned a script and you want to use a different one, select to highlight 

the script in the edit box and then press the [Clear] button. 

4. Type the command sequence you want to program into the Edit Script box, or select 

a command from the Native Command List to the right and click the [<<] button to 

add it to the script. 

5. When you are satisfied with the script, click [Update] to save the startup script. 

6. Click [OK] to close the Assign Script dialog box. 
7. The next time you start Visual CADD™ the script will be applied. 

For more information and some example scripts, see the Startup Scripts topic in the 

Visual CADD™ Help file. 

Custom Commands  

As described above, a script can be assigned to a mouse button, function key, or a combo 

of Windows shortcut keys. By wrapping a script in a Custom Command, you can also 

assign the script to a Visual CADD™ menu, a toolbar, or a 2 or 3 letter shortcut of your 

choosing. You can designate a bitmap if you decide to add the command name to a 

toolbar. 

Custom Commands are also used 

by developers writing add-on 

tools. One example is shown at 

right. 

As you can see, it includes the 

command name, keyboard 

shortcut, menu and status bar 

descriptions, and the script that 

runs the command. 

The script here is very different 

from the earlier example. It 

references external filenames and 

functions. When dealing with 
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these external commands, it is important that you do not change the command name or 

the script as it will cause the command to no longer function. You can safely change the 

shortcut and the text descriptions, as well as the optional bitmap if included (there is not 

one for the OrthoMatch command). 

When creating your own Custom Commands however you have complete control over all 

elements. In the example below we use the same script described earlier. That script sets 

a new text rotation angle with this sequence: press CTRL+T to start the script, then you 

are prompted to click on an object in the drawing to match its angle, and finally the Text 

Line command starts at the ortho angle of the matched object. 

To create a command to run 

this script, click the New 

button and type in a name that 

is between four and twelve 

characters long. Add a 2 or 3 

letter shortcut if desired. Be 

careful not to duplicate any 

shortcuts that already exist. 

Add a bitmap file and menu description if desired. The former will display on a toolbar 

and the latter will appear on a menu if you add the custom command name to a toolbar or 

menu file. If you add a description the text appears on the Status Bar when you run the 

Custom Command. 

Add the script as described in the earlier section, then save the new command and click 

[OK] to exit the dialog. 

See the Customizing section of Visual CADD™ Help for detailed info on Custom 

Commands. 

Note 

Custom Commands take precedence over internal native commands. If you 
create a custom command with the same name or keyboard shortcut as a native 
command, the latter will not work and the custom command will run instead. Be 
careful not to duplicate existing shortcuts or native command names unless that 
is what you intend. 
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Customizing Keyboard Shortcuts  

One of the more powerful time saving features in Visual CADD™ are the keyboard 

shortcuts. You can quickly start commands from the keyboard rather than mousing up 

into menus or toolbars. 

You can also modify these 

shortcuts. The Custom 

Shortcuts tab option is 

available with the Assign 

Script command. It allows 

you to change the 2 and 3 

letter keyboard shortcuts for 

the native commands in 

Visual CADD™ directly 

from within the interface. 

To customize a keyboard shortcut: 

1. Start the Assign Script command from the menu or toolbar (or type AS). 

2. Click the Custom Shortcuts tab if it is not already open. 

3. Scroll the Native Command list until you find the native command that you want to 

add or modify a shortcut and select it. 

4. Click the double arrow button to add it to the left hand list. Double clicking on the 

native will also add it to this list. 

5. Left click anywhere on the new item, in the Name, Default, or Custom columns to 

select and highlight it. 

6. Click again in any of the columns of the selection and a bounding text box will 

appear in the Custom column, with the custom shortcut highlighted. 

7. Change the shortcut, and click [Update] if you want to continue changing other 

native shortcuts, or [OK] if you want to keep the change and end the command. 

Tip 

Many native commands change individual settings in Visual CADD™ instead of 
starting a tool. The native DimTextSlant is an example. This command works 
only as part of a script --for example "...DimTextSlant;10;..." sets the slant to 10 
degrees. Assigning a keyboard shortcut to this command does not work, 
because there is no dialog or other way to specify the angle "on the fly"; it must 
be hardcoded in a script. 
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The Configuration Editor  

Customizing of menus, toolbars, hatches, and linetypes are done in external files. All v6 

customizable files are now in the XML format rather than the old ASCII text. 

XML is a text based document format that uses elements to group information. Because 

of its flexible, hierarchical structure it is ideally suited to Visual CADD™'s configuration 

files. The Configuration Editor is an XML editor that has been customized to work with 

Visual CADD™ files. Note that you can use any XML editor or text editor with XML 

files. The two main advantages of the Visual CADD™ editor is that it knows where to 

find Visual CADD™ configuration files and that it will convert older customization files 

to the new format. 

To Open the Configuration Editor: 

1. From the Utilities menu, select Configuration Editor. 

2. From the File menu of the editor, you can choose to create a new XML file, open any 

XML file, or open a specific Visual CADD™ file. Select the latter and you will see a 

flyout with options for the System Folder, where most of the customizable files are 

located, as well as specific file types such as Menus, Styles, Toolbars, Hatches, etc. 

3. If needed, change the File of Type in the dropdown. By default the XML format will 

be displayed (it adds a vc to the front of the older file extensions, for example mnu is 

now vcmnu). You can change the type to choose to open an older file and convert it to 

the new XML format. 

4. If needed, change the path to the file. Select the filename you want to open. 

5. Click [Open] or press [Enter] to complete the command. 

Tip 
For detailed information and options on converting your older files to the XML 
format in the Config Editor, see the Tips section of the Configuration Editor topic 
in the Help file. 

Creating Custom Menus  

Menus can be altered by adding, deleting, or rearranging either Native or Custom 

commands. New menus can be created either from scratch or by using an existing file as 

a starting point. 

In Visual CADD™ custom menus are saved as XML files with the .VCMNU extension. 

You may open and edit XML menu files in the Configuration Editor. 
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Place any new custom menu files in the Menus folder, which is on the same level as the 

System folder and by default is installed to a Visual CADD™ folder in My Documents. 

When you right click on the top menu bar in Visual CADD™ these menus will display in 

the list. Left click on a menu to make it current. Run the Save Current Environment 

command (EN) to use it as the default in the next drawing session. 

What follows is an example of the new XML format showing the first several commands 

in the Custom.vcmnu file located in the Menus folder. Also included is the very last 

command of the menu (in the Help section), and the tags that complete the XML file. 

These tags are typically referred to as elements and add a structure to identify each line of 

the file: 

<MenuFile> 
<Menu> 
<Popup Label="&amp;File"> 
<Item Label="&amp;New\aCtrl+N" Command="FileNew"/> 
<Item Label="&amp;Open...\aCtrl+O" Command="FileOpen"/> 
<Item Label="&amp;Close" Command="FileClose"/> 
<Separator/> 
<Item Label="&amp;Merge..." Command="FileMerge"/> 
<Separator/> 
<Item Label="&amp;Save\aCtrl+S" Command="FileSave"/> 
<Item Label="Save &amp;As..." Command="FileSaveAs"/> 
<Item Label="Save All" Command="FileSaveAll"/> 
<Separator/> 
<Popup Label="&amp;Import"> 
<Item Label="&amp;CADD Files" Command="ImportCAD"/> 
<Item Label="&amp;XML File" Command="ImportXML"/> 
</Popup> 
... 
... 
... 
<Item Label="&amp;About Visual CADD" Command="HelpAbout"/> 
</Popup> 
</Menu> 
</MenuFile> 

Popup Label - signifies the start of a discrete menu section (File, Edit, Modify) and also 

any flyout menu item within the section (with File for example it is used for the Import 

flyout, which has two commands, and the Export flyout which has four). 

Item Label - the first item is the menu description that appears on a menu. Most will be 

preceded by &amp, which is a code that signifies the command can be opened from the 

keyboard. For example, "&amp;File" means that if you hold down the ALT key and press 

F it will open the File menu. Then for "&amp;Print" you would press the P key to open 

the Print dialog (not ALT+P as the ALT key is only required to open a menu). If the label 



 

Visual CADD 7 User Guide 169 

 

also includes a CTRL+ option it will list a string such as \aCtrl+N. In the example menu 

section here pressing CTRL+N would create a new file in Visual CADD™. 

Note that earlier versions of Windows displayed the underlined character on the menus 

by default. Newer Windows versions hide them until you press and hold the ALT key. 

The second item lists the native command that is run when you choose that command 

from a menu in Visual CADD™, for example FileNew or FileOpen. 

Separator - creates a separator line in the menu. 

Standard Menu Elements 

Standard menu elements are used in all configuration files that define menus. These files 

include vcmnu files, vcpop files, and MouseMnu.vcdef. 

There are two standard elements. The <Menu> element is used to define the contents of 

menus. The <Command> element defines native and custom commands that are available 

while the menu is loaded. 

The <External> element can be used to insert the content of an external menu file (the 

TriTools toolkit menu is one example) to an existing menu. If only the file name is 

specified and the file's path is not, the current Menus folder is searched for the file. If the 

name has no extension then .vcmnu is appended. If an Add-on attribute is specified, the 

folder where the add-on is located is searched for the file. 

<Menu> 
<Item Label="Menu Text" Command="Native"/> 
<Separator/> 
<Popup Label="MenuText"/> 
<Item.../> 
... 
</Popup> 
<External File="File name" Addon="Addon name"/> 
... 
</Menu> 
<Commands> 
standard command elements 
</Commands> 



 

170 Customizing Visual CADD™ 

 

Customizing Context-Sensitive Right Mouse Menus  

Context-sensitive popup menus display when you right click with the mouse while a tool 

is running (another option is to specify SHIFT+RIGHT CLICK from the System2 dialog on the 

Settings menu if you want to assign a snap or other tool to the right mouse click). These 

menus contain a list of commands that are specific to the tool you are using. For example, 

with the Single Line tool popup you can toggle Ortho constraint on or off, set the Ortho 

Angle, start the Tracking command, and run any of the Zoom and Snaps commands. 

The popup menus, one for each command, are consolidated in the XML file 

Mousemnu.vcdef, to make customizing popups easier to manage. The format is generally 

the same as the main menu file discussed earlier, with a couple of differences as 

described below. The following example shows the start of the Mousemnu.vcdef file and 

the popup menu for the Leader command, and then the elements that close the file: 

<MouseMenu> 
<Command Name="LEADER"> 
<Menu> 
<Item Command="Penup"/> 
<Item Command="DimLeadSet"/> 
<Item Command="DimArrowSet"/> 
<Item Command="DimTextset"/> 
<Separator/> 
<Popup Label="&amp;Zooms"> 
<Item Label="&amp;All" Command="ZmAll"/> 
<Item Label="&amp;Window" Command="ZmArea"/> 
<Item Label="&amp;In" Command="ZmIn"/> 
<Item Label="&amp;Out" Command="ZmOut"/> 
<Item Label="&amp;Pan" Command="ZmPan"/> 
<Item Label="&amp;Selected" Command="ZmSel"/> 
<Item Label="Previo&amp;us" Command="ZmPrev"/> 
<Item Label="&amp;Redraw" Command="Regen"/> 
</Popup> 
<Popup Label="&amp;Snaps"> 
<Item Label="&amp;Object" Command="SnObject"/> 
<Item Label="&amp;Midpoint" Command="SnMidPt"/> 
<Item Label="&amp;Intersection" Command="SnIntersect"/> 
<Item Label="Perpendic&amp;ular" Command="SnPerp"/> 
<Item Label="&amp;Tangent" Command="SnTangent"/> 
<Item Label="&amp;Closest" Command="SnClosestPt"/> 
<Item Label="&amp;Percentage" Command="SnPercent"/> 
<Item Label="Ce&amp;nter" Command="SnCenter"/> 
<Item Label="&amp;Quadrant" Command="SnQuad"/> 
<Item Label="Paralle&amp;l" Command="SnPara"/> 
</Popup> 
</Menu> 
</Command> 
... 
... 
</MouseMenu> 
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The elements <MouseMenu> and </Mousemenu> respectively define the start and end of 

a popup menu. 

The <Command Name> tag starts a new popup menu section and </Command> ends it. 

External Popup Files 

Although we encourage you to put all popup information in one file, you can create 

external popup menus and add them to the end of the Mousemnu.vcdef file. Third party 

developers use this for their custom commands (the TriTools Toolkit is one example). 

Right-click popup menus can be defined in three ways: 

1. Popup menu is defined inline in mousemnu.vcdef. 

2. Popup menu is defined in an external vcpop file. The first <PopMenu> element 

encountered in the file is used. 

3. Popup menu is defined in an external vcpop file and a user selected <PopMenu> 

element is used. 

The XML structure is: 

<MouseMenu> 
<Command Name="Native" File="Mypop.vcpop" PopMenu="MyMenu"> 
Standard menu elements … 

... 

... 
</MouseMenu> 

The Name attribute is required and specifies the Native or Custom command that the 

popup menu applies to. 

The File attribute is optional and specifies an external vcpop file that contains the popup 

menu. If File is not included, standard menu elements can be used to define the popmenu. 

The PopMenu attribute is optional and specifies which specific PopMenu element in the 

vcpop file should be used. If PopMenu is not included, the first PopMenu element in the 

external vcpop file is used. 
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Customizing Toolbars  

You can easily rearrange or add new command icons on the main toolbar and side 

toolbar. The commands displayed on these bars are listed in the files mainsbar.vcmbr and 

toolpal.vctbr, respectively. These files are found in the Visual CADD™ Systems folder, 

installed by default to My Documents. 

To edit the toolbars, start the new Configuration Editor on the Utilities menu. Select 

File>Open Visual CADD File and then either Main Speedbars or Toolpals (the side 

menu). 

You can create custom mainsbars and toolbars and change between them and the default 

from within Visual CADD™ by right clicking on the particular toolbar. To do this, create 

a new XML file with the .VCMBR or .VCTBR extensions, and add the file to the System 

folder. Then, whenever you right click on the mainsbar or toolbar, the new toolbar will 

show in the list. Select it and the toolbar is now the active one. 

Main Toolbar 

The following listing in mainsbar.vcmbr or your custom .vcmbr file would first display a 

row of command icons for the File New, File Open, File Save, and Print commands, 

respectively. The Separator adds a vertical bar between sets of commands. The Group 

element denotes a flyout, where the display of all buttons in the group expands when you 

hold down the left mouse button while hovering over the icon: 

<ToolbarFile> 
<Toolbar> 
<Item Command="Filenew"/> 
<Item Command="Fileopen"/> 
<Item Command="FileSave"/> 
<Item Command="FilePrint"/> 
<Separator/> 
<Group> 
<Item Command="CBCut"/> 
<Item Command="CBCopy"/> 
<Item Command="CBPaste"/> 
</Group> 
... 
... 
</Toolbar> 
</ToolbarFile> 
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The first two items define the toolbar format required with XML. Note the corresponding 

tags at the end of the file (with the "/" preceding the tags). This is the method to complete 

and close XML files. 

The other items apply a tag or element preceding the Visual CADD™ native File 

commands. 

Side Toolbar 

The following listing in toolpal.vctbr or a custom .vctbr file create command icons in the 

side toolbar. Here again, the Group element denotes a flyout, where the display of all 

items in the group expand when you hold down the left mouse button while hovering 

over the icon: 

<ToolbarFile> 
<Toolbar> 
<Group> 
<Item Command="LineCont"/> 
<Item Command="LineSingle"/> 
<Item Command="LineDbl"/> 
<Item Command="MultiLine"/> 
<Item Command="MIDLINE"/> 
<Item Command="Point"/> 
</Group> 
... 
... 
</Toolbar> 
</ToolbarFile> 

You can rearrange buttons, or add as many command buttons in the vertical toolbar and 

flyout menus as will fit on the screen. 

Tip 
See the Help file topic Customizing Command Buttons and the tips section there 
for a wealth of detailed information on setting up and using custom toolbars. 

To edit an existing or create a new custom toolbar or mainsbar: 

1. Open the Configuration Editor from the Utilities menu. 

2. From the File menu select Open Visual CADD File and then click either Main 

Toolbars or Toolpals for a list of the top or side bars respectively. 

3. Open a file to edit and make changes, or use one of the existing .vcmbr or .vctbr files 

as a basis to create a new file, using SaveAs to create the new file and filename. 
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4. Rearrange, add, and/or delete commands in the file. For a list of Native Commands, 

see Appendix A. For a list of Custom Commands, see the tab of the same name on 

the Utilities>Assign Script dialog. 

5. Save the file when you have completed making changes. 

6. Open Visual CADD™. Depending on what type of toolbar you created, right click on 

either the top or side toolbar, and you will see your new toolbar listed. 

7. Click on it and it will be loaded as the current toolbar. 

8. To make the new toolbar “stick” the next time you open Visual CADD™, run the 

Save Current Environment (EN) command from the Utilities menu. 

Creating New Hatch Patterns  

You can rename and modify existing hatch patterns, or create your own from scratch. 

All of the hatch pattern definitions are contained in an XML file named hatches.vchat, 

located in the System folder. To create a new hatch or add an existing one from other 

sources, you would edit this file and format the new hatch info with the pertinent settings 

as described below. 

In Visual CADD™ all customizable files are in the XML format. You open and edit 

XML hatch files with the new Configuration Editor found on the Utilities menu. If you 

have a customized hatch file in the old format (.hat), the editor includes the option of 

converting your earlier ASCII files into the new format. You can also convert the many 

hatch files available in the public domain (see the Tip at the end of this section), and then 

copy and paste the information for a particular hatch that you want into the hatches.vchat 

file. 

A Visual CADD™ hatch definition consists of a family of dashed or solid lines, each at a 

user-defined angle. These lines are then copied and extended (and the dashed pattern 

repeated as necessary) to fill the hatched area. The hatch definitions are in the following 

format (hatch definitions define the hatch pattern as it would appear if drawn at a hatch 

scale factor of 1 and hatch rotation of 0°): 

<Hatch Name="goes here" Verbatim=""> 
<!--a comment line to describe the hatch--> 
<Line StartX="" StartY="" Angle="" OffsetX="" OffsetY=""> 
<Dash>1</Dash> 
<Space>2</Space> 
... 
</Line> 
... 
</Hatch> 
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Note that the hatch name and comment line precedes the actual hatch line definitions, 

which are enclosed within the set of brackets. There is no limit to the number of lines that 

can be included in a hatch definition, although more lines means slower hatching times. 

The hatch definition parameters are defined as follows: 

HatchName - name of the hatch pattern. Up to 32 characters are allowed. 

Verbatim - while hatch names are often used to represent patterns of no real world size 

or scale, often they are used to represent real world items that have a scale, such as 

bricks, tiles, or rocks. Visual CADD™ typically "normalizes" any hatch pattern unless 

the Verbatim option is used in the definition. Normalizing a hatch involves reducing all 

numbers in the hatch definition to numbers less than 1. In the case of an 8" brick 

however, this is not necessarily a good thing, so the Verbatim option is supplied to 

instruct Visual CADD™ to use the hatch definition as is, i.e. to not normalize it. To 

declare a hatch pattern as verbatim, include a "Verbatim" attribute with a value of "Yes" 

in the hatch definition. 

Comment - can be added anywhere using standard XML comments. Note the !--

preceding the comment, which means that the text following will not be used in 

calculating the hatch. 

StartX - is the X coordinate (in "real world" inches) of the start of the line relative to the 

"origin" of the hatch pattern. 

StartY - is theY coordinate (in "real world" inches) of the start of the line relative to the 

"origin" of the hatch pattern. 

Angle - is the angle of the line (0° is at the "3 o’clock" position, and positive is 

counterclockwise). 

OffsetX - is the X component (in "real world" inches) of the offset between copies of the 

line, in the frame of reference of the line. If the line is rotated 90° (to vertical), for 

example, then the X offset of the line is equivalent to the Y offset in the "absolute" 

reference frame of the overall hatch pattern. 

OffsetY - is the Y component (in "real world" inches) of the offset between copies of the 

line, in the frame of reference of the line. If the line is rotated 90° (to vertical), for 

example, then the Y offset of the line is equivalent to the X offset in the "absolute" 

reference frame of the overall hatch pattern. 
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DashLength - is the length (in "real world" inches) of a solid line segment making up 

part of the line pattern. The total number of dashes and spaces cannot exceed 16. You can 

start the line pattern with a dash or space. Note: if this hatch line is a solid, continuous 

line, skip this and all subsequent parameters on this line. 

SpaceLength - is the distance (in "real world" inches) between the end of one dash 

segment and the beginning of the next. The total number of dashes and spaces cannot 

exceed 16. 

Example: 

The following hatch pattern is for standard brick in running bond pattern: 

<Hatch Name="StdBrickRun" Verbatim="yes"> 
<!--Standard brick (running bond, 8" long, 2-2/3" high)--> 
<Line StartX="0" StartY="0" Angle="0" OffsetX="0" OffsetY="2.666667"/> 
<Line StartX="0" StartY="0" Angle="90" OffsetX="2.666667" OffsetY="4"> 
<Dash>2.666667</Dash> 
<Space>2.666667</Space> 
</Line> 
</Hatch> 

The first line after the name and comment is the 

continuous, solid horizontal line that represents the top 

and bottom of the bricks. It starts at the origin of the 

hatch pattern (thus the first two 0's) and is horizontal 

(angle = 0). This line is repeated vertically every 2-2/3" 

(hence the 2.666667 offset). Because the line is solid, 

there are no parameters for dash and space segment 

lengths. 

The second line represents the vertical faces of the bricks. This line starts at the origin 

(thus the first two 0's) and is vertical (angle = 90). The line is copied horizontally every 

8" (hence the 4” offset). The line pattern is defined by a solid segment 2-2/3" long (hence 

the first 2.666667), and a "blank" or space segment also 2-2/3" inch long (hence the final 

2.666667). 

The best way to understand how hatches work is to open and print the hatches.vchat file, 

and compare the individual hatch definitions with the appearance of the hatch onscreen in 

Visual CADD™. 
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Creating New Line Types  

You can rename or modify the line types that come with Visual CADD™, or create new 

ones. A maximum of 256 line types is available. 

All line type definitions are contained in an XML file named linetype.vclnt, located in the 

System folder. 

The line type definitions do not have to appear in order in the linetype.vclnt file, as the 

index number specifies where it appears in the list when loaded into Visual CADD™. 

Here is an excerpt from the default XML file that ships with Visual CADD™ showing 

the format using a dashed line as an example: 

<Linetype Name="DASHED" Index="10" Ref="Device" Align="Balanced"> 
<Line> 
<Dash>0.24</Dash> 
<Space>0.08</Space> 
</Line> 
</Linetype> 

Linetype Name - the name of the pattern to be displayed in all Linetype list boxes in the 

interface. Up to 32 characters are allowed. Spaces are not permitted in the name. The 

name must be unique. If a name is used multiple times, the index and definition 

associated with the last appearance of the name will be used. 

Index - the linetype number (0-255). While line names are optional, all linetypes must 

have a unique number. 

Ref - reference frame for measuring the lengths of the solid and blank segments that 

make up a custom line type. Choices are the world reference frame or the device 

reference frame. If the world option is chosen, then the segment lengths are measured in 

the same reference frame as the drawing objects themselves. Thus the apparent "size" of a 

world-reference pattern will change when you zoom in or out on-screen, or when you 

plot or print at different scales. If the device option is chosen, then the segment lengths 

are measured in the reference frame of the computer screen, printer, or plotter. The 

apparent "size" of a device-reference pattern will remain constant onscreen and on paper 

regardless of the zoom factor or print scale. 

All of the linetypes that ship with Visual CADD™ are the device type except one. 
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Align - during different views or when lines are drawn at specific lengths, the ends of 

line segments may not fall on a solid segment of a line definition. Because of this there is 

a provision built into Visual CADD™ that allows the explicit line type definition to be 

overridden in these cases. By using the Balanced option, Visual CADD™ will always 

"cap" the ends of lines with a solid segment regardless of the line definition and where 

the end of the line falls within that definition. 

DashLength - the length in inches of a solid line segment making up part of the pattern. 

The length is measured in "real world" inches if the World reference is specified, and on-

screen or printed inches if the Device reference is specified (see Ref, above). A dash is 

indicated as a positive length. To include a dot as part of the pattern, specify a length of 

0. The total number of dashes, dots and spaces cannot exceed 16. You can start any line 

type with a dash, dot, or space, and the pattern will begin at the starting point of any line 

you draw with that line type. 

SpaceLength - the distance between the end of one dash segment or dot and the 

beginning of the next. The length is measured in "real world" inches if the World 

reference is specified, and on-screen or printed inches if the Device reference is specified 

(see Ref, above). Spaces can either be defined with a <Space> element, in which case the 

value should be positive or with a <Dash> element, in which case the value should be 

negative. There is no difference between the two formats. To include a dot as part of the 

pattern, specify a length of 0. The total number of dashes, dots, and spaces cannot exceed 

16. You can start any line type with a dash, dot, or space, and the pattern will begin at the 

starting point of any line you draw with that line type. 

Example: 

The following custom line type is for a property line. The line type definition is as 

follows: 

<Linetype Name="PROPLIN" Index="51" Ref="Device" Align="Balanced"> 
<Line> 
<Dash>2</Dash> 
<Space>.06</Space> 
<Dash>.03</Dash> 
<Space>.06</Space> 
<Dash>.03</Dash> 
<Space>.06</Space> 
</Line> 
</Linetype> 
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We have named it PROPLIN as it is a pattern often used when drawing property lines in 

survey work and plot or site plans. The index number of 51 means that it will appear at 

the end of the list of the 51 default linetypes shipped with Visual CADD™. 

The pattern starts with a 2" long solid segment followed by a .06" long blank space, then 

a .03" long solid segment, then another .06" long blank space, then a .03" long solid 

segment, then another .06" long blank space. This is a Device reference line type, which 

means that it will always appear the same size on screen and on paper. The Balanced 

alignment instructs Visual CADD™ to always end lines with solid segments. 

Tip 
For a complete listing of the 51 predefined linetype definitions in Visual 
CADD™, see the Guide to Linetypes topic in the Help file. It provides some 
background on the history and/or intended use of each linetype. 
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C H A P T E R  

14 
WORKING WITH OTHER APPLICATIONS 

In hand drafting, using information from one drawing in another involves drawing it 

again, or duplicating a portion of the drawing and then cutting and pasting on a layout 

table. Visual CADD™ provides tools that allow you to share information with other 

drawings and with other Windows applications outside the Visual CADD™ environment 

quickly and easily. 

You can exchange drawings with users of AutoCAD and Generic CADD, and you can 

create graphical illustrations to export for use in other applications. You can also import 

text created in other applications directly into your Visual CADD™ drawings. 

Using the Windows clipboard is the easiest way to share information among applications. 

With the Microsoft feature Object Linking and Embedding (OLE), you can link Visual 

CADD™ drawings to files in other applications so that changes you make to the Visual 

CADD™ file are updated in the file it is linked to. Alternately use the clipboard Copy 

command to embed CADD objects by Pasting them directly into the other application. 

You can also use OLE to embed or link other files such as word processing documents 

and spreadsheets with Visual CADD™, displaying the contents of those files in your 

drawing. 

Copying Objects Between Visual CADD™ Drawings  

Because Visual CADD™ allows you to have multiple drawings open at the same time, 

sharing information between them is easily done via the clipboard. 
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To copy Visual CADD™ objects to another drawing: 

1. In the first drawing, select the Visual CADD™ entities you want to duplicate. 

2. Select Edit>Copy. 

3. Switch to the second open drawing from the Window menu or by pressing CTL+TAB, 

and select Edit>Paste. 

4. A bounding box will be attached to the cursor. Place the copied objects at the desired 

location with a mouse click. 

Merging Two Visual CADD™ Drawings 

Use the Merge command to combine the contents of two drawings. The name and 

drawing environment of the first drawing loaded are preserved, although symbols and 

attributes of the second drawing are added to those of the first (conflicts such as duplicate 

symbol names are resolved in favor of the first drawing). 

To merge another drawing file into the current drawing: 

1. Select File>Merge. The files that you are trying to merge must both be VCD files. 

2. If necessary, change the path and drive in order to locate the file you wish to merge. 

3. In the list box, double click the file name, or select the file name and click [Open]. 

4. A bounding box containing the contents of the merged file will be attached to the 

cursor. Place the merged drawing at the desired location with a mouse click. 

Copying Visual CADD™ to/from Other Applications  

Incorporating parts of Visual CADD™ drawings into other Windows based documents is 

simple. You can use the standard cut, copy, and paste commands to add Visual CADD™ 

illustrations to your spreadsheets or word processing documents. You can also use layout 

and publishing software to combine Visual CADD™ drawings with other text and 

graphic elements for visually appealing publications. 

To share text between Visual CADD™ and another application you use the Text Editor 

tool. 

To copy Visual CADD™ objects to another application: 

1. Select the Visual CADD™ entities you want to use in another application. 

2. Select Edit>Copy. 
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3. Switch to the other application, and select Edit>Paste. 

Note 
Visual CADD™ entities copied to the clipboard are pasted into other Windows 
applications as a Visual CADD™ Object (OLE). This results in a high quality 
image at different resolutions. 

To import text from another application: 

1. Within the other application, select the text 

you want to use. 

2. Select Edit>Copy. 

3. Switch to Visual CADD™, and then click the 

Text Editor tool. 

4. Select a point on the drawing at which to insert the text. 

5. In the Text Editor box, right click and select Paste. 

6. Click [OK] to place in the drawing. 

Alternately you can load the entire contents of an ASCII file (for example a .txt file) from 

within Text Editor. Start the tool, click on a placement point in the drawing, and then 

click the [Load ASCII File] button in the dialog. Choose a file and click [OK]. The file 

content is now loaded into the Text Editor window, ready for editing and/or placement in 

your drawing. 

To bypass Text Editor and load the text file directly into the drawing instead, select Load 

Text File (LA) from the Text section of the Draw menu. Choose a file, click [OK] to 

close the dialog, and a bounding box containing the text is attached to your cursor. Left 

click to place it in the drawing. 

Tip 
You can use OLE to import non-ASCII text from programs such as Word and 
Wordperfect. 

To use Visual CADD™ text in another application: 

1. In Visual CADD™, select a text object, and 

then click the Text Editor tool. 

2. In the Text Editor box, select the text you want 

to export, then right click and select Copy. 

3. Open the other application, and then select Edit>Paste. 
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Linking and Embedding Objects (OLE)   

OLE is a method to transfer and share information between Windows applications by 

including data created in one application into a document created in another application. 

Visual CADD™ works with OLE in both directions; you can paste or insert Visual 

CADD™ drawings into another application if it supports OLE, and you can paste or 

insert the contents of a graphic, spreadsheet, or word processing file into Visual 

CADD™. 

The application that sends the information to the second app is often called a server. The 

application receiving the information is called a client, or container. 

Data from other applications can be brought into Visual CADD™ using one of two 

methods. Paste Object takes objects on the clipboard and pastes them into Visual 

CADD™ as an OLE object. Examples might include several selected paragraphs of a 

word processing document, or a range of cells in a spreadsheet. 

Use Insert OLE Object to insert the entire contents of a file from another application into 

Visual CADD™. You choose an object type (for example, an Excel or WordPerfect file), 

and whether to insert an existing file on disk or a brand new file. 

Both commands work only if the application you are copying data from supports Object 

Linking and Embedding (OLE). If you copy information to the clipboard from the non-

OLE program and then try to paste it into Visual CADD™, Paste Object will be greyed 

out and not available from the Edit menu. If you try to insert an object from a non-OLE 

server, you may only see an icon in the drawing, representing the object type, or an error 

message telling you the insertion was not successful. 

Insert OLE Object allows you to either link or embed the object; Paste Object always 

places an embedded object. 

The difference between embedded versus linked has to do with where the native data is 

stored. We will use a Microsoft Excel spreadsheet as an example. Embedded stores the 

native Excel data into the Visual CADD™ drawing (in the VCD file), whereas linked 

stores a path to an Excel sheet and the native Excel data stays in that file (an XLS). 

Either way, the object is editable. Changes made to an embedded Object are saved in the 

VCD file. Changes made to a linked Object are saved in the original file, and the view is 

updated in Visual CADD™ to reflect the changes. 
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Because an OLE Object is a special type of Windows object, the Visual CADD™ 

commands have no effect on it. You cannot snap to the OLE Object, or use Rotate or any 

of the Copy commands. 

OLE Objects are placed in the upper left corner of a Visual CADD™ drawing. To move 

it, select the Object by clicking on it, hold down the left mouse button, and drag it to 

another location. If you use a line tool as your default, click the Selection arrow on the 

side toolbar (or type SE), then select the Object. 

You can change the size of the OLE Object, the layer it appears on, and the draw order as 

it relates to other OLE Objects and all Visual CADD™ objects, by selecting the Object, 

right clicking and clicking Properties to open a dialog. 

To paste objects on the clipboard from other applications into Visual 
CADD™: 

1. Use the Copy command in the other application to copy the objects to the clipboard. 

2. Choose the Paste Object command. 

The clipboard contents are pasted into the drawing. The contents remain on the clipboard, 

ready to be placed into the current or another Visual CADD™ drawing, or another 

Windows application that supports OLE. The information remains on the clipboard until 

you clear it, place new objects on it with Cut or Copy, or exit Windows. 

To Insert an OLE Object into Visual CADD™: 

1. Start the Insert OLE Object command from the Edit menu. 

2. On the Insert Object dialog that appears, choose whether you want to insert a new 

Object or an existing file. 

3. If you choose Create Object, pick from the Object Type list. 

Note that the list shows all object types on your computer. Some types might not be 

applicable for creating a new object inside the Visual CADD™ environment. 

4. If you choose Create from File, click [Browse] and navigate to the folder containing 

the file. Select it and press [Open]. 

Note that by default the file information will be embedded. If you want to link to the 

file instead, check the Link box. 
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5. Click the [OK] button. 

By default, when the Object is inserted into the drawing a Properties dialog pops up 

allowing you to edit the OLE Object. If you do not want this behavior, uncheck the 

Display dialog while inserting box at the bottom of the dialog, and do an Environment 

Save (EN) so that this setting "sticks" next time you open Visual CADD™. 

Creating Export Files  

If the application you are using does not support the Windows clipboard, you can create 

an export file containing the graphic information, and then place that file in your 

application. 

The Windows metafile format is the most flexible, as it supports line-weight control as 

well as filled entities, and displays on the screen what you will see in print. The 

encapsulated Postscript (EPS) format allows line-weight control and filled entities, but 

most applications will not display the graphic object until you print. The Hewlett Packard 

graphics language (HP-GL) format is the least flexible as it does not support lineweight 

control and it uses parallel lines to approximate filled entities. HP-GL also cannot be 

displayed for preview by most applications but may be used if the other formats are not 

available in your application. 

Creating a metafile is as simple as saving a file in the proper format. Creating EPS and 

HP-GL files requires that you set Windows to send printer or plotter output to a file. 

If you use this method, remember to set printer output back to a port when you are done, 

or you will be unable to print to a physical printer. You can simplify this process by 

setting up a separate printer description for each type of output that you use by using the 

Add Printer wizard in Windows. For further information about setting up different 

printers, see your Windows documentation. 

Tip 
To export only part of a drawing, select those entities to be included in the 
export file, and then check Save Selected in the Save As dialog. 
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File Format Differences 

To create a Windows metafile: 

1. Select File>Export>Images. 

2. Select WMF/AFM or EMF from the Image Type 

dropdown and then click the [Save Image] button. 

3. Specify a file name, and click [Save]. 

To create an encapsulated Postscript (.eps) 
file: 

1. Select File>Print. 

2. In the Print dialog, select a printer that supports Postscript. 

3. Change settings as desired for Scale, Rotation etc. 

4. Tick the Print to File checkbox and click [Print]. 

5. In the Print to File dialog, type a filename and click [Save]. In Windows Explorer 

(file manager), rename the file extension to .eps. 

To create an HPGL file: 

1. Select File>Plot. 
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2. In the Plot dialog Plotter list select Default Settings for HGPL Plotters. 

3. Change settings as desired for Scale, Rotation etc. 

4. Tick the Plot to File check box and click [Plot]. 

5. In the Plot to File dialog type a filename, select a file type, and then click [Save]. 

Sharing Files with AutoCAD and Generic CADD  

Visual CADD™ can read and write both AutoCAD and Generic CADD file formats. 

Because the three applications support different features, some objects and information 

might not be translated. 

For instance, because of the way Generic CADD was originally written, hatches do not 

import into Visual CADD™ at all but instead are converted to either a symbol or a single 

Visual CADD™ hatch pattern, depending on choices you make in a settings dialog. 

AutoCAD’s Paper space viewports are imported as bound reference frame entities. 

Although Visual CADD™ does not use AutoCAD’s Extended Entity Data, it will store it 

with a drawing and include it if the drawing is translated back into the AutoCAD format. 

You have access to Extended Entity Data through Visual CADD™’s programming 

interface. 

Version imports and exports AutoCAD files from R12 through R2013. Newer DWG 

formats will be supported by Visual CADD™ update patches. Check at 

www.tritools.com. 

When you "open" an AutoCAD or Generic CADD drawing, it is not opened in its native 

format. For example, if you open a DWG, each object will be converted into its Visual 

CADD™ equivalent. Your original DWG file at this point is still intact and unchanged. 

However, if you modify the drawing in Visual CADD™ and then select the Save 

command, the file is converted back to the DWG format and saved, overwriting the 

original with the changes. 

If retaining the original file is important, use the SaveAs command instead to save the file 

with the same name in the VCD format, or with a different name in the DWG format. 

To open an AutoCAD or Generic CADD drawing in Visual CADD™: 

1. Select File>Import>CADD Files. 

http://www.tritools.com/
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2. In the Open File dialog, click the Files of Type list, and then select either AutoCAD 

(.dwg) or Generic CADD (.gcd). 

3. Select the file to open. 

4. Click [Open]. 

To save an open AutoCAD or Generic CADD drawing to the original format: 

1. Select File>Export>CADD Files. 

2. Click the Files of Type dropdown list, and then select either AutoCAD (.dwg) or 

Generic CADD (.gcd). 

3. Specify the folder and filename in which to save the file. 

4. Click [Save]. 

Tip 

Unlike earlier ACAD versions, R2000 and later DWG files are automatically 
created with one empty layout space (a layout view is the same as a Paper 
Space view). If this view is empty, Visual CADD™ will not load it. If the Layout 
Space contains data, that view opens and you are prompted to save the Model 
Space file that links to the view. 

Converting AutoCAD Xrefs and Paper Space 

External references are imported into Visual CADD™ as linked reference frames, with 

the option of converting all linked files to .vcd format, or maintaining them as .dwg files. 

Linked reference frame entities export to AutoCAD as Xref insert entities. Bound 

reference frame entities are simply exploded. If the view of any reference frame is not the 

entire source object, all reference frame entities also map into AutoCAD viewport entities 

in paper space and the entities are tiled in model space. The AutoCAD paper space 

drawing appears the same as the original Visual CADD™ drawing. 

Tip 
If you open an AutoCAD drawing that contains external references, both the 
drawing and external reference files must be located in the same folder. 

AutoCAD and Generic CADD Translation Settings  

Although Visual CADD™, AutoCAD, and Generic CADD operate differently, you can 

adjust the way in which certain entities and properties are translated. 
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Duplicating Generic CADD hatch patterns 

Because of the way Generic CADD defines hatch patterns, they cannot be used in Visual 

CADD™. When converting, you can choose to have Visual CADD™ replace each hatch 

with a symbol that looks exactly like the Generic CADD hatch pattern. However, it is no 

longer an associative hatch and cannot be edited or modified. 

Or, you can choose to select a single Visual CADD™ hatch pattern to apply to all the 

imported hatches. Once the drawing is converted to Visual CADD™, you will have to go 

back and edit each hatch to get it to look the same as in GCADD. But the advantage is 

that all hatches are now associative (they will update when you stretch them, for 

example) and are completely editable for color, scale, and rotation. 

Setting AutoCAD Measurement Units 

When converting AutoCAD drawings into Visual CADD™, you must identify the unit of 

measurement in which they were drawn because it is not stored in the DWG files. 

Converting AutoCAD XRefs 

When you open an AutoCAD drawing that contains XRefs, you must decide how to treat 

the drawings to which the XRefs refer. You can either leave them in the AutoCAD 

format or you can convert them to the Visual CADD™ format. 

Translating AutoCAD Colors 

In AutoCAD, a numbered screen color is mapped to a plotter pen. On pen plotters, the 

color number is more important than the displayed color. If you use an inkjet plotter, the 

displayed color itself is often more important. Visual CADD™ uses color mapping to 

give you an unlimited choice of options for translating colors between the two programs. 

A default map is set, but you can also use custom maps for AutoCAD Windows colors, 

and a Visual CADD™ default of 1-to-1 (color 0 to color 0, color 1 to color 1, etc.). You 

can also create and save your own color maps of any combination. 

Importing Fonts Correctly 

When you import a drawing, you can choose “Ignore,” and all of the font names used in 

the drawing will be unchanged in the Visual CADD™ drawing. But you must first use 

the Font Converter to translate AutoCAD or Generic CADD fonts into a form that Visual 
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CADD™ understands before you import the drawing. Once done, the fonts will appear 

the same in both versions of the drawing. 

If you do not have the original AutoCAD or Generic CADD font files, or you do not want 

to convert them, you can use font mapping to translate AutoCAD or Generic CADD font 

names into names of fonts available to Visual CADD™. 

Generic CADD Translation Settings 

This dialog opens when you 

click on GCD Import/Export 

Settings on the Utilities menu. 

For complete details on each 

setting see the Help file. 

 The Hatch section gives you the choice of converting all hatches to a symbol so that 
they will appear the same in Visual CADD™ as they did in GCADD, or converts 
them all to a specific Visual CADD™ hatch so that they can be edited later. 

 If Ignore font map is checked, original font names are retained on import rather than 
using font mapping (more on that later in this chapter). 

 You set a default font for both import and export so that if no font match is found 
during the conversion, these fonts are substituted instead onscreen, if there is no font 
mapping specified. Substituted fonts still retain the original name in the file. 

AutoCAD Translation Settings 

This dialog opens when you 

click on DWG Import/ Export 

Settings on the Utilities menu. 

For complete details on each 

setting see the Help file. 
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 Choose the ACAD version for exporting from Visual CADD™. 

 Specify whether to convert XRef files or leave as DWG files. 

 Specify the method of Symbol conversion when using non-inch numeric settings. 

 Specify the unit settings for conversion. 

 Specify font mapping options (same as described on the Generic CADD settings 
dialog above). 

Adjusting Font Mapping  

Visual CADD™, AutoCAD, and Generic CADD do not use the same fonts. When 

converting a file between formats, you must decide how to substitute for fonts that exist 

in one application but not in the other. You can choose that a single default font be used 

whenever a font match is not found, both on import or export. 

If multiple fonts exist in either the DWG you are importing or the Visual CADD™ file 

you are exporting, a more flexible and powerful option is to create font maps to substitute 

a specific font for another specific font in the other program. 

Font maps simply describe the way in which font names are translated during file 

conversion. For example, you can specify that every time the font named “TXT” is found 

in an AutoCAD drawing, it is replaced with the font named “Engineer” when the drawing 

is loaded into Visual CADD™. 

Font maps can be saved to the folder of your choice, and then reloaded later. This is 

handy if you have clients or customers with different font requirements. Note that the file 

extension is .fnt for both the import and export font maps, so the file name itself should 

reflect whether you are converting in or out of Visual CADD™. 

If you have an AutoCAD or Generic 

CADD font name that is not shown 

on the font list, you can click [Add] 

to add a new name. The number of 

fonts on the list is limited to 32. 

Remove a font name by clicking the 

[Remove] button. 

If you include a font in your font map 

that is not on the computer, the 
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default font for import and export on the GCD or DWG Import/Export Settings tabs is 

substituted instead. For example, suppose you have set Arial as your default import font. 

If your font map replaces "TXT" from the DWG with "Engineer" in the VCD, but the 

Engineer font is not found on your system, TXT will map to Arial instead. 

Tip 
To avoid the need to translate font names, use the Font Converter on the 
Utilities menu to translate your AutoCAD and Generic CADD fonts to a Visual 
CADD™ vector font. 

Adjusting Color Mapping  

Visual CADD™ and AutoCAD have very different color indexes. Because AutoCAD 

maps colors to pen width for printed output, it is often important to retain these colors on 

drawings that you import and then must export back to consultants or others you share 

drawing files with. Color mapping provides the ability to match to other color indexes. 

Visual CADD™ uses a default mapping that is an accurate close match between Visual 

CADD™ and ACAD colors. This option is set by default on the tabs for both Color 

Import and Color Export, and all other controls are greyed out. 

Custom Maps 

To use an alternate mapping scheme, click the Use Custom Map button. Sample custom 

maps are provided for both AutoCAD Windows colors and One To One ( DWG color 1 

to VCD color 1, etc.). But you can also create your own maps for any other combination 

of colors. The Default map is included in the list. You cannot edit this map, but you can 

use it as the basis of a custom map by clicking the [New Map] button and assigning it a 

new name. Edit the new map, and when finished click [Save Map]. 

You can also map linewidth to color, or ignore color mapping on import and force all 

colors to a particular color that you designate. You can delete any custom map that you 

create. 

To Create a New Color Map: 

1. Select a map in the Map dropdown to 

use as the basis for your new map. 

2. Press the [New Map] button. 

3. Enter a name for the new color map 

and press [OK]. 
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4. The new name is shown as current in the Map dropdown list. 

5. In the edit boxes, make changes to Visual CADD™ colors to correspond with each 

DWG color. If you want to include linewidth mapping, uncheck the "Ignore" box and 

type a line-width to correspond with each DWG color. 

6. Alternatively, check the "All Colors to:" checkbox and type a color number in the 

right hand edit box to force all DWG colors to a single Visual CADD™ color. 

7. Press [Save Map] to save the new map and [OK] to finish. 

Note 
Do an Environment Save (EN) to make the custom map current the next time 
you open Visual CADD™. 

To Create a New Color Export Map: 

1. Select a map in the Map dropdown to use as the basis for your new map. Press the 

[New Map] button. 

2. Enter a name for the new color map and press [OK]. 

3. The new name is shown as current in the dialog dropdown list. 

4. Decide whether to convert color to color or Visual CADD™ linewidth to DWG 

color. 

5. In the edit boxes, make changes to Visual CADD™ linewidth and/or DWG colors. 

6. Press [Save Map] to save the new map and [OK] to finish. 

Tip 

Prior to AutoCAD 2000, setting a lineweight property in a DWG was not an 
option; for printed output a lineweight was mapped to a color in the display. 
Many AutoCAD users continue to use this method. You can map DWG colors to 
a Visual CADD™ linewidth when creating a custom color map, to approximate 
Visual CADD™’s linewidth feature. 
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C H A P T E R  

15 
PRINTING AND OTHER OUTPUT 

Because hand drafting involves recording information directly on paper, no extra process 

is required to create printed output. You hold the reproducible copy in hand. But when 

finished, you have limited presentation options. With Visual CADD™ you can present 

drawings in many different ways. 

For example, you can print your drawings to various printers and plotters. You can print 

the same drawing at many different sizes and types of media for different types of 

presentation. You can either have Visual CADD™ fit the drawing onto the page or you 

can specify an exact scale if the drawing will be used for technical drawings or 

construction documents. 

Drawings can also be exported from within Visual CADD™ to another file type, for 

example as a PDF or XML, and in raster image formats such as BMP, TIF, GIF, or JPG. 

You can save all the settings on the Print dialog as a Preset, and then call up different 

presets to quickly change paper sizes, orientation, margins, and even printers. 

If you have an older vector output device such as a pen plotter, Visual CADD™ provides 

you with control over line weight that is not available by using the standard Windows 

printer drivers. 

Printing Your Drawing  

Printing can be as simple as sizing the drawing to your paper size and then clicking 
[Print]. If you have more complex requirements, you can adjust Visual CADD™’s print 
settings to print the drawing at an exact scale. 
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Print settings give you control over the size and orientation of your drawing on the 
page as well as a variety of options for expediting printing and controlling various 
printers. 

Visual CADD™’s preview window lets you check output before you send it to the 
printer, and to make changes to margins, orientation, and scale before you do so. 

If your computer is not connected to the printer you want to use, you can store the 
output in an export file for later use. 

Print Settings 

Open the Print dialog from the icon on the main 

toolbar, from the File menu, or by typing PR. 

Printer Settings 

Sets the standard Windows printer settings. 

Choose a printer installed on your machine or 

network from the dropdown list and set 

properties, paper size, and margin sizes. Also 

select the unit to measure paper size and 

margins. 

Presets 

Adding a Print Preset takes a "snapshot" of all 

settings on the Print dialog, which can then be 

called up at a later time to quickly change all 

print settings. 

Print Scale and Orientation 

Sets the factor by which the drawing will be 

scaled when the Scale option is checked. Use the 

[Select a Scale] button to choose from a list of common print scales. 

The drawing Origin is relative to the lower left corner of the margin. The units of 

measure are those of the page size and not of the drawing. 
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Specify whether the drawing is to be scaled to fit the paper size, scaled so that the 

displayed onscreen view will fill the page, or scaled to a factor that you enter. 

Select between horizontal (landscape) and vertical (portrait) page orientation. Select 

number of copies to print. 

Set the rotation angle of your drawing relative to the paper (zero by default). 

Print Options 

Selection Only - prints only the entities that have been selected in the drawing. 

All Colors to Black - prints all entities in black, regardless of their color in the drawing. 

Center on Page - when checked, drawing is always centered on the page. 

Print to File - sends the output to a file on the disk drive or network. 

Lineweight 0 has Width - sets the finest line width in your drawing. Unchecked, Visual 

CADD™ prints the finest line your printer can output. Checked, Visual CADD™ prints 

the smallest linewidth as LW0. 

Baseline Width - sets the base or minimum width for line output from your printer. 

In addition to the standard Print and Cancel buttons on the dialog, the Center button will 

center the drawing on the printed page when the Always Center on Page checkbox is 

unchecked. The File Stamp button opens a dialog to add a date stamp on the printed 

page’s edge. You can add a watermark to the background of the drawing from this dialog. 

See the Help file for more details on the feature. 

Adjusting Print Settings 
and Options 

You can change the size of margins by 

clicking [Margins] on the Print dialog, 

and then typing new values. Margins 

can be no larger than the maximum 

print area defined by your printer. The 

printer cannot print to the edge of the 
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paper. Often the printer can print no less than 1/4" from the edge of the paper. Page Size 

is, at maximum, the actual usable area on the paper for printing. 

After changing the Print Scale of your drawing, you can drag the preview into position to 

display the portion you want to print. 

Common Print Scales: 

Print Scale … Real World Scale … 
3/32” = 1’ 1” = 128” 
1/8” = 1’ 1” = 96” 
3/16” 1’ 1” = 64” 
1/4” = 1’ 1” = 48” 
3/8” = 1’ 1” = 32” 
1/2” = 1’ 1” = 24” 
3/4” = 1’ 1” = 16” 
1” = 1’ 1” = 12” 
1 1/2” = 1’ 1” = 8” 
3” = 1’ 1” = 4” 

The scales above apply if your Numeric Units are set to Inches or Feet and Inches. If your 

units are set to Feet and you wanted to output at a print scale of 1/4”= 1’, the Real world 

value would be 1"=4’. 

The [Select a Scale] button in the Print Scale section provides a dropdown list of many of 

the most often used scales in the architectural and engineering disciplines, in both English 

and Metric units. Alternately, you can type any scale value directly into the Real World 

scale edit box on the Print dialog. 

Printing options 

 To print an entire drawing: 

1. Select File>Print. 

2. Click Fit to Paper and then 

click [Print]. 
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 To print a portion of a drawing: 

1. Zoom to display a portion of your drawing. 

2. Select File>Print. 

3. Click Current View and then click [Print]. 

 To set printing margins: 

1. Select File>Print. 

2. Click [Margins]. 

3. Adjust the margin settings. 

4. Click [OK] to return to the Print dialog. 

Note 
Clicking [Default] in the Margins dialog returns the settings to the default values 
of the selected printer. 

To select a different printer: 

1. Select File>Print. 

2. Click the down arrow in the Printer box at top of Print dialog to dropdown the list 

that shows available printers. 

3. Choose a printer from the list to make it current. 

4. Click [Print Properties] if you want to modify settings for that particular printer. This 

opens the typical Windows dialogs as installed by the printer manufacturer. 

5. After making changes click [OK] to return to the Visual CADD™ Print dialog. 

To select a different printer: 

1. Select File>Print. 

2. Click the down arrow in the Printer box at top of Print dialog to dropdown the list 

that shows available printers. 

3. Choose a printer from the list to make it current. 

4. Click [Print Properties] if you want to modify settings for that particular printer. This 

opens the typical Windows dialogs as installed by the printer manufacturer. 

5. After making changes click [OK] to return to the Visual CADD™ Print dialog. 

To create a print file: 

1. Select File>Print. 
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2. Check Print to File, and then click [Print]. 

3. Type a name and folder in which to save the print file, select a file type, and then 

click [Save]. 

Print Presets  

If your printing output often includes changes to settings such as paper size, scale, and 

different printers, you know how time consuming it can be to set each individual option. 

Visual CADD™ lets you take a "snapshot" of all the settings on the Print dialog, saving 

them for later use. One way to think of presets is as a print "style". Once you add a preset, 

it can be called up quickly from a list on the Print dialog. 

Presets can be modified or deleted at any time. 

To Add a Preset: 

1. Make changes to the Print dialog settings as desired. 

2. Click the [Add] button in the Preset section of the Print dialog. 

3. Enter the name of your new Preset, and press [OK] to finish. 

Note 
You can use almost any character in naming Presets. The exceptions are 
quotes (") and apostrophe (’). Maximum length is 79 characters; spaces 
between words are OK. 

To apply a Preset: 

1. Open the Print Dialog by selecting File>Print or typing PR. 

2. In the Preset dropdown list, choose Default or any of the Presets that you have 

created. 

3. Press the [Print] button to print the drawing. 

Note 

Change any setting after applying a Preset, but before printing your drawing, 
and it will affect the current print. If you close the Print dialog without clicking the 
Modify button to save the changes, they will not apply next time you use that 
Preset. 

To Modify a Preset: 

1. Make sure the Print Preset that you wish to modify is current in the preset dropdown. 
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2. Make changes to the settings on the Print dialog as desired. 

3. Click the [Modify] button. 

To Delete a Preset: 

1. Pick the Preset that you wish to delete from the preset dropdown. 

2. Click the [Delete] button. 

Note 

The Default is not really a Preset at all--it does not work the same as any of the 
Presets that you create. With Default applied, if you make changes in the dialog 
and then Print, those changes will also apply next time you open the Print 
dialog. 

Output as PDF  

You can export drawings directly from Visual CADD™ to the Portable Document File 

format and share them with your customers. PDF files preserve the look and integrity of 

your Visual CADD™ drawings, and you can share them with anyone electronically, 

regardless of hardware and software platforms. 

PDF files are compact and complete, and can be shared, viewed, and printed by anyone 

with the free Adobe Reader software. A copy is included on the Visual CADD™ CD; 

you can also download the Reader at www.adobe.com. If your customers have the full 

Adobe Acrobat software, they can redline the drawings and return them for revisions. 

Visual CADD™ creates vector PDF output; this results in much higher quality files than 

those created by PDF writers that produce raster (bitmap) files. 

PDF output from Visual CADD™ also has optional security features to protect sensitive 

drawings. If desired, you can set password protection for opening files, as well as 

individual permissions for printing, editing and copying. 

Although several of the 

settings options are unique 

to PDF, the PDF Export 

dialog will be familiar to 

you because the layout is 

based on the Print dialog, 

as shown in the illustration 

at right. You can save all of 

http://www.adobe.com/
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a drawing or a selection to PDF, and scale the output or fit to the paper size (that the PDF 

will ultimately be printed to). You can take a snapshot of settings and save them as a PDF 

Preset. 

A list of default page sizes is included, but at the bottom of that list is the option to open a 

dialog and create custom pages sizes or edit the existing ones. You can also adjust 

Margins for a particular page size and save the configuration as a Preset. 

There is an option to use compression, which will reduce file size significantly. We 

recommend that you use it; because the PDF is saved in vector format, the quality of the 

output will not suffer with compression applied. 

Another feature, available from the Properties button, is the ability to export Visual 

CADD™ layers with the PDF file. If your PDF viewing software supports layers, you 

can display and hide layers both onscreen viewing and with print output. 

Tip 

Be careful about outputting a PDF file that contains OLE Objects if you intend to 
transfer it to clients electronically. The Object is saved as a bitmap in the file, 
and depending on the size of the Object and the resolution, PDF files can 
become quite large. Experiment with the OLE Resolution setting to reduce file 
size. 

Output as Image  

You can export vector based Visual CADD™ drawings to a raster image file format so 

that they can be used for display on websites or in printed materials such as brochures, 

reports, and other documents. The Image Export dialog has a wide range of settings to 

help you control the image type, size, and other options for image output. 

There are 7 choices for image type: GIF, PNG, JPG, BMP, TIFF, EMF and WMF. The 

first three are highly compressed and are suitable for the Internet due to smaller file sizes. 

PNG is the functional equivalent but improved version of GIF and is supported by 

modern web browsers. JPG is a popular format and works well on photographs, 

naturalistic artwork, and similar material, but it is usually not the best choice for line 

drawings such as CADD files. 

The other formats are more suitable for printed applications due to larger file sizes (but 

higher quality images). TIFF is a long established choice for artwork in publications; all 

illustrations in this Users Guide are TIFF files. 
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EMF and WMF are 

included as legacy formats; 

they were used in early 

versions of Visual 

CADD™ and date back to 

Windows 3.1 thru Windows 

XP. EMF is an enhanced 

version of WMF. We 

recommend that you export 

to the newer graphic 

formats. 

The Help file topic Image 

Export provides more 

detailed information on 

each format, as well as a 

detailed description of the 

settings on the dialog as they apply to the particular image types. 

Although many of these settings options are unique to raster images, the Image Export 

dialog will look familiar because the general layout is based on the Print dialog. You can 

either choose a scale or decide to fit to “paper” -- which is the width and height of the 

overall image, that you specify in pixels, inches, mm, or cm. You can save a collection of 

settings for a particular image type by creating Presets, in the same manner that you 

would create one for Print settings. 

Using Direct Plotting  

If you have an older vector output device such as a pen plotter, you can use Visual 

CADD™’s direct plotting features to enhance control over the device. By using direct 

plot, you bypass the Windows print drivers and send information directly to the plotter. 

Direct plot allows you to use plotters that do not have a Windows driver. 

Using direct plot provides control over pen mapping. When you use pen mapping, 

remember that many inkjet plotters use pen numbers to refer to different line types. 

Certain pen numbers or ranges of pen numbers may refer to lines that are not solid or that 

are created using a grayscale fill. If you check All Colors to Black in the Plot dialog, all 

colors will plot using the pen mapped to color 0, which is normally black. 
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Visual CADD™ increases plotting speed by using pen sorting and motion optimization. 

Both features take more memory, but they increase overall plot speed. Pen sorting 

reduces pen changes by assuring that each pen is used only once. Motion optimization 

improves plot performance by minimizing unnecessary pen movements and drawing 

from one end of the sheet to the other whenever possible. 

To use direct plotting, make sure that your plotter is configured for hardware flow 

control. 

Tip 

The Direct Plot routines were designed specifically for devices not supported by 
Windows, such as pen plotters and vinyl cutters. Inkjet plotters --which are really 
just large scale raster printers-- may or may not work well with Direct Plot. The 
Print command is the better way to go with inkjets. If you want control over line 
and pen management with Print, or advanced HPGL-2 features, check out the 
WinLINE print/ plot driver at www.winline.com. 

 

Note 
Direct plotting does not support TrueType fonts. Vector fonts will be substituted 
for TrueType fonts when direct plotting is used. 

Pen Mapping Settings 

Opens when you press the 

[Pen Map] button on the Plot 

dialog. 

A - list of available pen 

maps. 

B - pen number assigned to a 

color. 

C - the color of the 

corresponding pen. 

D - creates a new pen map 

from current settings. 

E - resets the map to its 

http://www.winline.com/
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original settings. 

F - adjusts the width of a pen in millimeters. Used to create solid fills. 

G - sets speed at which the pen moves across the paper, in millimeters per second. 

Plotter Connection Settings 

Opens when you select a 

plotter from the list at the top 

of the Plot dialog and then 

press the [Plotter Properties] 

button. 

A - displays the plotter for 

which the current settings 

are listed. 

B - specifies the 

communications port to 

which the plotter is 

connected. 

C - specifies the communication settings. 

D - sets the number of pen carousels to be used. 

E- sets the number of pens in each carousel. 

F - check this box if you are using more than one carousel. 

G - creates a new plotter definition. 

H - when checked, sends the plot file out to disk buffer before sending it to the plotter. 

I - when checked, activates pen sorting. 

J - when checked, activates motion optimization. 
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K - when checked, places the origin in the lower left corner of the media. When 

unchecked, places it in the center of the media. 

L - selects the size of the plotter media. Page Size reflects the printed area on the page 

and not the actual sheet size. 

M - adds a new page size to the Page Size list by using the values set in the Length and 

Width boxes. 

N - deletes the current page size from the list. 

O - specifies the maximum resolution of the plotter in dots per inch. 

Tip 

Decrease overall plot time by checking Optimize Plotting and Sort Colors on 
the Plotter tab of the Plotter Settings dialog. 

To adjust the number of seconds that Visual CADD™ will wait for your 
plotter to respond, change the time-out value on the Plot dialog. 

Making a Custom Plotter Configuration  

If your plotter language is not already supported by Visual CADD™, you can easily 
create a custom plotter definition. Use the control codes listed in your plotter’s 
documentation to set up your plotter type. 

Plotter Language Settings 

Opens when you select a 

plotter from the list at the top 

of the Plot dialog and then 

press the [Plotter Properties] 

button, then the Language 

tab. 

A - specifies the plotter 

language for the current 

settings. 
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B - specifies the character that separates commands sent to the plotter. This field can be 

left blank. 

C - describes the commands that are sent to the plotter to initialize it. 

D - describes the commands that are sent to the plotter after a plot is completed. 

E - specifies which characters raise the pen from the paper. 

F - specifies which characters lower the pen to the paper. 

G - specifies the characters that signal the plotter to move the pen from one location to 

another in the up position. 

H - specifies the characters that signal the plotter to move the pen from one location to 

another in the down position. 

I - specifies the characters that set the pen speed for the current pen. 

J - specifies the characters that signal the plotter to change to a different pen. 

K - creates a new plotter language setting. 

L - restores the plotter language settings to the default values for an HPGL (Hewlett 

Packard graphics language) plotter. 

M - enables the use of HP-GL/2. Check this box to improve the quality of arcs and 

circles and decrease plot time if your plotter supports the HP-GL/2 graphics language. If 

you check this box, you need to provide an Init String that tells your plotter to recognize 

HP-GL/2 commands. 

Tip 
To add a control character to a field, type the caret symbol (") followed by a 
letter or up to three numerals. For example, type "27 for Esc, or "M for Enter. 
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Increasing Printing and Plotting Speed  

 Turn off unnecessary layers or make them non-printable. By eliminating information 
such as text or dimensions that you do not need in your plot, you can substantially 
reduce plot time. By using the same layer for all text and the same layer for all 
dimensions, you can easily hide these complex entities to enhance printing speed. 
Control the visibility of layers by selecting Layers>Layer Manager. 

 Turn off the display of fills, hatches, and line widths. By printing only the boundaries 
of fills and hatches, and by removing line widths, substantially less information is 
printed and printing time is reduced. You can access these display settings by 
selecting Utilities>Settings>System1. 

 Use simple hatch patterns. Avoid using hatch patterns that have many small elements. 
The smaller or more complex they are, the longer they take to plot. 

 Use HP-GL/2 if you can. HP-GL/2 reduces plot time by reducing the amount of 
information that needs to be sent to the plotter. You can access this setting from the 
Plot dialog by selecting Setup>Options>Language. 

 Set curve smoothness to a high value. Setting curve smoothness to a higher value 
causes Visual CADD™ to use fewer lines and create a rougher curve, but it increases 
plot speed. You can change Visual CADD™’s setting for curve smoothness on the 
Plot dialog. The value can range from 1–100. 
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A P P E N D I X  A  

KEYBOARD SHORTCUTS AND NATIVE COMMANDS 

 

A native command in Visual CADD™ means that it runs one of the internal commands 

when it is invoked. 

Any command can be run by typing a forward slash (/) followed by a native name on the 

command line (the status bar). For example to invoke the Linear Copy command, you 

would type /Copy. 

In most cases however you will start a native command from a menu, a toolbar icon, or a 

keyboard shortcut (CO is the shortcut for the Copy command). 

Many native commands will not work with a keyboard shortcut; they were designed to be 

used as part of a script, to define the settings that you draw with. Typically in a script you 

add a single parameter after the command. For example, DimTextHt;4; sets the 

dimension text height to 4 units high. 

See Chapter 13, Customizing Visual CADD™, and the online Help file for more 

information on writing and running scripts in Visual CADD™. 

To see the following list of commands sorted in three different ways, look for the topic 

titled Keyboard Shortcuts and Native Commands in the Visual CADD™ Help file. 

Quite a few of the native commands are toggles; they change the state of a setting, 

turning it on or off. Many of them have 2 or 3 letter shortcuts assigned; others do not. 

You can assign a shortcut to any toggle command on the Custom Shortcuts tab of the 

Utilities>Assign Script dialog (make sure it is not the same as an existing keyboard 

shortcut). In the following list, a toggle is marked with a star (*). 

Several of the native commands have multiple options for specific parameters that you 

must use; these are marked in the list with a plus sign (+). Please see the Scripting section 

of the Help file for a list of parameters and variables for specific commands. 
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Native Command   Shortcut     Command Description 

Absolute  MO  Manual Entry: Absolute 

AcadPolyW  
 

Convert Acad Polygon Width On/Off* 

Align  AG  Align 

AllLayEdOff  
 

All Layers Edit Off 

AllLayEdOn  
 

All Layers Edit On 

AllLayEdit  AL  All Layers Edit* 

AllLaySnOff  
 

All Layers Snap On 

AllLaySnOn  
 

All Layers Snap Off 

Aperture  AP  Aperture On/Off* 

Arc2  A2  Arc: 2-Point 

Arc3  A3  Arc: 3-Point 

AroScrnStep  
 

Arrow Key Screen Increment 

AroWrldStep  
 

Arrow Key World Increment 

ArrayCopy  AC  Array Copy 

ArrowFlip  AR  Flip Arrow* 

ArrowWorld  
 

Arrows World/Screen* 

AskCenter  
 

Zoom Ask Center Point* 

AtbColor  
 

Attribute: Set Color 

AtbEdit  
 

Attribute Edit 

AtbFont  
 

Attribute: Set Font 

AtbGlbLblDsp  
 

Attribute: Display Global Fields* 

AtbGlobalDsp  
 

Attribute: Display Global* 

AtbHt  
 

Attribute: Set Height 

AtbLclLblDsp  
 

Attribute: Display Local Fields* 

AtbLocalDsp  
 

Attribute: Display Local* 

AtbMove  
 

Attribute Move 

AtbUseLocal  
 

Attibute: Toggle Local/Global* 

AttAttach  TA  Attribute Attach 

AttCreate  TC  Attribute Create 

AttEmbed  TD  Attribute Embed 

AttOpen  TO  Load Attribute 

AttSave  TS  Save Attribute 

AutFilletOff  
 

AutoFillet Off 
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Native Command   Shortcut     Command Description 

AutFilletOn  
 

AutoFillet On 

AutoBack  
 

Auto Backup* 

AutoBackSec  
 

Auto Backup Interval 

AutoFillet  AF  AutoFillet* 

AutoMacro  
 

Automation Macro 

AutoSave  
 

Auto Save* 

AutoSaveSec  
 

Auto Save Interval 

BackColor  
 

Background Color 

BackRD  BA  Backward Redraw* 

Basepoint  MB  Manual Entry: BasePoint 

BasepointPt  
 

Basepoint Point (x, y) 

BezierCont  BC  Continuous Bezier Curve 

BezierSingle  BS  Single Bezier Curve 

BirdsEye  ZB  Bird's-Eye View 

Boolean  BO  Boolean 

Break  BR  Break 

BreakTo  BT  Break Objects to Edge Objects 

CBCopy  
 

Copy to Clipboard 

CBCut  
 

Cut to Clipboard 

CBPaste  
 

Paste from Clipboard 

CBPasteSpec  
 

Paste Special 

ChamDist1  
 

Chamfer Distance 1 

ChamDist2  
 

Chamfer Distance 2 

Chamfer  CH  Chamfer 

ChamferDist  C0  Chamfer Distance 

Change  CG  Change 

ChangeApply  
 

Change: Apply properties changes in scripts 

ChangeColor  
 

Change color in scripts + 

ChangeLType  
 

Change linetype in scripts + 

ChangeLWidth  
 

Change linewidth in scripts + 

ChangeLayer  
 

Change layer in scripts + 

ChangeRealW  
 

Change RW linewidth in scripts + 

CircDiam  CD  Circle: Diameter 



 

Visual CADD 7 User Guide 211 

 

Native Command   Shortcut     Command Description 

Circle2  C2  Circle: 2-Point 

Circle3  C3  Circle: 3-Point 

CleanData  XC  Clean/Erase 0 length entities 

Clear  DX  Clear Drawing 

CloseAll  
 

Close All 

CloseContr  CC  Close Contour 

ColorProp  CP  Color Property 

CompImages  
 

Compress Images when Saving* 

ConfigEdit  
 

Configuration Editor 

ConstPts  DC  Display Construction Points* 

ContLineEx  CX  Explode Continuous Lines* 

Copy  CO  Linear Copy 

CopySingle  C1  Single Copy 

CursColor  
 

Cursor Color 

CursFreeOff  
 

Cursor Free Off 

CursFreeOn  
 

Cursor Free On 

CursorFree  CF  Cursor Free* 

CursorSize  
 

Cursor Size on-screen 

Curve  CV  Spline Curve 

CurveTanPts  DV  Snap to Curve Tangent Points* 

DBMove  
 

Database Move 

DBScale  
 

Database Scale 

DBSet  DB  Double Line Settings 

DBView  
 

Database Viewer 

DWGChange  DG  Drawing: Change Properties 

DWGImpExp  
 

Import/Export DWG dialog 

DWGMove  
 

Drawing Move 

DWGPath  
 

Path: DWG 

DWGRotate  DT  Drawing: Rotate 

DWGScale  DZ  Drawing: Change Scale 

DXFPath  
 

Path: DXF 

Datum  DU  Datum Dimension 

DatumOff  
 

Datum Dimension Off 
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Native Command   Shortcut     Command Description 

DatumX  
 

Datum X 

DatumXY  
 

Datum XY 

DatumY  
 

Datum Y 

DeSelAll  AD  DeSelect All 

DefTool  
 

Default Tool+ 

DefaultBtns  
 

Default Buttons* 

DigAlign  GA  Drawing Align 

DigMode  GM  Digitizer Mode* 

DigScale  GZ  Digitizer Scale 

DimAlign  D3  Dimension Direction: Aligned 

DimAng  DA  Angular Dimension 

DimAngDec  
 

Dimension Angle Decimal Places 

DimAngForm  
 

Numeric Dimension Angle Format+ 

DimAngle  
 

Dimension Angle Variable 

DimArrowAng  
 

Dimension Arrow Angle 

DimArrowFlip  
 

Dimension Arrow Flip* 

DimArrowSet  DMA  Dimension Arrow Settings 

DimArrowSize  
 

Dimension Arrow Size 

DimArrowType  
 

Dimension Arrow Type + 

DimAtAngle  D4  Dimension Direction: At Angle 

DimCh  
 

Dimension Edit 

DimCumul  D6  Dimension Mode: Cumulative 

DimDecimal  
 

Numeric Dimension Decimal+ 

DimDia  DD  Diameter Dimension 

DimDispSet  DMD  Dimension Display Settings 

DimDistForm  
 

Numeric Dimension Unit Format+ 

DimEdit  DE  Edit Dimension 

DimExtAbove  
 

Dimension Extension Above Distance 

DimExtBelow  
 

Dimension Extension Below Distance 

DimExtOffset  
 

Dimension Extension Offset Distance 

DimExtSet  DMX  Dimension Extension Settings 

DimFlipLeft  
 

Dimension Flip Distance Left 

DimFlipRight  
 

Dimension Flip Distance Right 
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Native Command   Shortcut     Command Description 

DimFraction  
 

Numeric Dimension Fractional+ 

DimHorz  D1  Dimension Direction: Horizontal 

DimHorzTxt  D8  Dimension Horizontal Text On/Off 

DimInlineTxt  D9  Dimension In-Line Text On/Off 

DimLayer  
 

Dimension Use Layer Variable 

DimLeadSet  DME  Dimension Leader Settings 

DimLeadZero  
 

Numeric Dimension Leading Zeros* 

DimLin  DL  Linear Dimension 

DimLineColor  
 

Dimension Line Color 

DimLineSet  DML  Dimension Line Settings 

DimLineShow  
 

Dimension Line Display* 

DimLineType  
 

Dimension Line Type 

DimLineWidth  
 

Dimension Line Width 

DimLtArColor  
 

Dimension Left Arrow Color 

DimLtArShow  
 

Dimension Left Arrow Display* 

DimLtArType  
 

Dimension Left Arrow Type 

DimLtArWidth  
 

Dimension Left Arrow Width 

DimLtExColor  
 

Dimension Left Extension Color 

DimLtExShow  
 

Dimension Left Extension Display* 

DimLtExType  
 

Dimension Left Extension Type 

DimLtExWidth  
 

Dimension Left Extension Width 

DimMoveArc  
 

Dimension Move Arc 

DimMoveLine  
 

Dimension Move Line 

DimMoveTxt  
 

Dimension Text Move 

DimOrd  DO  Ordinate Dimension 

DimPart  D7  Dimension Mode: Partitioned 

DimRad  DR  Radial Dimension 

DimRefFlip  
 

Dimension Reference Flip 

DimRtArColor  
 

Dimension Right Arrow Color 

DimRtArShow  
 

Dimension Right Arrow Display* 

DimRtArType  
 

Dimension Right Arrow Type 

DimRtArWidth  
 

Dimension Right Arrow Width 

DimRtExColor  
 

Dimension Right Extension Color 
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Native Command   Shortcut     Command Description 

DimRtExShow  
 

Dimension Right Extension Display* 

DimRtExType  
 

Dimension Right Extension Type 

DimRtExWidth  
 

Dimension Right Extension Width 

DimSUFrac  
 

Numeric Dimension Show Single Unit Fraction* 

DimScaleSet  DMZ  Dimension Scale 

DimSecForm  
 

Numeric Dimension Secondary Unit+ 

DimSecond  
 

Numeric Dimension Show Secondary Units* 

DimSelected  MM  Dimension Selected 

DimSingle  D5  Dimension Mode: Single 

DimSlideTxt  
 

Dimension Text Slide 

DimStrSet  DMS  Dimension String Settings 

DimStretch  
 

Dimension Stretch* 

DimTextAbove  
 

Dimension Text Above 

DimTextAlign  DMG  Dimension Text Alignment 

DimTextAltRo  
 

Dimension Text Alternate Rotation* 

DimTextAsp  
 

Dimension Text Aspect 

DimTextBold  
 

Dimension Text Bold* 

DimTextCent  
 

Dimension Text Centered* 

DimTextChSp  
 

Dimension Text Character Spacing 

DimTextColor  
 

Dimension Text Color 

DimTextFill  
 

Dimension Text Fill* 

DimTextFont  
 

Dimension Text Font 

DimTextHt  
 

Dimension Text Height 

DimTextInLn  
 

Dimension Text Inline 

DimTextItal  
 

Dimension Text Italic* 

DimTextLnSp  
 

Dimension Text Line Spacing 

DimTextMono  
 

Dimension Text Monospace* 

DimTextOvStr  
 

Dimension Text Overwrite String 

DimTextOvwrt  
 

Dimension Text Overwrite* 

DimTextPreSt  
 

Dimension Text Prefix String 

DimTextPrefx  
 

Dimension Text Prefix* 

DimTextScale  
 

Dimension Text Scale 

DimTextSet  DMT  Dimension Text Settings 
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Native Command   Shortcut     Command Description 

DimTextShow  
 

Dimension Text Display* 

DimTextSlant  
 

Dimension Text Slant 

DimTextSufSt  
 

Dimension Text Suffix String 

DimTextSuffx  
 

Dimension Text Suffix* 

DimTextTol  
 

Dimension Text Tolerance+ 

DimTextTolLo  
 

Dimension Text Tolerance Lower 

DimTextTolUp  
 

Dimension Text Tolerance Upper 

DimTextType  
 

Dimension Text Linetype 

DimTextUnder  
 

Dimension Text Underline* 

DimTextVect  DMV  Dimension Vector Text Settings 

DimTextVert  
 

Dimension Text Vertical+ 

DimTextWidth  
 

Dimension Text LineWidth 

DimTolSet  DMO  Dimension Tolerance Settings 

DimUnits  
 

Numeric Dimension Show Units* 

DimUseLayer  
 

Dimension Use Layer* 

DimVert  D2  Dimension Direction: Vertical 

DispAngDec  
 

Numeric Display Angle Decimal Places 

DispAngForm  
 

Numeric Display Angle Format+ 

DispDash  
 

Numeric Display Show Dash* 

DispDecimal  
 

Numeric Display Decimal+ 

DispDistForm  
 

Numeric Display Unit Format 

DispFraction  
 

Numeric Display Fractional+ 

DispLayers  
 

Layer: Display layer(s) in scripts 

DispLeadZero  
 

Numeric Display Leading Zero* 

DispUnits  
 

Numeric Display Units* 

DivBreak  
 

Divide Break into segments* 

Divide  IV  Divide speedbar 

DlgOk  
 

Dialog OK 

DllCmdLine  
 

DLL Command Line variable 

DllFunName  
 

Dll Function Name variable 

DllName  
 

Dll Name variable 

DllRun  
 

Dll Run 

DllRunNET  
 

Run Command from .NET DLL 
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Native Command   Shortcut     Command Description 

DllRunNested  
 

Dll Run Nested 

DrawAfter  DWA  Bring Above Object 

DrawBefore  DWH  Send Behind Object 

DrawFirst  DWB  Send to Back 

DrawLast  DWF  Bring to Front 

Edit  ED  Edit 

EditLinks  
 

OLE Link 

EllArc  EA  Elliptical Arc 

Ellipse  EP  Ellipse 

EnvSaveExit  
 

Save Environment on Exit* 

Erase  ER  Erase 

EraseLast  EL  Erase Last 

ExeName  
 

Exename Variable 

Explode  EX  Explode 

ExportCAD  XPC  Export CADD File 

ExportImage  XPI  Export to BMP, TIFF etc 

ExportPDF  XPP  Export to PDF 

ExportXML  XPX  Export XML 

Extend  XT  Extend Single 

FenceTrim  NT  Trim Objects to a Fence 

FileClose  FC  Close 

FileCompress  
 

File Compression 

FileExit  FX  Exit 

FileMerge  FM  Merge 

FileName  
 

Name File 

FileNew  FN  New 

FileOpen  FO  Open 

FilePlot  PL  Plot 

FilePrint  PR  Print 

FileProtect  
 

File Protection 

FileRun  FU  File Run 

FileSave  DS  Save 

FileSaveAll  FL  File Save All 
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Native Command   Shortcut     Command Description 

FileSaveAs  FA  Save As 

FileSend  SD  Send 

FillBnd  FB  Fill: Boundary 

FillColor  
 

Fill Color 

FillDrawBnd  
 

Fill Show Boundary 

FillSel  FS  Fill: Selected 

Fillet  FI  Fillet 

FilletPrvOff  
 

Preview Fillet Off 

FilletPrvOn  
 

Preview Fillet On 

FilletRVar  
 

Fillet Radius Variable 

FilletRad  FR  Fillet Radius 

Filter  SF  Selection Filter 

FitScale  FT  Fit Scale 

FltActive  
 

Filter Active On/Off* 

FltColor  
 

Filter Color 

FltEntity  
 

Filter Entity Type+ 

FltLayer  
 

Filter Layer 

FltLnType  
 

Filter Linetype 

FltLnWidth  
 

Filter Linewidth 

FltName  
 

Filter Name for Symbol, Text, Hatch & RefFrame Entity+ 

FltReset  
 

Filter Reset to \"All\" 

FontConv  
 

Font Converter 

FontShowFav  
 

Font: Show Favorites 

FontShowTT  
 

Font: Show TrueType 

FontShowVCF  
 

Font: Show Vector 

FontSort  
 

Font: Sorting 

GCDImpExp  
 

Import/Export GCD dialog 

GCDPath  
 

Path: GCD 

GetUpdate  
 

Check for Updates 

GridDisp  GR  Grid Display* 

GridOrg  GO  Grid Origin 

GridSize  GS  Grid Size (x, y) 

GridSizeX  
 

Grid Size X 
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Native Command   Shortcut     Command Description 

GridSizeY  
 

Grid Size Y 

Group  GP  Create a Group 

GroupApply  
 

Layer Group: Apply a Group(s) via a script 

GroupProp  GG  Layer Group: Use Layer Group properties On/Off* 

HandlePts  DH  Display Handle Points* 

HatchBnd  HB  Hatch: Boundary 

HatchCh  HC  Hatch Change 

HatchColor  
 

Hatch Color 

HatchDrawBnd  
 

Hatch Show Boundary* 

HatchLType  
 

Hatch: LineType 

HatchLayer  
 

Hatch: Layer 

HatchName  
 

Hatch Name 

HatchParse  
 

Hatch Definition Parse 

HatchRot  
 

Hatch Rotation 

HatchScale  
 

Hatch Scale 

HatchScaleX  
 

Hatch: Scale X 

HatchScaleY  
 

Hatch: Scale Y 

HatchSel  HS  Hatch: Selected 

HatchSet  HT  Hatch Settings 

HatchWidth  
 

Hatch: LineWidth 

HelpAbout  
 

Help, About 

HelpIndex  
 

Help, Index 

HelpOnCmd  
 

Help on Command 

HelpSupport  
 

Email HelpDesk 

HelpWebsite  
 

TriTools Website 

HidLayerMsg  HM  Hidden Layer Message* 

HideLayers  
 

Layer: Hide layer(s) in scripts 

Hilite  HI  Selection Highlight On/Off* 

IPoly  IP  Irregular Polygon 

ImageEdit  
 

Image Edit 

ImportCAD  XIC  Import CADD File 

ImportXML  XIX  Import XML 

IncSnap  IN  Incremental Snap* 
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Native Command   Shortcut     Command Description 

IncSnapOff  
 

Incremental Snap Off 

IncSnapOn  
 

Incremental Snap On 

IncSnapSize  
 

Incremental Snap Size 

InsertOLEObj  
 

Insert OLE Object 

IntTrim  IT  Intersection Trim 

IsoLeft  IL  ISO Left Plane 

IsoMode  IM  ISO Mode On/Off* 

IsoPlane  
 

ISO Plane 

IsoRight  IR  ISO Right Plane 

IsoTop  IO  ISO Top Plane 

Join  JO  Join Objects 

JoinCorner  JC  Join Two Objects at a Corner 

JoinGroup  GJ  Add Objects to a Group 

LTScaleD  
 

Linetype Scale Device 

LTScaleW  
 

Linetype Scale World 

LargeIcons  
 

Toggle toolbar icon size* 

LayAllViews  
 

Layer Apply to All Views 

LayDisplay  YD  Display Layer 

LayHide  YH  Hide Layer 

LayLock  YK  Lock Layer 

LayMgr  MGL  Layer Manager dialog 

LayNoPrint  
 

Non-Print Layer 

LayPrint  
 

Print Layer 

LayPropDlg  PY  Layer Properties Dialog 

LaySelect1  
 

Layer: Select one layer 

LayUnlock  YU  UnLock Layer 

LayerGroup  LG  Layer Group dialog 

LayerGroupCB  
 

Layer Group combo box 

LayerProp  CL  Layer Property 

LdrArrowAng  
 

Leader Arrow Angle 

LdrArrowSize  
 

Leader Arrow Size 

LdrArrowType  
 

Leader Arrow Type+ 

LdrJust  
 

Leader Justify 
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Native Command   Shortcut     Command Description 

LdrLayer  
 

Leader Layer 

LdrOffset  
 

Leader Offset 

LdrShoulder  
 

Leader Shoulder 

LdrTextAsp  
 

Leader Text Aspect 

LdrTextBold  
 

Leader Text Bold* 

LdrTextChSp  
 

Leader Text Character Spacing 

LdrTextFill  
 

Leader Text Fill* 

LdrTextFont  
 

Leader Text Font 

LdrTextHt  
 

Leader Text Height 

LdrTextItal  
 

Leader Text Italic* 

LdrTextLnSp  
 

Leader Text Line Spacing 

LdrTextMono  
 

Leader Text Monospace* 

LdrTextSlant  
 

Leader Text Text Slant 

LdrTextStr  
 

Leader Text String 

LdrTextUnder  
 

Leader Text Underline* 

LdrType  
 

Leader Type 

LdrUseLayer  
 

Leader Use Layer 

LdrVertAlign  
 

Leader Vertical Align 

Leader  LE  Leader 

LeaderCh  
 

Leader Change 

LeaderEdit  
 

Leader Edit 

LeaveGroup  GL  Remove object from Group 

LineCont  LC  Continuous Line 

LineDbl  LD  Double Line 

LineScale  LZ  Line Scale speedbar 

LineSingle  LS  Single Line 

LoadAscii  LA  Load ASCII Text 

LoadLnt  
 

Load LineType file 

LoadMenu  LM  Load Menu 

LoadStyle  TY  Load Style 

LockLayers  
 

Layer: Lock layer(s) in scripts 

MEMode  
 

Manual Entry Mode+ 

MExtend  XM  Extend Multiple 
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MNUPath  
 

Path: MNU 

MRUFileList  
 

List of recently opened files 

MTrim  TM  Trim Multiple 

MTrim1  T1  Trim One 

MainsBar  
 

Main toolbar* 

MatchChange  MG  Match Selected to an Object 

MatchEnt  ME  Match Entity 

MatchTool  MT  Match Tool 

MeasArea  MA  Measure Area 

MeasDist  MD  Measure Distance 

MergePoly  PM  Polygon Merge 

MidLine  ML  MidLine Tool 

Mirror  MI  Mirror 

Move  MV  Move 

MovePt  MP  Move Point 

MulLineStyle  
 

MultiLine Style 

MulSetApply  
 

MultiLine: Apply Settings 

MulSetColor  
 

MultiLine: Set Color 

MulSetGet  
 

MultiLine: Set Line Index 

MulSetLType  
 

MultiLine: Set LineType 

MulSetLWidth  
 

MultiLine: Set LineWidth 

MulSetLayer  
 

MultiLine: Set Layer 

MulSetOffset  
 

MultiLine: Set Offset 

MulSetRealW  
 

MultiLine: Set Real World LineWidth 

MulSetReset  
 

MultiLine: Settings Reset 

MulSetUse  
 

MultiLine: Set Use 

MultiBreak  BM  MultiBreak 

MultiCopy  MC  Multiple Copy 

MultiLine  MN  MultiLine 

MultiSet  MS  MultiLine Settings 

NameView  NV  Name View 

NameViewCB  
 

Named View Combo Box 

NewHandle  NH  New Symbol Handle 
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Native Command   Shortcut     Command Description 

NewView  VW  New View 

NoPrntLayers  
 

Layer: Non-Print layer(s) in scripts 

NumCopies  
 

Number of Copies 

NumDivide  
 

Divide # of segments 

NumRows  
 

Number of Rows 

OLEVerbs  
 

Edit/Open OLE 

ObjChange  OG  Object: Change Properties 

ObjCopy  OC  Object: Copy 

ObjErase  OE  Object: Erase 

ObjInfo  OI  Object Information 

ObjMove  OM  Object: Move 

Offset  OF  Offset 

OffsetDist  
 

Offset Distance 

OffsetFixOff  
 

Fixed Offset Off 

OffsetFixOn  
 

Fixed Offset On 

OleClass  
 

OLE Class 

OleClassName  
 

OLE Class Name 

OleCmdLine  
 

OLE Command Line 

OleDllName  
 

OLE Dll Name 

OleFunName  
 

OLE Function Name 

OleMethod  
 

OLE Method 

OlePropDlg  
 

OLE Properties 

OleToBack  
 

OLE to Background 

OleTranspar  
 

OLE Transparent 

OrAngVar  
 

Ortho Angle Variable 

OrdOffset  
 

Ordinate Text Offset 

OrthoAdv  OV  Ortho Advanced speedbar 

OrthoAdvInc  
 

Ortho Advanced Increment 

OrthoAdvOne  
 

Ortho Advanced One Angle 

OrthoAdvStep  
 

Ortho Advanced Step 

OrthoAdvType  
 

Ortho Advanced Type+ 

OrthoMatch  OT  Match Ortho Angle to an Object 

OrthoMode  OR  Ortho Mode* 
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OrthoOff  
 

Ortho Off 

OrthoOn  
 

Ortho On 

OrthoSet  OA  Ortho Settings speedbar 

PackData  PD  Pack Data 

PasteObject  
 

Paste OLE into drawing 

Penup  PU  Pen Up 

PercSnapVal  
 

Snap Percentage Value 

Persist  PE  Change Next Tool Persistent 

PlaceImage  IG  Image 

Point  PO  Point 

PrintLayers  
 

Layer: Print layer(s) in scripts 

PrintNoDlg  
 

Print without Dialog 

PrintOrgPt  
 

Print Origin (x, y) 

PrintOrigin  
 

Set the Print Origin 

Properties  PP  Properties Button 

ProxFixed  PF  Dimension: Proximity Fixed* 

PrtAddPreset  
 

Print: Add Preset 

PrtAllBlack  
 

Print: All Colors to Black* 

PrtCenter  
 

Print: Centered* 

PrtCurPreset  
 

Print: set Current Preset 

PrtDateStamp  
 

Print: Date Stamp* 

PrtDelPreset  
 

Print: Delete Preset 

PrtDevice  
 

Print: set Printer+ 

PrtFastDraw  
 

Print: Fast Draw* 

PrtLW0HasWid  
 

Print: LW 0 has Width* 

PrtLandscape  
 

Print: Landscape* 

PrtLineWidth  
 

Print: BaseLine Width 

PrtMargBot  
 

Print: Bottom Margin 

PrtMargLeft  
 

Print: Left Margin 

PrtMargRight  
 

Print: Right Margin 

PrtMargTop  
 

Print: Top Margin 

PrtMetric  
 

Print: Metric* 

PrtMovePage  
 

Print: Move Page 
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Native Command   Shortcut     Command Description 

PrtNumCopies  
 

Print: Number of Copies 

PrtOrigin  
 

Print: Origin (X, Y) 

PrtPaperLen  
 

Print: Paper Length 

PrtPaperSize  
 

Print: Paper Size 

PrtPaperWid  
 

Print: Paper Width 

PrtPgHeight  
 

Print: Page Height 

PrtPgWidth  
 

Print: Page Width 

PrtPreview  
 

Print: Preview* 

PrtRotAngle  
 

Print: Rotation Angle 

PrtScale  
 

Print: Scale 

PrtSelected  
 

Print: Selected* 

PrtStampFont  
 

Print: Stamp Font 

PrtStampForm  
 

Print: Stamp Date Format 

PrtStampLoc  
 

Print: Stamp Location 

PrtStampSize  
 

Print: Stamp Font Size 

PrtToFile  
 

Print: Print to file* 

PrtViewType  
 

Print: Type of View 

PurgeLnt  
 

Purge Line Type 

QSearch  QS  Quick Search* 

RFBirdsEye  RFB  Reference Frame: Birdseye 

RFCreate  RFC  Reference Frame: Create 

RFDispBnd  
 

Reference Frame: Display Boundary 

RFEdit  RFE  Reference Frame: Edit 

RFEllBnd  
 

Reference Frame: Elliptical Boundary 

RFLayMgr  RFM  Reference Frame: Layer Manager 

RFPlace  RFP  Reference Frame: Place 

RFSize  RFZ  Reference Frame: Size 

RFTrans  
 

Reference Frame: Transparent 

RFUpdateLink  RFU  Reference Frame: Update link 

RFZoomAll  RFA  Reference Frame: Zoom all 

RFZoomAnchor  RFK  Reference Frame: Anchor 

RFZoomArea  RFW  Reference Frame: Zoom window 

RFZoomIn  RFI  Reference Frame: Zoom in 
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RFZoomOut  RFO  Reference Frame: Zoom out 

RFZoomPan  RFN  Reference Frame: Pan 

RFZoomPrev  RFL  Reference Frame: Zoom previous (last) 

RFZoomScale  RFS  Reference Frame: Zoom scale 

RFZoomView  RFV  Reference Frame: Zoom view 

RPolyCen  PC  Regular Polygon-Center 

RPolyCrcm  
 

Circumscribe Regular Polygon 

RPolyIn  
 

Inscribe Regular Polygon 

RPolyInOn  
 

Regular Polygon Inscribed 

RPolyNSides  
 

Regular Polygon - Number of Sides 

RPolySide  PS  Regular Polygon-Side 

RPolySideVar  
 

Regular Polygon Number of Sides 

RSAll  XSA  Running Snap All* 

RSCenter  XSN  Running Snap Center* 

RSEndPoint  XSC  Running Snap Endpt* 

RSIntersec  XSI  Running Snap Intersection* 

RSMidPoint  XSM  Running Snap Midpt* 

RSObject  XSO  Running Snap Object* 

RSPercent  XSR  Running Snap Percent* 

RSPerpend  XSP  Running Snap Perpendicular* 

RSQuadrant  XSQ  Running Snap Quadrant* 

RSTangent  XST  Running Snap Tangent* 

RadCopies  
 

Number of Radial Copies 

RadCopy  RC  Radial Copy 

RadSpanAngle  
 

Radial Span Angle 

RealWorldLW  
 

Real World LineWidth 

Rect2  R2  Rectangle: 2-Point 

Rect3  R3  Rectangle: 3-Point 

Redo  RE  Redo 

RegEdit  
 

Registry Editor 

Regen  RD  Redraw 

RegenAllView  
 

Redraw All Views 

RegenArea  RW  Redraw Window 
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Native Command   Shortcut     Command Description 

Relative  MR  Manual Entry: Relative 

Reset  
 

Reset 

RestoreSet  
 

Settings: Restore 

Rotate  RO  Rotate 

RubColor  
 

Rubberband Color 

STYPath  
 

Path: STY 

SYSPath  
 

Path: System 

SaveEnv  EN  Save Environment 

SaveSet  
 

Settings: Save 

SaveStyle  TV  Save Style 

Scale  SZ  Scale 

ScriptAssign  AS  Assign Script 

ScrollBar  
 

Scrollbar On/Off* 

SearchTol  
 

Search Tolerance 

SecDash  
 

Second Dimension Show Dash* 

SecDecimal  
 

Second Dimension Angle Decimal Places 

SecFraction  
 

Second Dimension Fractional Value 

SecLeadZero  
 

Second Dimension Show Leading Zeros* 

SecSUFrac  
 

Second Dimension Show Single Unit Fraction* 

SecUnits  
 

Second Dimension Show Units* 

SeedFill  FD  Fill: Seed 

SeedHatch  HD  Hatch: Seed 

SelAdj  SJ  Select Adjoining 

SelAll  SA  Select All 

SelClear  CS  Clear Selection List 

SelColor  
 

Selection Color 

SelCross  SX  Select Crossing 

SelInvert  IS  Invert Selection List 

SelLast  SL  Select Last 

SelLastObj  LO  Select Last Object 

SelLay  SY  Select Layer 

SelMod  SU  Select Modified 

SelObj  SB  Select Object 
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Native Command   Shortcut     Command Description 

SelRibalog  S1  Selection speedbar 

SelWin  SW  Select Window 

Selection  SE  Selection Tool 

SetAngle  
 

Set Rotation Angle 

SetBasePt  BP  Set BasePoint 

SetCfgEdit  
 

Set Configuration Editor 

SetColor  
 

Set Current Color 

SetLayer  
 

Set Current Layer 

SetRealWidth  
 

Set Real World Linewidth 

SetScale  
 

Set Scale X & Y 

SetScaleX  
 

Set Scale X 

SetScaleY  
 

Set Scale Y 

SetType  
 

Set Current Linetype 

SetWidth  
 

Set Pixel Linewidth 

ShiftClick  
 

Shift+RButton Popup* 

ShowDash  
 

Numeric Dimension Show Dash* 

ShowDrag  
 

Show Drag* 

ShowFill  TF  Display Fills* 

ShowHatch  TH  Display Hatches* 

ShowLnType  LT  Display Line Types* 

ShowLnWidth  LW  Display Line Widths* 

ShowPoint  TI  Display Points* 

ShowPrtOrg  
 

Show the Print Origin* 

Skew  KW  Skew 

SkewAngle  
 

Skew Angle 

SnAngle  SV  Snap Angle 

SnAngleVal  
 

Snap Angle Value 

SnCenter  SN  Snap Center 

SnClosestPt  SC  Snap Closest Point 

SnIntersect  SI  Snap Intersection 

SnLastPt  LP  Snap Last Point 

SnMid2Pts  S2  Snap between 2 Points 

SnMidPt  SM  Snap MidPoint 
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Native Command   Shortcut     Command Description 

SnNearPt  NP  Snap Near Point 

SnObject  SO  Snap Object 

SnParOffVal  
 

Snap Parallel Offset Value 

SnPara  LL  Snap Parallel 

SnPercent  SR  Snap Percentage 

SnPerp  SP  Snap Perpendicular 

SnPrev  RV  Snap Preview (Running Snaps)* 

SnQuad  SQ  Snap Quadrant 

SnRun  RS  Running Snap Mode On/Off 

SnTangent  ST  Snap Tangent 

SnType  RN  Running Snaps dialog 

SnapGrid  SG  Snap Grid 

SnapLayer  NL  Snap Layer 

SolidOff  
 

Double Line Fill Off 

SolidOn  
 

Double Line Fill On 

SpellCheck  SK  Check Spelling 

SpellOpt  
 

Spellcheck Options 

SplitPoly  PG  Polygon Split 

StatusBar  
 

Status Bar 

Stretch  SS  Stretch 

SymAutoExp  
 

Symbol Auto Explode on Placement* 

SymCount  
 

Symbol Count 

SymCreate  YC  Create Symbols 

SymExplode  YX  Explode Symbols 

SymExplodeTo  
 

Symbol Autoexplode to layer+ 

SymLast  YL  Last Symbol 

SymMgr  MGY  Symbol Manager 

SymName  
 

Symbol Name 

SymOpen  YO  Load Symbol 

SymPlace  YP  Place Symbol 

SymRemove  YV  Symbol Remove 

SymReplace  YR  Symbol Replace 

SymRot  
 

Symbol Rotation 
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Native Command   Shortcut     Command Description 

SymSave  YS  Save Symbol 

SymScX  
 

Symbol Scale X 

SymScY  
 

Symbol Scale Y 

SymScale  
 

Symbol Scale X & Y 

SymSnap  YN  Symbol Snap* 

SymSnapOff  
 

Symbol Snap Off 

SymSnapOn  
 

Symbol Snap On 

SymUnBreak  YE  Symbol UnBreak 

SymbolBreak  YB  Symbol Break 

TabAdv  TBA  Settings: Advanced 

TabCnstrnt  TBC  Settings: Constraints 

TabDim  TBD  Settings: Dimensions 

TabDimText  TBX  Settings: Dimension Text 

TabFonts  TBF  Settings: Fonts 

TabGeneral  TBG  Settings: General 

TabHatch  TBH  Settings: Hatch & Fill 

TabLdrText  TBE  Settings: Leader Text 

TabLeader  TBL  Settings: Leaders 

TabNumeric  TBN  Settings: Numeric 

TabOptions  TBO  Settings Dialog 

TabPath  TBP  Settings: Paths 

TabSymbols  TBY  Settings: Symbols 

TabSys2  TB2  Settings: System 2 

TabSystem  TBS  Settings: System 1 

TabText  TBT  Settings: Text 

TabTools  TBW  Settings: Tools 

Text  TL  Text Line 

TextAspect  
 

Text Aspect 

TextBold  
 

Text Bold* 

TextCh  
 

Text Change 

TextChSp  
 

Text Character Spacing 

TextCharset  
 

Text Character Set 

TextColor  
 

Text Color 
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Native Command   Shortcut     Command Description 

TextEditor  TE  Text Editor 

TextFill  
 

Text Fill* 

TextFont  
 

Text Font 

TextHeight  
 

Text Height 

TextItalic  
 

Text Italic* 

TextJust  
 

Text Justification 

TextLType  
 

Text LineType 

TextLWidth  
 

Text LineWidth 

TextLay  
 

Text Layer 

TextLnSp  
 

Text Linespacing 

TextMono  
 

Text Mono* 

TextRWidth  
 

Text Real World LineWidth 

TextRot  
 

Text Rotation 

TextSet  TT  Text Settings 

TextSlant  
 

Text Slant 

TextStr  
 

Text String 

TextTabStops  
 

Text Tab Stops 

TextUnderln  
 

Text Underline* 

TextUseLayer  
 

Text Use Layer* 

ToolBar  
 

Tool Bar 

Track  TK  Track 

TrackEnd  
 

Track End 

Trim  TR  Trim, Single 

TypeProp  TP  Linetype Property 

UIOff  
 

User Interface Off 

UIOn  
 

User Interface On 

Undo  OO  Undo 

UndoDim  UD  Undo Dimension 

UndoVertex  UV  Undo Vertex 

Ungroup  GU  Ungroup a group of objects 

UnitCM  
 

Unit of Measure: Centimeters 

UnitFeet  
 

Unit of Measure: Feet 

UnitFrFt  
 

Unit of Measure: Fractional Feet 
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Native Command   Shortcut     Command Description 

UnitFrFtIn  
 

Unit of Measure: Fractional Feet & Inches 

UnitFrIn  
 

Unit of Measure: Fractional Inches 

UnitFtIn  
 

Unit of Measure: Feet & Inches 

UnitInch  
 

Unit of Measure: Inches 

UnitKM  
 

Unit of Measure: Kilometers 

UnitMM  
 

Unit of Measure: Millimeters 

UnitMeter  
 

Unit of Measure: Meters 

UnitMile  
 

Unit of Measure: Miles 

UnlockLayers  
 

Layer: UnLock layer(s) in scripts 

Update  
 

Update Dialog 

UpdateSettin  
 

Auto-check for Updates 

UseFastProp  FP  Use Fast Properties* 

UseFileLock  
 

Use File Locking* 

UseLayProp  BL  Use Layer Properties On/Off* 

UsePrtOrg  
 

Use the Print Origin* 

UseSymClr  
 

Use Placement Color On/Off* 

UseSymClrOff  
 

Edit Symbol Placement Color Off 

UseSymClrOn  
 

Edit Symbol Placement Color On 

UtDimCM  
 

Units: Dimension Centimeters 

UtDimFeet  
 

Units: Dimension Decimal Feet 

UtDimFrFt  
 

Units: Dimension Fractional Feet 

UtDimFrFtIn  
 

Units: Dimension Fractional Feet-Inches 

UtDimFrIn  
 

Units: Dimension Fractional Inches 

UtDimFtIn  
 

Units: Dimension Feet-Inches 

UtDimInch  
 

Units: Dimension Decimal Inches 

UtDimKM  
 

Units: Dimension Kilometers 

UtDimMM  
 

Units: Dimension Millimeters 

UtDimMeter  
 

Units: Dimension Meters 

UtDimMile  
 

Units: Dimension Miles 

UtSecCM  
 

Units: Secondary Centimeters 

UtSecFeet  
 

Units: Secondary Decimal Feet 

UtSecFrFt  
 

Units: Secondary Fractional Feet 

UtSecFrFtIn  
 

Units: Secondary Fractional Feet-Inches 
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Native Command   Shortcut     Command Description 

UtSecFrIn  
 

Units: Secondary Fractional Inches 

UtSecFtIn  
 

Units: Secondary Feet-Inches 

UtSecInch  
 

Units: Secondary Decimal Inches 

UtSecKM  
 

Units: Secondary Kilometers 

UtSecMM  
 

Units: Secondary Millimeters 

UtSecMeter  
 

Units: Secondary Meters 

UtSecMile  
 

Units: Secondary Miles 

VCDPath  
 

Path: VCD 

VCFPath  
 

Path: VCF 

VCSPath  
 

Path: VCS 

WallWidth1  
 

Double Line Offset 1 

WallWidth2  
 

Double Line Offset 2 

WidthProp  WP  Linewidth Property 

WinArrange  
 

Arrange Icons 

WinCascade  
 

Cascade Windows 

WinChange  WG  Window: Change Properties 

WinCopy  WC  Window: Copy Contents 

WinErase  WE  Window: Erase Contents 

WinExec  RUN  Run Windows .EXE file 

WinFill  WF  Window: Fill Selection 

WinHatch  WH  Window: Hatch Selection 

WinHoriz  
 

Window: Horizontal 

WinMove  WM  Window: Move Contents 

WinRotate  WT  Window: Rotate Contents 

WinScale  WZ  Window: Change Scale 

WinStretch  WS  Window Stretch 

WinVert  
 

Window: Vertical 

WizDim  WID  Dimension Wizard 

WizDraw  WIR  Drawing Wizard 

WizProp  WIP  Drawing Properties 

WizText  WIT  Text Wizard 

ZmAll  ZA  Zoom All 

ZmAllView  
 

Zoom All Views 
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Native Command   Shortcut     Command Description 

ZmArea  ZW  Zoom Window 

ZmAutoPan  AA  Zoom AutoPan 

ZmIn  ZI  Zoom In 

ZmOut  ZO  Zoom Out 

ZmPan  PA  Pan 

ZmPrev  ZP  Zoom Previous 

ZmSel  ZS  Zoom Selected 

ZmValue  ZU  Zoom Value 

ZmView  ZN  Zoom View 

ZmViewName  
 

Zoom: text string for a View Name to be used in scripts 

ZoomFactor  
 

Zoom Factor In/Out 
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A P P E N D I X  B  

LINETYPES AND LINEWIDTHS 

Linetypes  

Visual CADD™ ships with 51 default linetypes. You can modify existing linetypes, or 

create new ones, up to a total of 256. See Chapter 13, Customizing Visual CADD™ for 

more details. 

 

Linewidths  

Visual CADD™ provides 16 predefined line widths, based on pixel widths. Note that 

LW 0 and LW 1 both display at one pixel onscreen, although LW 0 will print at the 

smallest width supported by the printer. 
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Visual CADD™ also supports Real World line widths. A Real World line width is actual 

width. You specify the width in real world terms; i.e., .5", 2mm, etc. Because of this, RW 

widths are subject to scaling during printed output and on the screen display depending 

on the zoom level.  For example, a pixel line width will appear the same thickness on the 

screen no matter how much you zoom in and out. But a Real World linewidth of .5" will 

appear larger when you zoom in and smaller when you zoom out. 

To specify a real world linewidth, select the last item in the main toolbar linewidth 

dropdown, and then type a value in the edit box. Or on the speedbar of the Properties and 

Change commands, click the RW button and then type a value in the edit box. 

Real World Linewidth values in the edit box will display with the unit value you have 

currently set on the Enter & Display Unit dropdown of the Numeric Tab dialog. For 

instance, if you type 12" into the linewidth box on the main toolbar but your units are set 

to feet, the value will display as 1'. 
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A P P E N D I X  C  

ENTERING NUMBERS IN VISUAL CADD™ 

In Visual CADD™, you enter numbers to define coordinates, distances, angles, and sizes. 

At any time, you can enter coordinates and distances in another measurement system by 

entering the abbreviation for the system after the number. For example, if your current 

unit of measure is feet and inches, you can enter meters by typing m after the number. 

On the Numeric screen of the Settings dialog, you can set the unit of measurement used 

to enter and display numbers in the status bar and dimension strings. 

Mathematical Expressions  

You can enter mathematical expressions to have Visual CADD™ calculate a value. 

Visual CADD™ evaluates mathematical expressions in the following order: 

 Numbers or sub-expressions enclosed in parentheses 

 Trigonometric or exponential functions 

 Multiplication or division 

 Addition or subtraction 

Operations of equal priority are carried out from left to right. 

Measurement Abbreviations  

Abbreviation Unit 
” inches 
’ feet 
’ ” feet-inches 
mm millimeters 
cm centimeters 
m meters 
km kilometers 
mi miles 
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Formats for Entering Numbers  

Format Distinction 
3’6” No space between the foot mark and inches value 

3’ 6” Space between the foot mark and inches value 

3’6 Inch mark omitted 

3’ 6 1/2” Mixed feet/fractional inches 

3’6.5” Mixed feet/decimal inches 

3.5’ Decimal feet 

3’ 1/2’ Fractional feet 

3.5m No space between number and abbreviation 

3.5 m Space between number and abbreviation 

 

NOTE: Visual CADD™ interprets a hyphen separating feet and inches as a mathematical 

expression.  For example, entering 5’-4" means 5-feet minus 4-inches and results in a 

measurement of 4’ 8". Similarly, it interprets fractions not separated from inches by a 

space as a mathematical expression of division. 

Operators for Mathematical Expressions  

Operator Function 
+ Adds preceding value to following value 

- Subtracts following value from preceding value 

* Multiplies preceding value by following value 

/ Divides preceding value by following value 
$SIN(A) Sine of A 
$COS(A) Cosine of A 
$TAN(A) Tangent of A 
$ASN(A) Arc or inverse sine of A 
$ACS(A) Arc or inverse cosine of A 
$ATN(A) Arc or inverse tangent of A 
$LOG(A) Log (base 10) of A 
$NLN(A) Natural log (base e) of A 
(A)$EXP(B) Exponential, A to the power B 
$SQR(A) Square of A (A to the power 2) 
$SQT(A) Square root of A 
$ABS(A) Absolute value of A 
$PI() Mathematical constant pi 
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Mathematical Expression Examples  

Entry Result 
2*3 6 
2*3-1 5 
6*3-1/4 17.75 
6*(3-1/4) 16.5 
23' 6 1/2" + 9' 4 1/2"*2 42.29166667' or 42' 3 1/2" 
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2-Point Arc tool .............. 51 

2-Point Circle tool .......... 50 

2-Point Rectangle tool .... 49 

3-Point Arc tool .............. 51 

3-Point Circle tool .......... 50 

3-Point Rectangle tool .... 49 
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Align command .............. 93 

Angle Measurement ..... 119 

Angular dimension tool 107 
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Arc tools 
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displaying .................... 140 
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Autopan .......................... 71 
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Backup files .................... 13 

Backward Redraw .......... 84 

Basepoint coordinates .... 16 

Bearings ....................... 151 

Birds-Eye View ...... 72, 159 

BMP file ....................... 201 

Boolean 
intersection .................. 102 

subtraction ................... 102 
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Breaking 
break .............................. 84 

multibreak ..................... 85 

Center Polygon tool........ 50 

Change Command ........ 104 

Circle tools 
2-Point Circle ................ 50 

3-Point Circle ................ 50 

Diameter Circle ............. 50 

Clear Drawing ................ 83 

Closing a drawing .......... 12 

Color 
background .................... 21 

selection ........................ 21 

Combining objects ....... 101 

Complex Curve tools...... 51 

Configuration Editor .... 167 

Constraining 
Lines .............................. 59 

Objects .......................... 59 

Constraining Snaps ........ 64 

Constraint dialog ............ 58 

Construction points ........ 52 

Context-sensitive help ...... 5 

Continuous Bezier tool ...51 

Continuous Line tool ......46 

Control points .................52 

Coordinate system ..........15 

Coordinates 
absolute ......................... 16 

basepoint ....................... 16 
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Copy OLE objects ........181 

Copying 
Array Copy .................... 98 

between applications ... 181 

between drawings ........ 180 

importing text .............. 182 

Linear Copy ................... 97 

Mirror Copy .................. 98 

Multiple Copy ............... 97 

Radial Copy ............. 98, 99 

Single Copy ................... 97 

Creating export files .....185 

Creating symbols ..........138 

Cumulative Dimensions106 

Cursor Free .....................59 

Cursor size ......................19 

Curve 
changing the shape of a . 53 

Custom Commands ......164 

Customer Service .............7 

Customizing 
an overview ................. 161 

Configuration Editor ... 167 

custom commands ....... 164 

hatch patterns .............. 174 

keyboard shortcuts....... 166 

menus .......................... 167 

new line types .............. 177 

right-click menus ......... 170 

toolbars ........................ 172 
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Datum Dimension tool . 108 

Default settings .............. 18 

Default Tool ................... 21 

Deleting entities ............. 83 

Deselecting objects ........ 77 

Diameter Circle tool ....... 50 

Diameter Dimension tool107 

Digitizer 
align drawing .............. 158 

scale............................. 159 

tablet mode .................. 158 

Digitizing a drawing .... 158 

Dimension text settings 113 

Dimension tools 
angular dimension ....... 107 

datum dimension ......... 108 

diameter dimension ..... 107 

linear dimension .......... 106 

multiple dimension ...... 108 

ordinate dimension ...... 108 

radial dimension .......... 107 

Dimensions 
adjusting settings ......... 110 

cumulative ................... 106 

editing ......................... 109 

modifying .................... 109 

moving a dimension arc

................................. 110 

moving a dimension line

................................. 110 

moving dimension text 109 

partitioned ................... 106 

sliding dimension text . 109 

Direct plotting .............. 202 

Direct-Distance entry ..... 45 

Distance Measurement . 119 

Divide tool ................... 101 

Documentation 
online help ....................... 5 

Users Guide ..................... 4 

Double Line tool ............ 47 

setting the offset ............ 47 

Draw Order Commands103 

Drawing 
a parallel line ................. 65 

a perpendicular line ....... 65 

a tangent line ................. 65 

by placing points ........... 45 

close .............................. 13 

leaders ......................... 116 

objects, overview .......... 44 

opening existing ............ 13 

save as new file ............. 13 

starting a new ................ 13 

using a grid .................... 61 

using direct-distance entry

 ................................... 45 

using Ortho mode .......... 57 

using polar coordinates . 45 

using snaps .................... 62 

version control ............... 13 

when to use line tools .... 46 

with precision ................ 57 

with straight line tools ... 46 

Drawing tools 
2-Point Arc .................... 51 

2-Point Circle ................ 50 

2-Point Rectangle .......... 49 

3-Point Arc .................... 51 

3-Point Circle ................ 50 

3-Point Rectangle .......... 49 

arc tools ......................... 51 

Center Polygon .............. 50 

circle tools ..................... 50 

complex curve tools ...... 51 

Continuous Bezier Curve

 ................................... 51 
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Double Line ................... 47 
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straight line tools ........... 46 
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Editing 
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Elliptical Arc tool ...........51 
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Embedding Objects ......183 
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Environment Save ..........23 
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Exit Visual CADD .........13 

Explode Continuous Lines21 

Exploding objects ...........95 

Export files 
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mathematical ............... 237 

Extend commands 
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Extend Single ................ 86 
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Fast Properties ................54 

File formats ..................185 
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Files 
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Fill Settings .................. 143 

Fillet 
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Fit Scale ......................... 91 

Flipping a symbol ........ 136 
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Generic CADD ............ 132 
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Generic CADD 
font mapping ............... 191 
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